Upstream information

CVE-2023-4512 at MITRE

Description

CBOR dissector crash in Wireshark 4.0.0 to 4.0.6 allows denial of service via packet injection or crafted capture file

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 5.3
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1214561 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP1-SAP-Azure-LI-BYOS-Production
Image SLES15-SP1-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP5-SAP-Azure-LI-BYOS
Image SLES15-SP5-SAP-Azure-LI-BYOS-Production
Image SLES15-SP5-SAP-Azure-VLI-BYOS
Image SLES15-SP5-SAP-Azure-VLI-BYOS-Production
  • libwireshark15 >= 3.6.16-150000.3.100.1
  • libwiretap12 >= 3.6.16-150000.3.100.1
  • libwsutil13 >= 3.6.16-150000.3.100.1
  • wireshark >= 3.6.16-150000.3.100.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libwireshark15 >= 3.6.16-150000.3.100.1
  • libwiretap12 >= 3.6.16-150000.3.100.1
  • libwsutil13 >= 3.6.16-150000.3.100.1
  • wireshark >= 3.6.16-150000.3.100.1
  • wireshark-devel >= 3.6.16-150000.3.100.1
  • wireshark-ui-qt >= 3.6.16-150000.3.100.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-3778
SUSE-SLE-Module-Desktop-Applications-15-SP4-2023-3778
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • libwireshark15 >= 3.6.16-150000.3.100.1
  • libwiretap12 >= 3.6.16-150000.3.100.1
  • libwsutil13 >= 3.6.16-150000.3.100.1
  • wireshark >= 3.6.16-150000.3.100.1
  • wireshark-devel >= 3.6.16-150000.3.100.1
  • wireshark-ui-qt >= 3.6.16-150000.3.100.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2023-3778
SUSE-SLE-Module-Desktop-Applications-15-SP5-2023-3778
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libwireshark15 >= 3.6.16-150000.3.100.1
  • libwiretap12 >= 3.6.16-150000.3.100.1
  • libwsutil13 >= 3.6.16-150000.3.100.1
  • wireshark >= 3.6.16-150000.3.100.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-3778
SUSE Linux Enterprise Module for Basesystem 15 SP5
  • libwireshark15 >= 3.6.16-150000.3.100.1
  • libwiretap12 >= 3.6.16-150000.3.100.1
  • libwsutil13 >= 3.6.16-150000.3.100.1
  • wireshark >= 3.6.16-150000.3.100.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2023-3778
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • wireshark-devel >= 3.6.16-150000.3.100.1
  • wireshark-ui-qt >= 3.6.16-150000.3.100.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP4-2023-3778
SUSE Linux Enterprise Module for Desktop Applications 15 SP5
  • wireshark-devel >= 3.6.16-150000.3.100.1
  • wireshark-ui-qt >= 3.6.16-150000.3.100.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP5-2023-3778
SUSE Manager Proxy 4.2
  • libwireshark15 >= 3.6.16-150000.3.100.1
  • libwiretap12 >= 3.6.16-150000.3.100.1
  • libwsutil13 >= 3.6.16-150000.3.100.1
  • wireshark >= 3.6.16-150000.3.100.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.2-2023-3778
SUSE Manager Retail Branch Server 4.2
  • libwireshark15 >= 3.6.16-150000.3.100.1
  • libwiretap12 >= 3.6.16-150000.3.100.1
  • libwsutil13 >= 3.6.16-150000.3.100.1
  • wireshark >= 3.6.16-150000.3.100.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.2-2023-3778
SUSE Manager Server 4.2
  • libwireshark15 >= 3.6.16-150000.3.100.1
  • libwiretap12 >= 3.6.16-150000.3.100.1
  • libwsutil13 >= 3.6.16-150000.3.100.1
  • wireshark >= 3.6.16-150000.3.100.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.2-2023-3778
openSUSE Leap 15.4
  • libwireshark15 >= 3.6.16-150000.3.100.1
  • libwiretap12 >= 3.6.16-150000.3.100.1
  • libwsutil13 >= 3.6.16-150000.3.100.1
  • wireshark >= 3.6.16-150000.3.100.1
  • wireshark-devel >= 3.6.16-150000.3.100.1
  • wireshark-ui-qt >= 3.6.16-150000.3.100.1
Patchnames:
openSUSE-SLE-15.4-2023-3778
openSUSE Leap 15.5
  • libwireshark15 >= 3.6.16-150000.3.100.1
  • libwiretap12 >= 3.6.16-150000.3.100.1
  • libwsutil13 >= 3.6.16-150000.3.100.1
  • wireshark >= 3.6.16-150000.3.100.1
  • wireshark-devel >= 3.6.16-150000.3.100.1
  • wireshark-ui-qt >= 3.6.16-150000.3.100.1
Patchnames:
openSUSE-SLE-15.5-2023-3778
openSUSE Tumbleweed
  • libwireshark16 >= 4.0.8-2.1
  • libwiretap13 >= 4.0.8-2.1
  • libwsutil14 >= 4.0.8-2.1
  • wireshark >= 4.0.8-2.1
  • wireshark-devel >= 4.0.8-2.1
  • wireshark-ui-qt >= 4.0.8-2.1
Patchnames:
openSUSE Tumbleweed GA libwireshark16-4.0.8-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 wireshark Affected
SUSE Linux Enterprise Desktop 15 SP5 wireshark Released
SUSE Linux Enterprise High Performance Computing 12 SP5 wireshark Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP5 wireshark Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 wireshark Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 wireshark Released
SUSE Linux Enterprise Real Time 15 SP3 wireshark Affected
SUSE Linux Enterprise Server 12 SP5 wireshark Unsupported
SUSE Linux Enterprise Server 12-LTSS wireshark Unsupported
SUSE Linux Enterprise Server 15 SP5 wireshark Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 wireshark Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP4 wireshark Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 wireshark Released
SUSE Linux Enterprise Software Development Kit 12 SP5 wireshark Unsupported
SUSE Manager Proxy 4.3 wireshark Released
SUSE Manager Retail Branch Server 4.3 wireshark Released
SUSE Manager Server 4.3 wireshark Released
openSUSE Leap 15.5 wireshark Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 wireshark Released
SUSE Linux Enterprise High Performance Computing 15 wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 wireshark Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS wireshark Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS wireshark Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS wireshark Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS wireshark Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 wireshark Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 wireshark Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 wireshark Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 wireshark Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 wireshark Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 wireshark Released
SUSE Linux Enterprise Server 15 SP2 wireshark Affected
SUSE Linux Enterprise Server 15 SP2-LTSS wireshark Affected
SUSE Linux Enterprise Server 15 SP3 wireshark Affected
SUSE Linux Enterprise Server 15 SP3-LTSS wireshark Affected
SUSE Linux Enterprise Server 15 SP4 wireshark Released
SUSE Linux Enterprise Server 15 SP4-LTSS wireshark Affected
SUSE Linux Enterprise Server for SAP Applications 15 wireshark Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 wireshark Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 wireshark Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 wireshark Affected
SUSE OpenStack Cloud 8 wireshark Unsupported
SUSE OpenStack Cloud 9 wireshark Unsupported
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 wireshark Unsupported
SUSE CaaS Platform 4.0 wireshark Affected
SUSE Enterprise Storage 6 wireshark Affected
SUSE Enterprise Storage 7 wireshark Affected
SUSE Linux Enterprise Desktop 11 SP4 wireshark Unsupported
SUSE Linux Enterprise Desktop 12 wireshark Unsupported
SUSE Linux Enterprise Desktop 12 SP1 wireshark Unsupported
SUSE Linux Enterprise Desktop 12 SP2 wireshark Unsupported
SUSE Linux Enterprise Desktop 12 SP3 wireshark Unsupported
SUSE Linux Enterprise Desktop 12 SP4 wireshark Unsupported
SUSE Linux Enterprise Desktop 15 wireshark Affected
SUSE Linux Enterprise Desktop 15 SP1 wireshark Affected
SUSE Linux Enterprise Desktop 15 SP2 wireshark Affected
SUSE Linux Enterprise Desktop 15 SP3 wireshark Affected
SUSE Linux Enterprise Module for Basesystem 15 wireshark Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 wireshark Affected
SUSE Linux Enterprise Module for Desktop Applications 15 wireshark Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 wireshark Affected
SUSE Linux Enterprise Real Time 15 SP2 wireshark Affected
SUSE Linux Enterprise Real Time 15 SP4 wireshark Affected
SUSE Linux Enterprise Server 11 SP3 wireshark Unsupported
SUSE Linux Enterprise Server 11 SP3-LTSS wireshark Unsupported
SUSE Linux Enterprise Server 11 SP4 wireshark Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS wireshark Unsupported
SUSE Linux Enterprise Server 11 SP4-LTSS wireshark Unsupported
SUSE Linux Enterprise Server 12 wireshark Unsupported
SUSE Linux Enterprise Server 12 SP1 wireshark Unsupported
SUSE Linux Enterprise Server 12 SP1-LTSS wireshark Unsupported
SUSE Linux Enterprise Server 12 SP2 wireshark Unsupported
SUSE Linux Enterprise Server 12 SP2-BCL wireshark Unsupported
SUSE Linux Enterprise Server 12 SP2-ESPOS wireshark Unsupported
SUSE Linux Enterprise Server 12 SP2-LTSS wireshark Unsupported
SUSE Linux Enterprise Server 12 SP3 wireshark Unsupported
SUSE Linux Enterprise Server 12 SP3-BCL wireshark Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS wireshark Unsupported
SUSE Linux Enterprise Server 12 SP3-LTSS wireshark Unsupported
SUSE Linux Enterprise Server 12 SP4 wireshark Unsupported
SUSE Linux Enterprise Server 12 SP4-ESPOS wireshark Unsupported
SUSE Linux Enterprise Server 12 SP4-LTSS wireshark Unsupported
SUSE Linux Enterprise Server 15 wireshark Affected
SUSE Linux Enterprise Server 15 SP1 wireshark Affected
SUSE Linux Enterprise Server 15 SP1-BCL wireshark Affected
SUSE Linux Enterprise Server 15 SP1-LTSS wireshark Affected
SUSE Linux Enterprise Server 15 SP2-BCL wireshark Affected
SUSE Linux Enterprise Server 15 SP3-BCL wireshark Affected
SUSE Linux Enterprise Server 15-LTSS wireshark Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 wireshark Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP4 wireshark Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 wireshark Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP1 wireshark Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 wireshark Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 wireshark Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 wireshark Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP4 wireshark Unsupported
SUSE Linux Enterprise Software Development Kit 12 wireshark Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP1 wireshark Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 wireshark Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 wireshark Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP4 wireshark Unsupported
SUSE Manager Proxy 4.0 wireshark Affected
SUSE Manager Proxy 4.1 wireshark Affected
SUSE Manager Proxy 4.2 wireshark Released
SUSE Manager Retail Branch Server 4.0 wireshark Affected
SUSE Manager Retail Branch Server 4.1 wireshark Affected
SUSE Manager Retail Branch Server 4.2 wireshark Released
SUSE Manager Server 4.0 wireshark Affected
SUSE Manager Server 4.1 wireshark Affected
SUSE Manager Server 4.2 wireshark Released
SUSE OpenStack Cloud 7 wireshark Unsupported
SUSE OpenStack Cloud Crowbar 8 wireshark Unsupported
SUSE OpenStack Cloud Crowbar 9 wireshark Unsupported
openSUSE Leap 15.4 wireshark Released


SUSE Timeline for this CVE

CVE page created: Thu Aug 24 10:03:23 2023
CVE page last modified: Fri Apr 19 19:14:31 2024