Upstream information

CVE-2023-43655 at MITRE

Description

Composer is a dependency manager for PHP. Users publishing a composer.phar to a public web-accessible server where the composer.phar can be executed as a php file may be subject to a remote code execution vulnerability if PHP also has `register_argc_argv` enabled in php.ini. Versions 2.6.4, 2.2.22 and 1.10.27 patch this vulnerability. Users are advised to upgrade. Users unable to upgrade should make sure `register_argc_argv` is disabled in php.ini, and avoid publishing composer.phar to the web as this is not best practice.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 6.4
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required Low High
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1215859 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/php-apache:8-8.9
Container bci/php-fpm:8-8.10
Container bci/php:8-8.8
  • php-composer2 >= 2.2.3-150400.3.6.1
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Web and Scripting 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • php-composer2 >= 2.2.3-150400.3.6.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP4-2023-4041
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Web and Scripting 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • php-composer2 >= 2.2.3-150400.3.6.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP5-2023-4041
openSUSE Leap 15.4
  • php-composer2 >= 2.2.3-150400.3.6.1
Patchnames:
openSUSE-SLE-15.4-2023-4041
openSUSE Leap 15.5
  • php-composer2 >= 2.2.3-150400.3.6.1
Patchnames:
openSUSE-SLE-15.5-2023-4041
openSUSE Tumbleweed
  • php-composer2 >= 2.6.4-1.1
Patchnames:
openSUSE Tumbleweed GA php-composer2-2.6.4-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP5 php-composer2 Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP5 php-composer2 Released
SUSE Linux Enterprise Server 15 SP5 php-composer2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 php-composer2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 php-composer2 Released
SUSE Manager Proxy 4.3 php-composer2 Released
SUSE Manager Retail Branch Server 4.3 php-composer2 Released
SUSE Manager Server 4.3 php-composer2 Released
openSUSE Leap 15.5 php-composer2 Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP4 php-composer2 Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS php-composer2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS php-composer2 Affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP4 php-composer2 Released
SUSE Linux Enterprise Server 15 SP4 php-composer2 Released
SUSE Linux Enterprise Server 15 SP4-LTSS php-composer2 Affected
Products past their end of life and not receiving proactive updates anymore.
openSUSE Leap 15.4 php-composer2 Released
Container Status
bci/php-apache:8
bci/php-fpm:8
bci/php:8
php-composer2Released


SUSE Timeline for this CVE

CVE page created: Sat Sep 30 00:00:07 2023
CVE page last modified: Wed Mar 27 21:40:28 2024