Upstream information

CVE-2023-42795 at MITRE

Description

Incomplete Cleanup vulnerability in Apache Tomcat.When recycling various internal objects in Apache Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.80 and from 8.5.0 through 8.5.93, an error could cause Tomcat to skip some parts of the recycling process leading to information leaking from the current request/response to the next. Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fixes the issue.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1

Note from the SUSE Security Team

This problem was fixed with Apache Tomcat version 9.0.81, but not referenced in the changelog file, as the CVEs were assigned at a later date.
See: Apache Tomcat 9.0.81 Security Advisory

SUSE Bugzilla entry: 1216119 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/manager/5.0/x86_64/server:latest
Image SLES15-SP4-Manager-Server-4-3
Image SLES15-SP4-Manager-Server-4-3-Azure-llc
Image SLES15-SP4-Manager-Server-4-3-Azure-ltd
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-Azure
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Server-4-3-BYOS-GCE
Image SLES15-SP4-Manager-Server-4-3-EC2-llc
Image SLES15-SP4-Manager-Server-4-3-EC2-ltd
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
SUSE CaaS Platform 4.0
  • tomcat >= 9.0.36-150100.4.98.1
  • tomcat-admin-webapps >= 9.0.36-150100.4.98.1
  • tomcat-el-3_0-api >= 9.0.36-150100.4.98.1
  • tomcat-jsp-2_3-api >= 9.0.36-150100.4.98.1
  • tomcat-lib >= 9.0.36-150100.4.98.1
  • tomcat-servlet-4_0-api >= 9.0.36-150100.4.98.1
  • tomcat-webapps >= 9.0.36-150100.4.98.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2023-4423
SUSE Enterprise Storage 7.1
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-Storage-7.1-2024-472
SUSE Liberty Linux 9
  • tomcat >= 9.0.62-37.el9_3.1
  • tomcat-admin-webapps >= 9.0.62-37.el9_3.1
  • tomcat-docs-webapp >= 9.0.62-37.el9_3.1
  • tomcat-el-3.0-api >= 9.0.62-37.el9_3.1
  • tomcat-jsp-2.3-api >= 9.0.62-37.el9_3.1
  • tomcat-lib >= 9.0.62-37.el9_3.1
  • tomcat-servlet-4.0-api >= 9.0.62-37.el9_3.1
  • tomcat-webapps >= 9.0.62-37.el9_3.1
Patchnames:
RHSA-2024:0474
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • tomcat >= 9.0.36-150100.4.98.1
  • tomcat-admin-webapps >= 9.0.36-150100.4.98.1
  • tomcat-el-3_0-api >= 9.0.36-150100.4.98.1
  • tomcat-jsp-2_3-api >= 9.0.36-150100.4.98.1
  • tomcat-lib >= 9.0.36-150100.4.98.1
  • tomcat-servlet-4_0-api >= 9.0.36-150100.4.98.1
  • tomcat-webapps >= 9.0.36-150100.4.98.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2023-4423
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2024-472
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP3-LTSS-2024-472
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP4-ESPOS-2024-472
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP4-LTSS-2024-472
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Web and Scripting 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP5-2024-472
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • tomcat >= 9.0.36-3.111.1
  • tomcat-admin-webapps >= 9.0.36-3.111.1
  • tomcat-docs-webapp >= 9.0.36-3.111.1
  • tomcat-el-3_0-api >= 9.0.36-3.111.1
  • tomcat-javadoc >= 9.0.36-3.111.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.111.1
  • tomcat-lib >= 9.0.36-3.111.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.111.1
  • tomcat-webapps >= 9.0.36-3.111.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2023-4337
SUSE Linux Enterprise Server 15 SP1-LTSS
  • tomcat >= 9.0.36-150100.4.98.1
  • tomcat-admin-webapps >= 9.0.36-150100.4.98.1
  • tomcat-el-3_0-api >= 9.0.36-150100.4.98.1
  • tomcat-jsp-2_3-api >= 9.0.36-150100.4.98.1
  • tomcat-lib >= 9.0.36-150100.4.98.1
  • tomcat-servlet-4_0-api >= 9.0.36-150100.4.98.1
  • tomcat-webapps >= 9.0.36-150100.4.98.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2023-4423
SUSE Linux Enterprise Server 15 SP2-LTSS
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2024-472
SUSE Linux Enterprise Server 15 SP3-LTSS
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP3-LTSS-2024-472
SUSE Linux Enterprise Server 15 SP4-LTSS
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP4-LTSS-2024-472
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • tomcat >= 9.0.36-150100.4.98.1
  • tomcat-admin-webapps >= 9.0.36-150100.4.98.1
  • tomcat-el-3_0-api >= 9.0.36-150100.4.98.1
  • tomcat-jsp-2_3-api >= 9.0.36-150100.4.98.1
  • tomcat-lib >= 9.0.36-150100.4.98.1
  • tomcat-servlet-4_0-api >= 9.0.36-150100.4.98.1
  • tomcat-webapps >= 9.0.36-150100.4.98.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2023-4423
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2024-472
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP3-2024-472
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP4-2024-472
SUSE Manager Server 4.3
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.3-2024-472
openSUSE Leap 15.5
  • tomcat >= 9.0.85-150200.57.1
  • tomcat-admin-webapps >= 9.0.85-150200.57.1
  • tomcat-docs-webapp >= 9.0.85-150200.57.1
  • tomcat-el-3_0-api >= 9.0.85-150200.57.1
  • tomcat-embed >= 9.0.85-150200.57.1
  • tomcat-javadoc >= 9.0.85-150200.57.1
  • tomcat-jsp-2_3-api >= 9.0.85-150200.57.1
  • tomcat-jsvc >= 9.0.85-150200.57.1
  • tomcat-lib >= 9.0.85-150200.57.1
  • tomcat-servlet-4_0-api >= 9.0.85-150200.57.1
  • tomcat-webapps >= 9.0.85-150200.57.1
Patchnames:
openSUSE-SLE-15.5-2024-472
openSUSE Tumbleweed
  • tomcat >= 9.0.82-2.1
  • tomcat-admin-webapps >= 9.0.82-2.1
  • tomcat-docs-webapp >= 9.0.82-2.1
  • tomcat-el-3_0-api >= 9.0.82-2.1
  • tomcat-embed >= 9.0.82-2.1
  • tomcat-javadoc >= 9.0.82-2.1
  • tomcat-jsp-2_3-api >= 9.0.82-2.1
  • tomcat-jsvc >= 9.0.82-2.1
  • tomcat-lib >= 9.0.82-2.1
  • tomcat-servlet-4_0-api >= 9.0.82-2.1
  • tomcat-webapps >= 9.0.82-2.1
Patchnames:
openSUSE Tumbleweed GA tomcat-9.0.82-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 tomcat Released
SUSE Linux Enterprise High Performance Computing 12 SP5 tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP5 tomcat Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP5 tomcat Released
SUSE Linux Enterprise Server 12 SP5 tomcat Released
SUSE Linux Enterprise Server 15 SP5 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 tomcat Released
SUSE Manager Proxy 4.3 tomcat Released
SUSE Manager Retail Branch Server 4.3 tomcat Released
SUSE Manager Server 4.3 tomcat Released
openSUSE Leap 15.5 tomcat Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 tomcat Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 tomcat Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS tomcat Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP2 tomcat Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS tomcat Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP3 tomcat Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP4 tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS tomcat Released
SUSE Linux Enterprise High Performance Computing 15-ESPOS tomcat Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS tomcat Affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 tomcat Affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 tomcat Affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP4 tomcat Released
SUSE Linux Enterprise Server 12 SP2-BCL tomcat Affected
SUSE Linux Enterprise Server 15 SP2 tomcat Affected
SUSE Linux Enterprise Server 15 SP2-LTSS tomcat Released
SUSE Linux Enterprise Server 15 SP3 tomcat Affected
SUSE Linux Enterprise Server 15 SP3-LTSS tomcat Released
SUSE Linux Enterprise Server 15 SP4 tomcat Released
SUSE Linux Enterprise Server 15 SP4-LTSS tomcat Released
SUSE Linux Enterprise Server for SAP Applications 15 tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 tomcat Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 tomcat Affected
SUSE CaaS Platform 4.0 tomcat Released
SUSE Enterprise Storage 6 tomcat Affected
SUSE Enterprise Storage 7 tomcat Affected
SUSE Linux Enterprise Module for Web and Scripting 15 tomcat Affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP1 tomcat Affected
SUSE Linux Enterprise Server 11 SP3 tomcat6 Affected
SUSE Linux Enterprise Server 11 SP3-LTSS tomcat6 Affected
SUSE Linux Enterprise Server 11 SP4 tomcat6 Affected
SUSE Linux Enterprise Server 11 SP4 LTSS tomcat6 Affected
SUSE Linux Enterprise Server 11 SP4-LTSS tomcat6 Affected
SUSE Linux Enterprise Server 12 SP2 tomcat Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS tomcat Affected
SUSE Linux Enterprise Server 12 SP2-LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP3 tomcat Affected
SUSE Linux Enterprise Server 12 SP3-BCL tomcat Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS tomcat Affected
SUSE Linux Enterprise Server 12 SP3-LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP4 tomcat Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS tomcat Affected
SUSE Linux Enterprise Server 12 SP4-LTSS tomcat Affected
SUSE Linux Enterprise Server 15 tomcat Affected
SUSE Linux Enterprise Server 15 SP1 tomcat Affected
SUSE Linux Enterprise Server 15 SP1-BCL tomcat Affected
SUSE Linux Enterprise Server 15 SP1-LTSS tomcat Released
SUSE Linux Enterprise Server 15 SP2-BCL tomcat Affected
SUSE Linux Enterprise Server 15 SP3-BCL tomcat Affected
SUSE Linux Enterprise Server 15-LTSS tomcat Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 tomcat Affected
SUSE Manager Proxy 4.0 tomcat Affected
SUSE Manager Proxy 4.1 tomcat Affected
SUSE Manager Proxy 4.2 tomcat Affected
SUSE Manager Retail Branch Server 4.0 tomcat Affected
SUSE Manager Retail Branch Server 4.1 tomcat Affected
SUSE Manager Retail Branch Server 4.2 tomcat Affected
SUSE Manager Server 4.0 tomcat Affected
SUSE Manager Server 4.1 tomcat Affected
SUSE Manager Server 4.2 tomcat Released
SUSE OpenStack Cloud 7 tomcat Affected
SUSE OpenStack Cloud 8 tomcat Affected
SUSE OpenStack Cloud 9 tomcat Affected
SUSE OpenStack Cloud Crowbar 8 tomcat Affected
SUSE OpenStack Cloud Crowbar 9 tomcat Affected
Container Status
suse/manager/5.0/x86_64/server tomcatReleased


SUSE Timeline for this CVE

CVE page created: Tue Oct 10 22:00:02 2023
CVE page last modified: Tue Mar 19 16:40:03 2024