Upstream information

CVE-2023-41915 at MITRE

Description

OpenPMIx PMIx before 4.2.6 and 5.0.x before 5.0.1 allows attackers to obtain ownership of arbitrary files via a race condition during execution of library code with UID 0.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 6.3
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Attack Vector Network Local
Attack Complexity High Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1215190 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP5-HPC-Azure
Image SLES15-SP5-HPC-BYOS-Azure
Image SLES15-SP5-HPC-BYOS-EC2
Image SLES15-SP5-HPC-BYOS-GCE
  • libmca_common_dstore1 >= 3.2.3-150300.3.8.1
  • libpmix2 >= 3.2.3-150300.3.8.1
  • pmix-plugins >= 3.2.3-150300.3.8.1
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for HPC 15 SP4
  • libmca_common_dstore1 >= 3.2.3-150300.3.8.1
  • libpmix2 >= 3.2.3-150300.3.8.1
  • pmix >= 3.2.3-150300.3.8.1
  • pmix-devel >= 3.2.3-150300.3.8.1
  • pmix-headers >= 3.2.3-150300.3.8.1
  • pmix-mca-params >= 3.2.3-150300.3.8.1
  • pmix-plugin-munge >= 3.2.3-150300.3.8.1
  • pmix-plugins >= 3.2.3-150300.3.8.1
  • pmix-test >= 3.2.3-150300.3.8.1
Patchnames:
SUSE-SLE-Module-HPC-15-SP4-2023-3859
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for HPC 15 SP5
  • libmca_common_dstore1 >= 3.2.3-150300.3.8.1
  • libpmix2 >= 3.2.3-150300.3.8.1
  • pmix >= 3.2.3-150300.3.8.1
  • pmix-devel >= 3.2.3-150300.3.8.1
  • pmix-headers >= 3.2.3-150300.3.8.1
  • pmix-mca-params >= 3.2.3-150300.3.8.1
  • pmix-plugin-munge >= 3.2.3-150300.3.8.1
  • pmix-plugins >= 3.2.3-150300.3.8.1
  • pmix-test >= 3.2.3-150300.3.8.1
Patchnames:
SUSE-SLE-Module-HPC-15-SP5-2023-3859
SUSE Linux Enterprise High Performance Computing 15 SP6
SUSE Linux Enterprise Module for HPC 15 SP6
  • libmca_common_dstore1 >= 3.2.3-150300.3.8.1
  • libpmix2 >= 3.2.3-150300.3.8.1
  • pmix >= 3.2.3-150300.3.8.1
  • pmix-devel >= 3.2.3-150300.3.8.1
  • pmix-headers >= 3.2.3-150300.3.8.1
  • pmix-mca-params >= 3.2.3-150300.3.8.1
  • pmix-plugin-munge >= 3.2.3-150300.3.8.1
  • pmix-plugins >= 3.2.3-150300.3.8.1
  • pmix-test >= 3.2.3-150300.3.8.1
Patchnames:
SUSE Linux Enterprise Module for HPC 15 SP6 GA pmix-3.2.3-150300.3.8.1
openSUSE Leap 15.4
  • libmca_common_dstore1 >= 3.2.3-150300.3.8.1
  • libpmix2 >= 3.2.3-150300.3.8.1
  • pmix >= 3.2.3-150300.3.8.1
  • pmix-devel >= 3.2.3-150300.3.8.1
  • pmix-headers >= 3.2.3-150300.3.8.1
  • pmix-mca-params >= 3.2.3-150300.3.8.1
  • pmix-plugin-munge >= 3.2.3-150300.3.8.1
  • pmix-plugins >= 3.2.3-150300.3.8.1
  • pmix-test >= 3.2.3-150300.3.8.1
Patchnames:
openSUSE-SLE-15.4-2023-3859
openSUSE Leap 15.5
  • libmca_common_dstore1 >= 3.2.3-150300.3.8.1
  • libpmix2 >= 3.2.3-150300.3.8.1
  • pmix >= 3.2.3-150300.3.8.1
  • pmix-devel >= 3.2.3-150300.3.8.1
  • pmix-headers >= 3.2.3-150300.3.8.1
  • pmix-mca-params >= 3.2.3-150300.3.8.1
  • pmix-plugin-munge >= 3.2.3-150300.3.8.1
  • pmix-plugins >= 3.2.3-150300.3.8.1
  • pmix-test >= 3.2.3-150300.3.8.1
Patchnames:
openSUSE-SLE-15.5-2023-3859
openSUSE Tumbleweed
  • libmca_common_dstore1 >= 3.2.3-11.1
  • libpmix2 >= 3.2.3-11.1
  • pmix >= 3.2.3-11.1
  • pmix-devel >= 3.2.3-11.1
  • pmix-headers >= 3.2.3-11.1
  • pmix-mca-params >= 3.2.3-11.1
  • pmix-plugin-munge >= 3.2.3-11.1
  • pmix-plugins >= 3.2.3-11.1
  • pmix-test >= 3.2.3-11.1
Patchnames:
openSUSE-Tumbleweed-2024-13223


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP5 pmix Released
SUSE Linux Enterprise High Performance Computing 15 SP6 pmix Released
SUSE Linux Enterprise Module for HPC 15 SP5 pmix Released
SUSE Linux Enterprise Module for HPC 15 SP6 pmix Released
SUSE Linux Enterprise Module for Package Hub 15 SP5 pmix Affected
SUSE Linux Enterprise Module for Package Hub 15 SP6 pmix Affected
openSUSE Leap 15.5 pmix Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 pmix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS pmix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS pmix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 pmix Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS pmix Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS pmix Released
SUSE Linux Enterprise High Performance Computing 15 SP4 pmix Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS pmix Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS pmix Affected
SUSE Linux Enterprise Module for HPC 15 SP2 pmix Unsupported
SUSE Linux Enterprise Module for HPC 15 SP3 pmix Affected
SUSE Linux Enterprise Module for HPC 15 SP4 pmix Released
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise High Performance Computing 15 SP1 pmix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS pmix Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS pmix Unsupported
SUSE Linux Enterprise Module for HPC 15 SP1 pmix Unsupported
openSUSE Leap 15.3 pmix Released
openSUSE Leap 15.4 pmix Released


SUSE Timeline for this CVE

CVE page created: Sun Sep 10 02:00:15 2023
CVE page last modified: Sun Jun 16 02:56:19 2024