Upstream information

CVE-2023-38103 at MITRE

Description

GStreamer RealMedia File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of MDPR chunks. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-21443.

Upstream Security Advisories:

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 8.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1213751 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Linux Enterprise Workstation Extension 15 SP4
  • gstreamer-plugins-ugly >= 1.20.1-150400.3.3.1
  • gstreamer-plugins-ugly-lang >= 1.20.1-150400.3.3.1
Patchnames:
SUSE-SLE-Product-WE-15-SP4-2023-3226
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
SUSE Linux Enterprise Workstation Extension 15 SP5
  • gstreamer-plugins-ugly >= 1.22.0-150500.3.3.1
  • gstreamer-plugins-ugly-lang >= 1.22.0-150500.3.3.1
Patchnames:
SUSE-SLE-Product-WE-15-SP5-2023-3247
openSUSE Leap 15.4
  • gstreamer-plugins-ugly >= 1.20.1-150400.3.3.1
  • gstreamer-plugins-ugly-32bit >= 1.20.1-150400.3.3.1
  • gstreamer-plugins-ugly-doc >= 1.16.3-150200.3.6.1
  • gstreamer-plugins-ugly-lang >= 1.20.1-150400.3.3.1
Patchnames:
openSUSE-SLE-15.4-2023-3222
openSUSE-SLE-15.4-2023-3226
openSUSE Leap 15.5
  • gstreamer-plugins-ugly >= 1.22.0-150500.3.3.1
  • gstreamer-plugins-ugly-32bit >= 1.22.0-150500.3.3.1
  • gstreamer-plugins-ugly-lang >= 1.22.0-150500.3.3.1
Patchnames:
openSUSE-SLE-15.5-2023-3247


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP5 gstreamer-plugins-ugly Released
SUSE Linux Enterprise Desktop 15 SP6 gstreamer-plugins-ugly Already fixed
SUSE Linux Enterprise Server 15 SP5 gstreamer-plugins-ugly Released
SUSE Linux Enterprise Server 15 SP6 gstreamer-plugins-ugly Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 gstreamer-plugins-ugly Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 gstreamer-plugins-ugly Already fixed
SUSE Linux Enterprise Workstation Extension 15 SP5 gstreamer-plugins-ugly Released
SUSE Linux Enterprise Workstation Extension 15 SP6 gstreamer-plugins-ugly Already fixed
openSUSE Leap 15.5 gstreamer-plugins-ugly Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 gstreamer-plugins-ugly Released
SUSE Linux Enterprise Server 15 SP2 gstreamer-plugins-ugly Affected
SUSE Linux Enterprise Server 15 SP3 gstreamer-plugins-ugly Affected
SUSE Linux Enterprise Server 15 SP4 gstreamer-plugins-ugly Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 gstreamer-plugins-ugly Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 gstreamer-plugins-ugly Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 gstreamer-plugins-ugly Released
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 15 SP2 gstreamer-plugins-ugly Affected
SUSE Linux Enterprise Desktop 15 SP3 gstreamer-plugins-ugly Affected
SUSE Linux Enterprise Workstation Extension 15 SP2 gstreamer-plugins-ugly Affected
SUSE Linux Enterprise Workstation Extension 15 SP3 gstreamer-plugins-ugly Affected
SUSE Linux Enterprise Workstation Extension 15 SP4 gstreamer-plugins-ugly Released
openSUSE Leap 15.4 gstreamer-plugins-ugly Released


SUSE Timeline for this CVE

CVE page created: Fri Jul 28 02:01:02 2023
CVE page last modified: Thu May 30 15:57:08 2024