Upstream information

CVE-2023-3255 at MITRE

Description

A flaw was found in the QEMU built-in VNC server while processing ClientCutText messages. A wrong exit condition may lead to an infinite loop when inflating an attacker controlled zlib buffer in the `inflate_buffer` function. This could allow a remote authenticated client who is able to send a clipboard to the VNC server to trigger a denial of service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 4.9
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required Low High
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1213001 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/sle-micro-rancher/5.3:latest
Container suse/sle-micro-rancher/5.4:latest
  • qemu-guest-agent >= 6.2.0-150400.37.20.1
Container suse/sle-micro/kvm-5.5:2.0.2-2.2.20
  • qemu-guest-agent >= 7.1.0-150500.49.6.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • qemu-tools >= 6.2.0-150400.37.20.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-3234
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
  • qemu-tools >= 7.1.0-150500.49.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2023-3082
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • qemu >= 6.2.0-150400.37.20.1
  • qemu-SLOF >= 6.2.0-150400.37.20.1
  • qemu-accel-tcg-x86 >= 6.2.0-150400.37.20.1
  • qemu-arm >= 6.2.0-150400.37.20.1
  • qemu-audio-alsa >= 6.2.0-150400.37.20.1
  • qemu-audio-pa >= 6.2.0-150400.37.20.1
  • qemu-audio-spice >= 6.2.0-150400.37.20.1
  • qemu-block-curl >= 6.2.0-150400.37.20.1
  • qemu-block-iscsi >= 6.2.0-150400.37.20.1
  • qemu-block-rbd >= 6.2.0-150400.37.20.1
  • qemu-block-ssh >= 6.2.0-150400.37.20.1
  • qemu-chardev-baum >= 6.2.0-150400.37.20.1
  • qemu-chardev-spice >= 6.2.0-150400.37.20.1
  • qemu-guest-agent >= 6.2.0-150400.37.20.1
  • qemu-hw-display-qxl >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-gpu >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-gpu-pci >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-vga >= 6.2.0-150400.37.20.1
  • qemu-hw-s390x-virtio-gpu-ccw >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-host >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-redirect >= 6.2.0-150400.37.20.1
  • qemu-ipxe >= 1.0.0+-150400.37.20.1
  • qemu-ksm >= 6.2.0-150400.37.20.1
  • qemu-kvm >= 6.2.0-150400.37.20.1
  • qemu-lang >= 6.2.0-150400.37.20.1
  • qemu-ppc >= 6.2.0-150400.37.20.1
  • qemu-s390x >= 6.2.0-150400.37.20.1
  • qemu-seabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-sgabios >= 8-150400.37.20.1
  • qemu-skiboot >= 6.2.0-150400.37.20.1
  • qemu-tools >= 6.2.0-150400.37.20.1
  • qemu-ui-curses >= 6.2.0-150400.37.20.1
  • qemu-ui-gtk >= 6.2.0-150400.37.20.1
  • qemu-ui-opengl >= 6.2.0-150400.37.20.1
  • qemu-ui-spice-app >= 6.2.0-150400.37.20.1
  • qemu-ui-spice-core >= 6.2.0-150400.37.20.1
  • qemu-vgabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-x86 >= 6.2.0-150400.37.20.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-3234
SUSE-SLE-Module-Server-Applications-15-SP4-2023-3234
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • qemu >= 7.1.0-150500.49.6.1
  • qemu-SLOF >= 7.1.0-150500.49.6.1
  • qemu-accel-tcg-x86 >= 7.1.0-150500.49.6.1
  • qemu-arm >= 7.1.0-150500.49.6.1
  • qemu-audio-alsa >= 7.1.0-150500.49.6.1
  • qemu-audio-dbus >= 7.1.0-150500.49.6.1
  • qemu-audio-pa >= 7.1.0-150500.49.6.1
  • qemu-audio-spice >= 7.1.0-150500.49.6.1
  • qemu-block-curl >= 7.1.0-150500.49.6.1
  • qemu-block-iscsi >= 7.1.0-150500.49.6.1
  • qemu-block-rbd >= 7.1.0-150500.49.6.1
  • qemu-block-ssh >= 7.1.0-150500.49.6.1
  • qemu-chardev-baum >= 7.1.0-150500.49.6.1
  • qemu-chardev-spice >= 7.1.0-150500.49.6.1
  • qemu-guest-agent >= 7.1.0-150500.49.6.1
  • qemu-hw-display-qxl >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-gpu >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-gpu-pci >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-vga >= 7.1.0-150500.49.6.1
  • qemu-hw-s390x-virtio-gpu-ccw >= 7.1.0-150500.49.6.1
  • qemu-hw-usb-host >= 7.1.0-150500.49.6.1
  • qemu-hw-usb-redirect >= 7.1.0-150500.49.6.1
  • qemu-ipxe >= 1.0.0+-150500.49.6.1
  • qemu-ksm >= 7.1.0-150500.49.6.1
  • qemu-kvm >= 7.1.0-150500.49.6.1
  • qemu-lang >= 7.1.0-150500.49.6.1
  • qemu-ppc >= 7.1.0-150500.49.6.1
  • qemu-s390x >= 7.1.0-150500.49.6.1
  • qemu-seabios >= 1.16.0_0_gd239552-150500.49.6.1
  • qemu-sgabios >= 8-150500.49.6.1
  • qemu-skiboot >= 7.1.0-150500.49.6.1
  • qemu-tools >= 7.1.0-150500.49.6.1
  • qemu-ui-curses >= 7.1.0-150500.49.6.1
  • qemu-ui-dbus >= 7.1.0-150500.49.6.1
  • qemu-ui-gtk >= 7.1.0-150500.49.6.1
  • qemu-ui-opengl >= 7.1.0-150500.49.6.1
  • qemu-ui-spice-app >= 7.1.0-150500.49.6.1
  • qemu-ui-spice-core >= 7.1.0-150500.49.6.1
  • qemu-vgabios >= 1.16.0_0_gd239552-150500.49.6.1
  • qemu-x86 >= 7.1.0-150500.49.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2023-3082
SUSE-SLE-Module-Server-Applications-15-SP5-2023-3082
SUSE Linux Enterprise Micro 5.3
  • qemu >= 6.2.0-150400.37.20.1
  • qemu-accel-tcg-x86 >= 6.2.0-150400.37.20.1
  • qemu-arm >= 6.2.0-150400.37.20.1
  • qemu-audio-spice >= 6.2.0-150400.37.20.1
  • qemu-chardev-spice >= 6.2.0-150400.37.20.1
  • qemu-guest-agent >= 6.2.0-150400.37.20.1
  • qemu-hw-display-qxl >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-gpu >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-vga >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-redirect >= 6.2.0-150400.37.20.1
  • qemu-ipxe >= 1.0.0+-150400.37.20.1
  • qemu-s390x >= 6.2.0-150400.37.20.1
  • qemu-seabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-sgabios >= 8-150400.37.20.1
  • qemu-tools >= 6.2.0-150400.37.20.1
  • qemu-ui-opengl >= 6.2.0-150400.37.20.1
  • qemu-ui-spice-core >= 6.2.0-150400.37.20.1
  • qemu-vgabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-x86 >= 6.2.0-150400.37.20.1
Patchnames:
SUSE-SLE-Micro-5.3-2023-3234
SUSE Linux Enterprise Micro 5.4
  • qemu >= 6.2.0-150400.37.20.1
  • qemu-accel-tcg-x86 >= 6.2.0-150400.37.20.1
  • qemu-arm >= 6.2.0-150400.37.20.1
  • qemu-audio-spice >= 6.2.0-150400.37.20.1
  • qemu-chardev-spice >= 6.2.0-150400.37.20.1
  • qemu-guest-agent >= 6.2.0-150400.37.20.1
  • qemu-hw-display-qxl >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-gpu >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-vga >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-redirect >= 6.2.0-150400.37.20.1
  • qemu-ipxe >= 1.0.0+-150400.37.20.1
  • qemu-s390x >= 6.2.0-150400.37.20.1
  • qemu-seabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-sgabios >= 8-150400.37.20.1
  • qemu-tools >= 6.2.0-150400.37.20.1
  • qemu-ui-opengl >= 6.2.0-150400.37.20.1
  • qemu-ui-spice-core >= 6.2.0-150400.37.20.1
  • qemu-vgabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-x86 >= 6.2.0-150400.37.20.1
Patchnames:
SUSE-SLE-Micro-5.4-2023-3234
SUSE Linux Enterprise Micro 5.5
  • qemu >= 7.1.0-150500.49.6.1
  • qemu-accel-tcg-x86 >= 7.1.0-150500.49.6.1
  • qemu-arm >= 7.1.0-150500.49.6.1
  • qemu-audio-spice >= 7.1.0-150500.49.6.1
  • qemu-block-curl >= 7.1.0-150500.49.6.1
  • qemu-chardev-spice >= 7.1.0-150500.49.6.1
  • qemu-guest-agent >= 7.1.0-150500.49.6.1
  • qemu-hw-display-qxl >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-gpu >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-vga >= 7.1.0-150500.49.6.1
  • qemu-hw-usb-redirect >= 7.1.0-150500.49.6.1
  • qemu-ipxe >= 1.0.0+-150500.49.6.1
  • qemu-s390x >= 7.1.0-150500.49.6.1
  • qemu-seabios >= 1.16.0_0_gd239552-150500.49.6.1
  • qemu-sgabios >= 8-150500.49.6.1
  • qemu-tools >= 7.1.0-150500.49.6.1
  • qemu-ui-opengl >= 7.1.0-150500.49.6.1
  • qemu-ui-spice-core >= 7.1.0-150500.49.6.1
  • qemu-vgabios >= 1.16.0_0_gd239552-150500.49.6.1
  • qemu-x86 >= 7.1.0-150500.49.6.1
Patchnames:
SUSE-SLE-Micro-5.5-2023-3082
SUSE Linux Enterprise Module for Server Applications 15 SP4
  • qemu >= 6.2.0-150400.37.20.1
  • qemu-SLOF >= 6.2.0-150400.37.20.1
  • qemu-accel-tcg-x86 >= 6.2.0-150400.37.20.1
  • qemu-arm >= 6.2.0-150400.37.20.1
  • qemu-audio-alsa >= 6.2.0-150400.37.20.1
  • qemu-audio-pa >= 6.2.0-150400.37.20.1
  • qemu-audio-spice >= 6.2.0-150400.37.20.1
  • qemu-block-curl >= 6.2.0-150400.37.20.1
  • qemu-block-iscsi >= 6.2.0-150400.37.20.1
  • qemu-block-rbd >= 6.2.0-150400.37.20.1
  • qemu-block-ssh >= 6.2.0-150400.37.20.1
  • qemu-chardev-baum >= 6.2.0-150400.37.20.1
  • qemu-chardev-spice >= 6.2.0-150400.37.20.1
  • qemu-guest-agent >= 6.2.0-150400.37.20.1
  • qemu-hw-display-qxl >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-gpu >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-gpu-pci >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-vga >= 6.2.0-150400.37.20.1
  • qemu-hw-s390x-virtio-gpu-ccw >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-host >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-redirect >= 6.2.0-150400.37.20.1
  • qemu-ipxe >= 1.0.0+-150400.37.20.1
  • qemu-ksm >= 6.2.0-150400.37.20.1
  • qemu-kvm >= 6.2.0-150400.37.20.1
  • qemu-lang >= 6.2.0-150400.37.20.1
  • qemu-ppc >= 6.2.0-150400.37.20.1
  • qemu-s390x >= 6.2.0-150400.37.20.1
  • qemu-seabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-sgabios >= 8-150400.37.20.1
  • qemu-skiboot >= 6.2.0-150400.37.20.1
  • qemu-ui-curses >= 6.2.0-150400.37.20.1
  • qemu-ui-gtk >= 6.2.0-150400.37.20.1
  • qemu-ui-opengl >= 6.2.0-150400.37.20.1
  • qemu-ui-spice-app >= 6.2.0-150400.37.20.1
  • qemu-ui-spice-core >= 6.2.0-150400.37.20.1
  • qemu-vgabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-x86 >= 6.2.0-150400.37.20.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP4-2023-3234
SUSE Linux Enterprise Module for Server Applications 15 SP5
  • qemu >= 7.1.0-150500.49.6.1
  • qemu-SLOF >= 7.1.0-150500.49.6.1
  • qemu-accel-tcg-x86 >= 7.1.0-150500.49.6.1
  • qemu-arm >= 7.1.0-150500.49.6.1
  • qemu-audio-alsa >= 7.1.0-150500.49.6.1
  • qemu-audio-dbus >= 7.1.0-150500.49.6.1
  • qemu-audio-pa >= 7.1.0-150500.49.6.1
  • qemu-audio-spice >= 7.1.0-150500.49.6.1
  • qemu-block-curl >= 7.1.0-150500.49.6.1
  • qemu-block-iscsi >= 7.1.0-150500.49.6.1
  • qemu-block-rbd >= 7.1.0-150500.49.6.1
  • qemu-block-ssh >= 7.1.0-150500.49.6.1
  • qemu-chardev-baum >= 7.1.0-150500.49.6.1
  • qemu-chardev-spice >= 7.1.0-150500.49.6.1
  • qemu-guest-agent >= 7.1.0-150500.49.6.1
  • qemu-hw-display-qxl >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-gpu >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-gpu-pci >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-vga >= 7.1.0-150500.49.6.1
  • qemu-hw-s390x-virtio-gpu-ccw >= 7.1.0-150500.49.6.1
  • qemu-hw-usb-host >= 7.1.0-150500.49.6.1
  • qemu-hw-usb-redirect >= 7.1.0-150500.49.6.1
  • qemu-ipxe >= 1.0.0+-150500.49.6.1
  • qemu-ksm >= 7.1.0-150500.49.6.1
  • qemu-kvm >= 7.1.0-150500.49.6.1
  • qemu-lang >= 7.1.0-150500.49.6.1
  • qemu-ppc >= 7.1.0-150500.49.6.1
  • qemu-s390x >= 7.1.0-150500.49.6.1
  • qemu-seabios >= 1.16.0_0_gd239552-150500.49.6.1
  • qemu-sgabios >= 8-150500.49.6.1
  • qemu-skiboot >= 7.1.0-150500.49.6.1
  • qemu-ui-curses >= 7.1.0-150500.49.6.1
  • qemu-ui-dbus >= 7.1.0-150500.49.6.1
  • qemu-ui-gtk >= 7.1.0-150500.49.6.1
  • qemu-ui-opengl >= 7.1.0-150500.49.6.1
  • qemu-ui-spice-app >= 7.1.0-150500.49.6.1
  • qemu-ui-spice-core >= 7.1.0-150500.49.6.1
  • qemu-vgabios >= 1.16.0_0_gd239552-150500.49.6.1
  • qemu-x86 >= 7.1.0-150500.49.6.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP5-2023-3082
openSUSE Leap 15.4
  • qemu >= 6.2.0-150400.37.20.1
  • qemu-SLOF >= 6.2.0-150400.37.20.1
  • qemu-accel-qtest >= 6.2.0-150400.37.20.1
  • qemu-accel-tcg-x86 >= 6.2.0-150400.37.20.1
  • qemu-arm >= 6.2.0-150400.37.20.1
  • qemu-audio-alsa >= 6.2.0-150400.37.20.1
  • qemu-audio-jack >= 6.2.0-150400.37.20.1
  • qemu-audio-pa >= 6.2.0-150400.37.20.1
  • qemu-audio-spice >= 6.2.0-150400.37.20.1
  • qemu-block-curl >= 6.2.0-150400.37.20.1
  • qemu-block-dmg >= 6.2.0-150400.37.20.1
  • qemu-block-gluster >= 6.2.0-150400.37.20.1
  • qemu-block-iscsi >= 6.2.0-150400.37.20.1
  • qemu-block-nfs >= 6.2.0-150400.37.20.1
  • qemu-block-rbd >= 6.2.0-150400.37.20.1
  • qemu-block-ssh >= 6.2.0-150400.37.20.1
  • qemu-chardev-baum >= 6.2.0-150400.37.20.1
  • qemu-chardev-spice >= 6.2.0-150400.37.20.1
  • qemu-extra >= 6.2.0-150400.37.20.1
  • qemu-guest-agent >= 6.2.0-150400.37.20.1
  • qemu-hw-display-qxl >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-gpu >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-gpu-pci >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-vga >= 6.2.0-150400.37.20.1
  • qemu-hw-s390x-virtio-gpu-ccw >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-host >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-redirect >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-smartcard >= 6.2.0-150400.37.20.1
  • qemu-ipxe >= 1.0.0+-150400.37.20.1
  • qemu-ivshmem-tools >= 6.2.0-150400.37.20.1
  • qemu-ksm >= 6.2.0-150400.37.20.1
  • qemu-kvm >= 6.2.0-150400.37.20.1
  • qemu-lang >= 6.2.0-150400.37.20.1
  • qemu-microvm >= 6.2.0-150400.37.20.1
  • qemu-ppc >= 6.2.0-150400.37.20.1
  • qemu-s390x >= 6.2.0-150400.37.20.1
  • qemu-seabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-sgabios >= 8-150400.37.20.1
  • qemu-skiboot >= 6.2.0-150400.37.20.1
  • qemu-tools >= 6.2.0-150400.37.20.1
  • qemu-ui-curses >= 6.2.0-150400.37.20.1
  • qemu-ui-gtk >= 6.2.0-150400.37.20.1
  • qemu-ui-opengl >= 6.2.0-150400.37.20.1
  • qemu-ui-spice-app >= 6.2.0-150400.37.20.1
  • qemu-ui-spice-core >= 6.2.0-150400.37.20.1
  • qemu-vgabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-vhost-user-gpu >= 6.2.0-150400.37.20.1
  • qemu-x86 >= 6.2.0-150400.37.20.1
Patchnames:
openSUSE-SLE-15.4-2023-3234
openSUSE Leap 15.5
  • qemu >= 7.1.0-150500.49.6.1
  • qemu-SLOF >= 7.1.0-150500.49.6.1
  • qemu-accel-qtest >= 7.1.0-150500.49.6.1
  • qemu-accel-tcg-x86 >= 7.1.0-150500.49.6.1
  • qemu-arm >= 7.1.0-150500.49.6.1
  • qemu-audio-alsa >= 7.1.0-150500.49.6.1
  • qemu-audio-dbus >= 7.1.0-150500.49.6.1
  • qemu-audio-jack >= 7.1.0-150500.49.6.1
  • qemu-audio-pa >= 7.1.0-150500.49.6.1
  • qemu-audio-spice >= 7.1.0-150500.49.6.1
  • qemu-block-curl >= 7.1.0-150500.49.6.1
  • qemu-block-dmg >= 7.1.0-150500.49.6.1
  • qemu-block-gluster >= 7.1.0-150500.49.6.1
  • qemu-block-iscsi >= 7.1.0-150500.49.6.1
  • qemu-block-nfs >= 7.1.0-150500.49.6.1
  • qemu-block-rbd >= 7.1.0-150500.49.6.1
  • qemu-block-ssh >= 7.1.0-150500.49.6.1
  • qemu-chardev-baum >= 7.1.0-150500.49.6.1
  • qemu-chardev-spice >= 7.1.0-150500.49.6.1
  • qemu-extra >= 7.1.0-150500.49.6.1
  • qemu-guest-agent >= 7.1.0-150500.49.6.1
  • qemu-hw-display-qxl >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-gpu >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-gpu-pci >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-vga >= 7.1.0-150500.49.6.1
  • qemu-hw-s390x-virtio-gpu-ccw >= 7.1.0-150500.49.6.1
  • qemu-hw-usb-host >= 7.1.0-150500.49.6.1
  • qemu-hw-usb-redirect >= 7.1.0-150500.49.6.1
  • qemu-hw-usb-smartcard >= 7.1.0-150500.49.6.1
  • qemu-ipxe >= 1.0.0+-150500.49.6.1
  • qemu-ivshmem-tools >= 7.1.0-150500.49.6.1
  • qemu-ksm >= 7.1.0-150500.49.6.1
  • qemu-kvm >= 7.1.0-150500.49.6.1
  • qemu-lang >= 7.1.0-150500.49.6.1
  • qemu-microvm >= 7.1.0-150500.49.6.1
  • qemu-ppc >= 7.1.0-150500.49.6.1
  • qemu-s390x >= 7.1.0-150500.49.6.1
  • qemu-seabios >= 1.16.0_0_gd239552-150500.49.6.1
  • qemu-sgabios >= 8-150500.49.6.1
  • qemu-skiboot >= 7.1.0-150500.49.6.1
  • qemu-tools >= 7.1.0-150500.49.6.1
  • qemu-ui-curses >= 7.1.0-150500.49.6.1
  • qemu-ui-dbus >= 7.1.0-150500.49.6.1
  • qemu-ui-gtk >= 7.1.0-150500.49.6.1
  • qemu-ui-opengl >= 7.1.0-150500.49.6.1
  • qemu-ui-spice-app >= 7.1.0-150500.49.6.1
  • qemu-ui-spice-core >= 7.1.0-150500.49.6.1
  • qemu-vgabios >= 1.16.0_0_gd239552-150500.49.6.1
  • qemu-vhost-user-gpu >= 7.1.0-150500.49.6.1
  • qemu-x86 >= 7.1.0-150500.49.6.1
Patchnames:
openSUSE-SLE-15.5-2023-3082
openSUSE Leap Micro 5.3
  • qemu >= 6.2.0-150400.37.20.1
  • qemu-accel-tcg-x86 >= 6.2.0-150400.37.20.1
  • qemu-arm >= 6.2.0-150400.37.20.1
  • qemu-audio-spice >= 6.2.0-150400.37.20.1
  • qemu-chardev-spice >= 6.2.0-150400.37.20.1
  • qemu-guest-agent >= 6.2.0-150400.37.20.1
  • qemu-hw-display-qxl >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-gpu >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-vga >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-redirect >= 6.2.0-150400.37.20.1
  • qemu-ipxe >= 1.0.0+-150400.37.20.1
  • qemu-seabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-sgabios >= 8-150400.37.20.1
  • qemu-tools >= 6.2.0-150400.37.20.1
  • qemu-ui-opengl >= 6.2.0-150400.37.20.1
  • qemu-ui-spice-core >= 6.2.0-150400.37.20.1
  • qemu-vgabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-x86 >= 6.2.0-150400.37.20.1
Patchnames:
openSUSE-Leap-Micro-5.3-2023-3234
openSUSE Leap Micro 5.4
  • qemu >= 6.2.0-150400.37.20.1
  • qemu-accel-tcg-x86 >= 6.2.0-150400.37.20.1
  • qemu-arm >= 6.2.0-150400.37.20.1
  • qemu-audio-spice >= 6.2.0-150400.37.20.1
  • qemu-chardev-spice >= 6.2.0-150400.37.20.1
  • qemu-guest-agent >= 6.2.0-150400.37.20.1
  • qemu-hw-display-qxl >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-gpu >= 6.2.0-150400.37.20.1
  • qemu-hw-display-virtio-vga >= 6.2.0-150400.37.20.1
  • qemu-hw-usb-redirect >= 6.2.0-150400.37.20.1
  • qemu-ipxe >= 1.0.0+-150400.37.20.1
  • qemu-s390x >= 6.2.0-150400.37.20.1
  • qemu-seabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-sgabios >= 8-150400.37.20.1
  • qemu-tools >= 6.2.0-150400.37.20.1
  • qemu-ui-opengl >= 6.2.0-150400.37.20.1
  • qemu-ui-spice-core >= 6.2.0-150400.37.20.1
  • qemu-vgabios >= 1.15.0_0_g2dd4b9b-150400.37.20.1
  • qemu-x86 >= 6.2.0-150400.37.20.1
Patchnames:
openSUSE-Leap-Micro-5.4-2023-3234
openSUSE Leap Micro 5.5
  • qemu >= 7.1.0-150500.49.6.1
  • qemu-accel-tcg-x86 >= 7.1.0-150500.49.6.1
  • qemu-arm >= 7.1.0-150500.49.6.1
  • qemu-audio-spice >= 7.1.0-150500.49.6.1
  • qemu-block-curl >= 7.1.0-150500.49.6.1
  • qemu-chardev-spice >= 7.1.0-150500.49.6.1
  • qemu-guest-agent >= 7.1.0-150500.49.6.1
  • qemu-hw-display-qxl >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-gpu >= 7.1.0-150500.49.6.1
  • qemu-hw-display-virtio-vga >= 7.1.0-150500.49.6.1
  • qemu-hw-usb-redirect >= 7.1.0-150500.49.6.1
  • qemu-ipxe >= 1.0.0+-150500.49.6.1
  • qemu-s390x >= 7.1.0-150500.49.6.1
  • qemu-seabios >= 1.16.0_0_gd239552-150500.49.6.1
  • qemu-sgabios >= 8-150500.49.6.1
  • qemu-tools >= 7.1.0-150500.49.6.1
  • qemu-ui-opengl >= 7.1.0-150500.49.6.1
  • qemu-ui-spice-core >= 7.1.0-150500.49.6.1
  • qemu-vgabios >= 1.16.0_0_gd239552-150500.49.6.1
  • qemu-x86 >= 7.1.0-150500.49.6.1
Patchnames:
openSUSE-Leap-Micro-5.5-2023-3082
openSUSE Tumbleweed
  • qemu >= 8.0.3-2.1
  • qemu-SLOF >= 8.0.3-2.1
  • qemu-accel-qtest >= 8.0.3-2.1
  • qemu-accel-tcg-x86 >= 8.0.3-2.1
  • qemu-arm >= 8.0.3-2.1
  • qemu-audio-alsa >= 8.0.3-2.1
  • qemu-audio-dbus >= 8.0.3-2.1
  • qemu-audio-jack >= 8.0.3-2.1
  • qemu-audio-oss >= 8.0.3-2.1
  • qemu-audio-pa >= 8.0.3-2.1
  • qemu-audio-spice >= 8.0.3-2.1
  • qemu-block-curl >= 8.0.3-2.1
  • qemu-block-dmg >= 8.0.3-2.1
  • qemu-block-gluster >= 8.0.3-2.1
  • qemu-block-iscsi >= 8.0.3-2.1
  • qemu-block-nfs >= 8.0.3-2.1
  • qemu-block-rbd >= 8.0.3-2.1
  • qemu-block-ssh >= 8.0.3-2.1
  • qemu-chardev-baum >= 8.0.3-2.1
  • qemu-chardev-spice >= 8.0.3-2.1
  • qemu-doc >= 8.0.3-2.1
  • qemu-extra >= 8.0.3-2.1
  • qemu-guest-agent >= 8.0.3-2.1
  • qemu-headless >= 8.0.3-2.1
  • qemu-hw-display-qxl >= 8.0.3-2.1
  • qemu-hw-display-virtio-gpu >= 8.0.3-2.1
  • qemu-hw-display-virtio-gpu-pci >= 8.0.3-2.1
  • qemu-hw-display-virtio-vga >= 8.0.3-2.1
  • qemu-hw-s390x-virtio-gpu-ccw >= 8.0.3-2.1
  • qemu-hw-usb-host >= 8.0.3-2.1
  • qemu-hw-usb-redirect >= 8.0.3-2.1
  • qemu-hw-usb-smartcard >= 8.0.3-2.1
  • qemu-img >= 8.0.3-2.1
  • qemu-ipxe >= 1.0.0+-2.1
  • qemu-ivshmem-tools >= 8.0.3-2.1
  • qemu-ksm >= 8.0.3-2.1
  • qemu-kvm >= 8.0.3-2.1
  • qemu-lang >= 8.0.3-2.1
  • qemu-microvm >= 8.0.3-2.1
  • qemu-ppc >= 8.0.3-2.1
  • qemu-pr-helper >= 8.0.3-2.1
  • qemu-s390x >= 8.0.3-2.1
  • qemu-seabios >= 1.16.2_3_gd478f380-2.1
  • qemu-skiboot >= 8.0.3-2.1
  • qemu-tools >= 8.0.3-2.1
  • qemu-ui-curses >= 8.0.3-2.1
  • qemu-ui-dbus >= 8.0.3-2.1
  • qemu-ui-gtk >= 8.0.3-2.1
  • qemu-ui-opengl >= 8.0.3-2.1
  • qemu-ui-spice-app >= 8.0.3-2.1
  • qemu-ui-spice-core >= 8.0.3-2.1
  • qemu-vgabios >= 1.16.2_3_gd478f380-2.1
  • qemu-vhost-user-gpu >= 8.0.3-2.1
  • qemu-x86 >= 8.0.3-2.1
Patchnames:
openSUSE Tumbleweed GA qemu-8.0.3-2.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 qemu Not affected
SUSE Linux Enterprise Desktop 15 SP5 qemu Released
SUSE Linux Enterprise High Performance Computing 12 SP5 qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 qemu Released
SUSE Linux Enterprise Micro 5.1 qemu Not affected
SUSE Linux Enterprise Micro 5.2 qemu Not affected
SUSE Linux Enterprise Micro 5.3 qemu Released
SUSE Linux Enterprise Micro 5.4 qemu Released
SUSE Linux Enterprise Micro 5.5 qemu Released
SUSE Linux Enterprise Micro for Rancher 5.3 qemu Released
SUSE Linux Enterprise Micro for Rancher 5.4 qemu Released
SUSE Linux Enterprise Micro for Rancher 5.5 qemu Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 qemu Released
SUSE Linux Enterprise Module for Package Hub 15 SP5 qemu Affected
SUSE Linux Enterprise Module for Server Applications 15 SP5 qemu Released
SUSE Linux Enterprise Real Time 15 SP3 qemu Not affected
SUSE Linux Enterprise Server 12 SP5 qemu Not affected
SUSE Linux Enterprise Server 15 SP5 qemu Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 qemu Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 qemu Released
SUSE Manager Proxy 4.3 qemu Released
SUSE Manager Retail Branch Server 4.3 qemu Released
SUSE Manager Server 4.3 qemu Released
openSUSE Leap 15.5 qemu Released
openSUSE Leap Micro 5.3 qemu Released
openSUSE Leap Micro 5.4 qemu Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 qemu Released
SUSE Linux Enterprise High Performance Computing 15 qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 qemu Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS qemu Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS qemu Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS qemu Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS qemu Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 qemu Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 qemu Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 qemu Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 qemu Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 qemu Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 qemu Released
SUSE Linux Enterprise Server 15 SP2 qemu Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS qemu Not affected
SUSE Linux Enterprise Server 15 SP3 qemu Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS qemu Not affected
SUSE Linux Enterprise Server 15 SP4 qemu Released
SUSE Linux Enterprise Server 15 SP4-LTSS qemu Affected
SUSE Linux Enterprise Server for SAP Applications 15 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 qemu Not affected
SUSE OpenStack Cloud 8 qemu Not affected
SUSE OpenStack Cloud 9 qemu Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 qemu Not affected
SUSE CaaS Platform 3.0 qemu Not affected
SUSE CaaS Platform 4.0 qemu Not affected
SUSE Enterprise Storage 6 qemu Not affected
SUSE Enterprise Storage 7 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP2 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP3 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP4 qemu Not affected
SUSE Linux Enterprise Desktop 15 qemu Not affected
SUSE Linux Enterprise Desktop 15 SP1 qemu Not affected
SUSE Linux Enterprise Desktop 15 SP2 qemu Not affected
SUSE Linux Enterprise Desktop 15 SP3 qemu Not affected
SUSE Linux Enterprise Micro 5.0 qemu Not affected
SUSE Linux Enterprise Module for Basesystem 15 qemu Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 qemu Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 qemu Affected
SUSE Linux Enterprise Module for Server Applications 15 qemu Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 qemu Not affected
SUSE Linux Enterprise Real Time 15 SP2 qemu Not affected
SUSE Linux Enterprise Real Time 15 SP4 qemu Affected
SUSE Linux Enterprise Server 11 SP4 kvm Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS kvm Not affected
SUSE Linux Enterprise Server 12 SP2 qemu Not affected
SUSE Linux Enterprise Server 12 SP2-BCL qemu Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS qemu Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS qemu Not affected
SUSE Linux Enterprise Server 12 SP3 qemu Not affected
SUSE Linux Enterprise Server 12 SP3-BCL qemu Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS qemu Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS qemu Not affected
SUSE Linux Enterprise Server 12 SP4 qemu Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS qemu Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS qemu Not affected
SUSE Linux Enterprise Server 15 qemu Not affected
SUSE Linux Enterprise Server 15 SP1 qemu Not affected
SUSE Linux Enterprise Server 15 SP1-BCL qemu Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS qemu Not affected
SUSE Linux Enterprise Server 15 SP2-BCL qemu Not affected
SUSE Linux Enterprise Server 15 SP3-BCL qemu Not affected
SUSE Linux Enterprise Server 15-LTSS qemu Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 qemu Not affected
SUSE Manager Proxy 4.0 qemu Not affected
SUSE Manager Proxy 4.1 qemu Not affected
SUSE Manager Proxy 4.2 qemu Not affected
SUSE Manager Retail Branch Server 4.0 qemu Not affected
SUSE Manager Retail Branch Server 4.1 qemu Not affected
SUSE Manager Retail Branch Server 4.2 qemu Not affected
SUSE Manager Server 4.0 qemu Not affected
SUSE Manager Server 4.1 qemu Not affected
SUSE Manager Server 4.2 qemu Not affected
SUSE OpenStack Cloud 7 qemu Not affected
SUSE OpenStack Cloud Crowbar 8 qemu Not affected
SUSE OpenStack Cloud Crowbar 9 qemu Not affected
openSUSE Leap 15.4 qemu Released
Container Status
suse/sles/15.6/libguestfs-tools:1.1.1
suse/sles/15.6/virt-launcher:1.1.1
qemuAlready fixed
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.3/libguestfs-tools:0.45.0
suse/sles/15.3/virt-launcher:0.45.0
qemuNot affected
suse/sles/15.4/libguestfs-tools:0.49.0
suse/sles/15.4/virt-launcher:0.49.0
suse/sles/15.5/libguestfs-tools:0.58.0
suse/sles/15.5/virt-launcher:0.58.0
qemuIn progress


SUSE Timeline for this CVE

CVE page created: Tue Jul 4 12:00:04 2023
CVE page last modified: Wed Apr 17 15:41:04 2024