Upstream information

CVE-2023-24626 at MITRE

Description

socket.c in GNU Screen through 4.9.0, when installed setuid or setgid (the default on platforms such as Arch Linux and FreeBSD), allows local users to send a privileged SIGHUP signal to any PID, causing a denial of service or disruption of the target process.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 6.2
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Changed Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1210272 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • screen >= 4.9.1-1.1
Patchnames:
openSUSE-Tumbleweed-2024-13285


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 screen Not affected
SUSE Linux Enterprise Desktop 15 SP5 screen Not affected
SUSE Linux Enterprise Desktop 15 SP6 screen Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP6 screen Not affected
SUSE Linux Enterprise Micro 5.3 screen Not affected
SUSE Linux Enterprise Micro 5.4 screen Not affected
SUSE Linux Enterprise Micro 5.5 screen Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP5 screen Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP6 screen Not affected
SUSE Linux Enterprise Server 12 SP5 screen Not affected
SUSE Linux Enterprise Server 15 SP5 screen Not affected
SUSE Linux Enterprise Server 15 SP6 screen Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 screen Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 screen Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 screen Not affected
SUSE Manager Proxy 4.3 screen Not affected
SUSE Manager Retail Branch Server 4.3 screen Not affected
SUSE Manager Server 4.3 screen Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS screen Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 screen Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 screen Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 screen Not affected
SUSE Linux Enterprise Server 15 SP2 screen Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS screen Not affected
SUSE Linux Enterprise Server 15 SP3 screen Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS screen Not affected
SUSE Linux Enterprise Server 15 SP4 screen Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS screen Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 screen Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 screen Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 screen Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 screen Not affected
SUSE CaaS Platform 3.0 screen Not affected
SUSE CaaS Platform 4.0 screen Not affected
SUSE Enterprise Storage 6 screen Not affected
SUSE Enterprise Storage 7 screen Not affected
SUSE Linux Enterprise Desktop 12 SP2 screen Not affected
SUSE Linux Enterprise Desktop 12 SP3 screen Not affected
SUSE Linux Enterprise Desktop 12 SP4 screen Not affected
SUSE Linux Enterprise Desktop 15 screen Not affected
SUSE Linux Enterprise Desktop 15 SP1 screen Not affected
SUSE Linux Enterprise Desktop 15 SP2 screen Not affected
SUSE Linux Enterprise Desktop 15 SP3 screen Not affected
SUSE Linux Enterprise High Performance Computing 15 screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS screen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS screen Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS screen Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS screen Not affected
SUSE Linux Enterprise Module for Basesystem 15 screen Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 screen Not affected
SUSE Linux Enterprise Real Time 15 SP2 screen Not affected
SUSE Linux Enterprise Real Time 15 SP3 screen Not affected
SUSE Linux Enterprise Real Time 15 SP4 screen Not affected
SUSE Linux Enterprise Server 11 SP3 screen Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS screen Not affected
SUSE Linux Enterprise Server 11 SP4 screen Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS screen Not affected
SUSE Linux Enterprise Server 12 SP2 screen Not affected
SUSE Linux Enterprise Server 12 SP2-BCL screen Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS screen Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS screen Not affected
SUSE Linux Enterprise Server 12 SP3 screen Not affected
SUSE Linux Enterprise Server 12 SP3-BCL screen Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS screen Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS screen Not affected
SUSE Linux Enterprise Server 12 SP4 screen Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS screen Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS screen Not affected
SUSE Linux Enterprise Server 15 screen Not affected
SUSE Linux Enterprise Server 15 SP1 screen Not affected
SUSE Linux Enterprise Server 15 SP1-BCL screen Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS screen Not affected
SUSE Linux Enterprise Server 15 SP2-BCL screen Not affected
SUSE Linux Enterprise Server 15 SP3-BCL screen Not affected
SUSE Linux Enterprise Server 15-LTSS screen Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 screen Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 screen Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 screen Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 screen Not affected
SUSE Linux Enterprise Server for SAP Applications 15 screen Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 screen Not affected
SUSE Manager Proxy 4.0 screen Not affected
SUSE Manager Proxy 4.1 screen Not affected
SUSE Manager Proxy 4.2 screen Not affected
SUSE Manager Retail Branch Server 4.0 screen Not affected
SUSE Manager Retail Branch Server 4.1 screen Not affected
SUSE Manager Retail Branch Server 4.2 screen Not affected
SUSE Manager Server 4.0 screen Not affected
SUSE Manager Server 4.1 screen Not affected
SUSE Manager Server 4.2 screen Not affected
SUSE OpenStack Cloud 7 screen Not affected
SUSE OpenStack Cloud 8 screen Not affected
SUSE OpenStack Cloud 9 screen Not affected
SUSE OpenStack Cloud Crowbar 8 screen Not affected
SUSE OpenStack Cloud Crowbar 9 screen Not affected


SUSE Timeline for this CVE

CVE page created: Sat Apr 8 08:00:03 2023
CVE page last modified: Sun Jun 16 02:47:24 2024