Upstream information

CVE-2022-46908 at MITRE

Description

SQLite through 3.40.0, when relying on --safe for execution of an untrusted CLI script, does not properly implement the azProhibitedFunctions protection mechanism, and instead allows UDF functions such as WRITEFILE.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.3 5.3
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1206337 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/bci-init:15.3.21.99
Container bci/nodejs:12-17.114
Container bci/openjdk-devel:11-38.20
Container bci/openjdk-devel:17-12.17
Container bci/openjdk:11-34.10
Container bci/openjdk:17-11.8
Container bci/python:3.10-10.7
Container bci/python:3.9-22.25
Container suse/389-ds:2.0-18.14
Container suse/pcp:5.2.2-11.119
Container suse/sle-micro-rancher/5.2:latest
Container suse/sle-micro-rancher/5.3:latest
Container suse/sle15:15.0.4.22.659
Container suse/sle15:15.1.6.2.723
Container suse/sle15:15.2.9.5.248
Container suse/sle15:15.3.17.20.88
Container suse/sle15:15.4.27.14.26
Image SLES15-SP3-Micro-5-1-BYOS-EC2-HVM
Image SLES15-SP3-Micro-5-1-BYOS-GCE
Image SLES15-SP3-Micro-5-2-BYOS-Azure
Image SLES15-SP3-Micro-5-2-BYOS-EC2-HVM
Image SLES15-SP3-Micro-5-2-BYOS-GCE
Image SLES15-SP4-CHOST-BYOS
Image SLES15-SP4-CHOST-BYOS-Aliyun
Image SLES15-SP4-CHOST-BYOS-Azure
Image SLES15-SP4-CHOST-BYOS-EC2
Image SLES15-SP4-CHOST-BYOS-GCE
Image SLES15-SP4-Micro-5-3-BYOS
Image SLES15-SP4-Micro-5-3-BYOS-Azure
Image SLES15-SP4-Micro-5-3-BYOS-EC2
Image SLES15-SP4-Micro-5-3-BYOS-GCE
Image SLES15-SP4-SUSE-Rancher-Setup-BYOS
Image SLES15-SP4-SUSE-Rancher-Setup-BYOS-EC2
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
Container bci/ruby:2.5-32.7
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
  • sqlite3-devel >= 3.39.3-150000.3.20.1
Image SLES12-SP5-Azure-BYOS
Image SLES12-SP5-Azure-Basic-On-Demand
Image SLES12-SP5-Azure-HPC-BYOS
Image SLES12-SP5-Azure-HPC-On-Demand
Image SLES12-SP5-Azure-Standard-On-Demand
Image SLES12-SP5-EC2-BYOS
Image SLES12-SP5-GCE-BYOS
Image SLES12-SP5-GCE-On-Demand
  • libsqlite3-0 >= 3.39.3-9.26.1
  • sqlite3-tcl >= 3.39.3-9.26.1
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
  • libsqlite3-0 >= 3.39.3-9.26.1
  • sqlite3 >= 3.39.3-9.26.1
  • sqlite3-tcl >= 3.39.3-9.26.1
Image SLES12-SP5-EC2-ECS-On-Demand
  • libsqlite3-0 >= 3.39.3-9.26.1
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-GCE
Image SLES15-SP3-Manager-4-2-Server-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Server-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Server-BYOS-GCE
Image SLES15-SP4-Manager-Proxy-4-3-BYOS
Image SLES15-SP4-Manager-Proxy-4-3-BYOS-GCE
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-Azure
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Server-4-3-BYOS-GCE
Image SLES15-SP4-SAP-BYOS
Image SLES15-SP4-SAP-BYOS-Azure
Image SLES15-SP4-SAP-BYOS-GCE
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
  • sqlite3 >= 3.39.3-150000.3.20.1
  • sqlite3-tcl >= 3.39.3-150000.3.20.1
Image SLES15-SP4
Image SLES15-SP4-Azure-Basic
Image SLES15-SP4-Azure-Standard
Image SLES15-SP4-BYOS
Image SLES15-SP4-BYOS-Azure
Image SLES15-SP4-BYOS-GCE
Image SLES15-SP4-GCE
Image SLES15-SP4-HPC
Image SLES15-SP4-HPC-Azure
Image SLES15-SP4-HPC-BYOS
Image SLES15-SP4-HPC-BYOS-Azure
Image SLES15-SP4-HPC-BYOS-GCE
Image SLES15-SP4-HPC-GCE
Image SLES15-SP4-Hardened-BYOS
Image SLES15-SP4-Hardened-BYOS-Azure
Image SLES15-SP4-Hardened-BYOS-EC2
Image SLES15-SP4-Hardened-BYOS-GCE
Image SLES15-SP4-SAP
Image SLES15-SP4-SAP-Azure
Image SLES15-SP4-SAP-GCE
Image SLES15-SP4-SAPCAL
Image SLES15-SP4-SAPCAL-Azure
Image SLES15-SP4-SAPCAL-GCE
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
  • sqlite3-tcl >= 3.39.3-150000.3.20.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
  • libsqlite3-0-32bit >= 3.39.3-150000.3.20.1
  • sqlite3 >= 3.39.3-150000.3.20.1
  • sqlite3-devel >= 3.39.3-150000.3.20.1
  • sqlite3-tcl >= 3.39.3-150000.3.20.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2022-4628
SUSE Linux Enterprise Micro 5.1
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2022-4628
SUSE Linux Enterprise Micro 5.2
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2022-4628
SUSE Linux Enterprise Micro 5.3
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
  • sqlite3-tcl >= 3.39.3-150000.3.20.1
Patchnames:
SUSE-SLE-Micro-5.3-2022-4628
SUSE Linux Enterprise Real Time 15 SP3
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
  • libsqlite3-0-32bit >= 3.39.3-150000.3.20.1
  • sqlite3 >= 3.39.3-150000.3.20.1
  • sqlite3-devel >= 3.39.3-150000.3.20.1
  • sqlite3-tcl >= 3.39.3-150000.3.20.1
Patchnames:
SUSE-SLE-Product-RT-15-SP3-2022-4628
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libsqlite3-0 >= 3.39.3-9.26.1
  • libsqlite3-0-32bit >= 3.39.3-9.26.1
  • sqlite3 >= 3.39.3-9.26.1
  • sqlite3-devel >= 3.39.3-9.26.1
  • sqlite3-tcl >= 3.39.3-9.26.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-4603
SUSE-SLE-SERVER-12-SP5-2022-4603
SUSE Linux Enterprise Software Development Kit 12 SP5
  • sqlite3-devel >= 3.39.3-9.26.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-4603
openSUSE Leap 15.3
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
  • libsqlite3-0-32bit >= 3.39.3-150000.3.20.1
  • sqlite3 >= 3.39.3-150000.3.20.1
  • sqlite3-devel >= 3.39.3-150000.3.20.1
  • sqlite3-doc >= 3.39.3-150000.3.20.1
  • sqlite3-tcl >= 3.39.3-150000.3.20.1
Patchnames:
openSUSE-SLE-15.3-2022-4628
openSUSE Leap 15.4
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
  • libsqlite3-0-32bit >= 3.39.3-150000.3.20.1
  • sqlite3 >= 3.39.3-150000.3.20.1
  • sqlite3-devel >= 3.39.3-150000.3.20.1
  • sqlite3-doc >= 3.39.3-150000.3.20.1
  • sqlite3-tcl >= 3.39.3-150000.3.20.1
Patchnames:
openSUSE-SLE-15.4-2022-4628
openSUSE Leap Micro 5.2
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
Patchnames:
openSUSE-Leap-Micro-5.2-2022-4628
openSUSE Leap Micro 5.3
  • libsqlite3-0 >= 3.39.3-150000.3.20.1
  • sqlite3-tcl >= 3.39.3-150000.3.20.1
Patchnames:
openSUSE-Leap-Micro-5.3-2022-4628
openSUSE Tumbleweed
  • libsqlite3-0 >= 3.40.0-2.1
  • libsqlite3-0-32bit >= 3.40.0-2.1
  • sqlite3 >= 3.40.0-2.1
  • sqlite3-devel >= 3.40.0-2.1
  • sqlite3-doc >= 3.40.0-2.1
  • sqlite3-tcl >= 3.40.0-2.1
Patchnames:
openSUSE Tumbleweed GA libsqlite3-0-3.40.0-2.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 sqlite3 Affected
SUSE Enterprise Storage 7.1 sqlite3 Affected
SUSE Linux Enterprise Desktop 15 SP4 sqlite3 Released
SUSE Linux Enterprise High Availability Extension 12 SP5 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 12 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 sqlite3 Released
SUSE Linux Enterprise High Performance Computing 15 SP4 sqlite3 Released
SUSE Linux Enterprise Micro 5.1 sqlite3 Released
SUSE Linux Enterprise Micro 5.2 sqlite3 Released
SUSE Linux Enterprise Micro 5.3 sqlite3 Released
SUSE Linux Enterprise Micro for Rancher 5.2 sqlite3 Released
SUSE Linux Enterprise Micro for Rancher 5.3 sqlite3 Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 sqlite3 Released
SUSE Linux Enterprise Real Time 15 SP3 sqlite3 Released
SUSE Linux Enterprise Server 12 SP5 sqlite2 Not affected
SUSE Linux Enterprise Server 12 SP5 sqlite3 Released
SUSE Linux Enterprise Server 15 SP4 sqlite3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 sqlite3 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 sqlite3 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 sqlite2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 sqlite3 Released
SUSE Manager Proxy 4.2 sqlite3 Unsupported
SUSE Manager Proxy 4.3 sqlite3 Released
SUSE Manager Retail Branch Server 4.2 sqlite3 Unsupported
SUSE Manager Retail Branch Server 4.3 sqlite3 Released
SUSE Manager Server 4.2 sqlite3 Unsupported
SUSE Manager Server 4.3 sqlite3 Released
openSUSE Leap 15.4 sqlite3 Released
openSUSE Leap Micro 5.3 sqlite3 Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Availability Extension 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 15 sqlite3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 sqlite3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS sqlite3 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS sqlite3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 sqlite3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS sqlite3 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS sqlite3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 sqlite3 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS sqlite3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS sqlite3 Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS sqlite3 Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS sqlite3 Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP1 sqlite3 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 sqlite3 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 sqlite3 Unsupported
SUSE Linux Enterprise Server 12 SP2-BCL sqlite3 Affected
SUSE Linux Enterprise Server 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise Server 12 SP4 sqlite3 Affected
SUSE Linux Enterprise Server 12 SP4-LTSS sqlite3 Affected
SUSE Linux Enterprise Server 15 SP1 sqlite3 Affected
SUSE Linux Enterprise Server 15 SP1-LTSS sqlite3 Affected
SUSE Linux Enterprise Server 15 SP2 sqlite3 Affected
SUSE Linux Enterprise Server 15 SP2-LTSS sqlite3 Affected
SUSE Linux Enterprise Server 15 SP3 sqlite3 Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS sqlite3 Affected
SUSE Linux Enterprise Server 15-ESPOS sqlite3 Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 sqlite3 Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 sqlite3 Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 sqlite3 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 15 sqlite3 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 sqlite3 Unsupported
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 sqlite3 Affected
SUSE CaaS Platform 3.0 sqlite3 Affected
SUSE CaaS Platform 4.0 sqlite3 Affected
SUSE Enterprise Storage 6 sqlite3 Affected
SUSE Linux Enterprise Desktop 11 SP4 sqlite3 Not affected
SUSE Linux Enterprise Desktop 12 sqlite2 Not affected
SUSE Linux Enterprise Desktop 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise Desktop 12 SP1 sqlite3 Affected
SUSE Linux Enterprise Desktop 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise Desktop 12 SP2 sqlite3 Affected
SUSE Linux Enterprise Desktop 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise Desktop 12 SP3 sqlite3 Affected
SUSE Linux Enterprise Desktop 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise Desktop 12 SP4 sqlite3 Affected
SUSE Linux Enterprise Desktop 15 sqlite3 Affected
SUSE Linux Enterprise Desktop 15 SP1 sqlite3 Affected
SUSE Linux Enterprise Desktop 15 SP2 sqlite3 Affected
SUSE Linux Enterprise Desktop 15 SP3 sqlite3 Unsupported
SUSE Linux Enterprise High Availability Extension 12 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise Micro 5.0 sqlite3 Affected
SUSE Linux Enterprise Module for Basesystem 15 sqlite3 Affected
SUSE Linux Enterprise Real Time 15 SP2 sqlite3 Affected
SUSE Linux Enterprise Server 11 SP3 sqlite3 Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS sqlite3 Not affected
SUSE Linux Enterprise Server 11 SP4 sqlite3 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS sqlite3 Not affected
SUSE Linux Enterprise Server 12 sqlite2 Not affected
SUSE Linux Enterprise Server 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise Server 12 SP1 sqlite3 Affected
SUSE Linux Enterprise Server 12 SP1-LTSS sqlite3 Affected
SUSE Linux Enterprise Server 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise Server 12 SP2 sqlite3 Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS sqlite3 Affected
SUSE Linux Enterprise Server 12 SP2-LTSS sqlite3 Affected
SUSE Linux Enterprise Server 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise Server 12 SP3 sqlite3 Affected
SUSE Linux Enterprise Server 12 SP3-BCL sqlite3 Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS sqlite3 Affected
SUSE Linux Enterprise Server 12 SP3-LTSS sqlite3 Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS sqlite3 Affected
SUSE Linux Enterprise Server 15 sqlite3 Affected
SUSE Linux Enterprise Server 15 SP1-BCL sqlite3 Affected
SUSE Linux Enterprise Server 15 SP2-BCL sqlite3 Affected
SUSE Linux Enterprise Server 15 SP3-BCL sqlite3 Affected
SUSE Linux Enterprise Server 15-LTSS sqlite3 Unsupported
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 sqlite3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 sqlite3 Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 sqlite3 Not affected
SUSE Linux Enterprise Software Development Kit 12 sqlite2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 sqlite3 Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 sqlite3 Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 sqlite3 Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 sqlite3 Affected
SUSE Manager Proxy 4.0 sqlite3 Affected
SUSE Manager Proxy 4.1 sqlite3 Unsupported
SUSE Manager Retail Branch Server 4.0 sqlite3 Affected
SUSE Manager Retail Branch Server 4.1 sqlite3 Unsupported
SUSE Manager Server 4.0 sqlite3 Affected
SUSE Manager Server 4.1 sqlite3 Unsupported
SUSE OpenStack Cloud 7 sqlite3 Affected
SUSE OpenStack Cloud 8 sqlite3 Affected
SUSE OpenStack Cloud 9 sqlite3 Affected
SUSE OpenStack Cloud Crowbar 8 sqlite3 Affected
SUSE OpenStack Cloud Crowbar 9 sqlite3 Affected


SUSE Timeline for this CVE

CVE page created: Mon Dec 12 13:00:23 2022
CVE page last modified: Mon Feb 6 22:20:32 2023