Upstream information

CVE-2022-44792 at MITRE

Description

handle_ipDefaultTTL in agent/mibgroup/ip-mib/ip_scalars.c in Net-SNMP 5.8 through 5.9.3 has a NULL Pointer Exception bug that can be used by a remote attacker (who has write access) to cause the instance to crash via a crafted UDP packet, resulting in Denial of Service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None Low
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1205150 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
  • libsnmp30 >= 5.7.3-11.6.1
  • net-snmp >= 5.7.3-11.6.1
  • perl-SNMP >= 5.7.3-11.6.1
  • snmp-mibs >= 5.7.3-11.6.1
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
  • libsnmp40 >= 5.9.3-150300.15.8.1
  • net-snmp >= 5.9.3-150300.15.8.1
  • perl-SNMP >= 5.9.3-150300.15.8.1
  • snmp-mibs >= 5.9.3-150300.15.8.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libsnmp40 >= 5.9.3-150300.15.8.1
  • net-snmp >= 5.9.3-150300.15.8.1
  • net-snmp-devel >= 5.9.3-150300.15.8.1
  • perl-SNMP >= 5.9.3-150300.15.8.1
  • snmp-mibs >= 5.9.3-150300.15.8.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-75
SUSE Linux Enterprise Micro 5.3
  • libsnmp40 >= 5.9.3-150300.15.8.1
  • snmp-mibs >= 5.9.3-150300.15.8.1
Patchnames:
SUSE-SLE-Micro-5.3-2023-75
SUSE Linux Enterprise Real Time 15 SP3
  • libsnmp40 >= 5.9.3-150300.15.8.1
  • net-snmp >= 5.9.3-150300.15.8.1
  • net-snmp-devel >= 5.9.3-150300.15.8.1
  • perl-SNMP >= 5.9.3-150300.15.8.1
  • snmp-mibs >= 5.9.3-150300.15.8.1
Patchnames:
SUSE-SLE-Product-RT-15-SP3-2023-75
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libsnmp30 >= 5.7.3-11.6.1
  • libsnmp30-32bit >= 5.7.3-11.6.1
  • net-snmp >= 5.7.3-11.6.1
  • net-snmp-devel >= 5.7.3-11.6.1
  • perl-SNMP >= 5.7.3-11.6.1
  • snmp-mibs >= 5.7.3-11.6.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2023-68
SUSE-SLE-SERVER-12-SP5-2023-68
SUSE Linux Enterprise Software Development Kit 12 SP5
  • net-snmp-devel >= 5.7.3-11.6.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2023-68
openSUSE Leap 15.4
  • libsnmp40 >= 5.9.3-150300.15.8.1
  • libsnmp40-32bit >= 5.9.3-150300.15.8.1
  • net-snmp >= 5.9.3-150300.15.8.1
  • net-snmp-devel >= 5.9.3-150300.15.8.1
  • net-snmp-devel-32bit >= 5.9.3-150300.15.8.1
  • perl-SNMP >= 5.9.3-150300.15.8.1
  • python3-net-snmp >= 5.9.3-150300.15.8.1
  • snmp-mibs >= 5.9.3-150300.15.8.1
Patchnames:
openSUSE-SLE-15.4-2023-75
openSUSE Leap Micro 5.3
  • libsnmp40 >= 5.9.3-150300.15.8.1
  • snmp-mibs >= 5.9.3-150300.15.8.1
Patchnames:
openSUSE-Leap-Micro-5.3-2023-75


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 net-snmp Unsupported
SUSE Enterprise Storage 7.1 net-snmp Released
SUSE Linux Enterprise Desktop 15 SP4 net-snmp Released
SUSE Linux Enterprise High Performance Computing 12 SP5 net-snmp Released
SUSE Linux Enterprise High Performance Computing 15 SP4 net-snmp Released
SUSE Linux Enterprise Micro 5.3 net-snmp Released
SUSE Linux Enterprise Micro for Rancher 5.3 net-snmp Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 net-snmp Released
SUSE Linux Enterprise Module for Package Hub 15 SP4 net-snmp Unsupported
SUSE Linux Enterprise Real Time 15 SP3 net-snmp Released
SUSE Linux Enterprise Server 12 SP5 net-snmp Released
SUSE Linux Enterprise Server 15 SP4 net-snmp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 net-snmp Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 net-snmp Released
SUSE Linux Enterprise Software Development Kit 12 SP5 net-snmp Released
SUSE Manager Proxy 4.2 net-snmp Affected
SUSE Manager Proxy 4.3 net-snmp Released
SUSE Manager Retail Branch Server 4.2 net-snmp Affected
SUSE Manager Retail Branch Server 4.3 net-snmp Released
SUSE Manager Server 4.2 net-snmp Affected
SUSE Manager Server 4.3 net-snmp Released
SUSE Package Hub 15 SP4 net-snmp Released
openSUSE Leap 15.4 net-snmp Released
openSUSE Leap Micro 5.3 net-snmp Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 net-snmp Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 net-snmp Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS net-snmp Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS net-snmp Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS net-snmp Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS net-snmp Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 net-snmp Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS net-snmp Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS net-snmp Released
SUSE Linux Enterprise High Performance Computing 15-ESPOS net-snmp Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS net-snmp Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 net-snmp Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP3 net-snmp Affected
SUSE Linux Enterprise Server 12 SP2-BCL net-snmp Unsupported
SUSE Linux Enterprise Server 12 SP4 net-snmp Unsupported
SUSE Linux Enterprise Server 12 SP4-LTSS net-snmp Affected
SUSE Linux Enterprise Server 15 SP1 net-snmp Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS net-snmp Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS net-snmp Unsupported
SUSE Linux Enterprise Server 15 SP3 net-snmp Affected
SUSE Linux Enterprise Server 15 SP3-LTSS net-snmp Unsupported
SUSE Linux Enterprise Server 15-ESPOS net-snmp Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 net-snmp Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 net-snmp Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 net-snmp Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 net-snmp Affected
SUSE Linux Enterprise Server for SAP Applications 15 net-snmp Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 net-snmp Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 net-snmp Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 net-snmp Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 net-snmp Unsupported
SUSE CaaS Platform 3.0 net-snmp Unsupported
SUSE CaaS Platform 4.0 net-snmp Unsupported
SUSE Enterprise Storage 6 net-snmp Unsupported
SUSE Linux Enterprise Desktop 11 SP4 net-snmp Not affected
SUSE Linux Enterprise Desktop 12 SP1 net-snmp Unsupported
SUSE Linux Enterprise Desktop 12 SP2 net-snmp Unsupported
SUSE Linux Enterprise Desktop 12 SP3 net-snmp Unsupported
SUSE Linux Enterprise Desktop 12 SP4 net-snmp Unsupported
SUSE Linux Enterprise Desktop 15 net-snmp Unsupported
SUSE Linux Enterprise Desktop 15 SP1 net-snmp Unsupported
SUSE Linux Enterprise Desktop 15 SP3 net-snmp Affected
SUSE Linux Enterprise Module for Basesystem 15 net-snmp Unsupported
SUSE Linux Enterprise Module for Package Hub 15 SP1 net-snmp Unsupported
SUSE Linux Enterprise Module for Package Hub 15 SP3 net-snmp Unsupported
SUSE Linux Enterprise Real Time 15 SP2 net-snmp Unsupported
SUSE Linux Enterprise Server 11 SP3-LTSS net-snmp Not affected
SUSE Linux Enterprise Server 11 SP4 net-snmp Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS net-snmp Not affected
SUSE Linux Enterprise Server 12 SP1 net-snmp Unsupported
SUSE Linux Enterprise Server 12 SP1-LTSS net-snmp Unsupported
SUSE Linux Enterprise Server 12 SP2 net-snmp Unsupported
SUSE Linux Enterprise Server 12 SP2-ESPOS net-snmp Unsupported
SUSE Linux Enterprise Server 12 SP2-LTSS net-snmp Unsupported
SUSE Linux Enterprise Server 12 SP3 net-snmp Unsupported
SUSE Linux Enterprise Server 12 SP3-BCL net-snmp Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS net-snmp Unsupported
SUSE Linux Enterprise Server 12 SP3-LTSS net-snmp Unsupported
SUSE Linux Enterprise Server 12 SP4-ESPOS net-snmp Affected
SUSE Linux Enterprise Server 15 net-snmp Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL net-snmp Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL net-snmp Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL net-snmp Unsupported
SUSE Linux Enterprise Server 15-LTSS net-snmp Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 net-snmp Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP4 net-snmp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 net-snmp Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 net-snmp Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 net-snmp Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP4 net-snmp Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 net-snmp Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 net-snmp Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 net-snmp Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP4 net-snmp Unsupported
SUSE Manager Proxy 4.0 net-snmp Unsupported
SUSE Manager Proxy 4.1 net-snmp Affected
SUSE Manager Retail Branch Server 4.0 net-snmp Unsupported
SUSE Manager Retail Branch Server 4.1 net-snmp Affected
SUSE Manager Server 4.0 net-snmp Unsupported
SUSE Manager Server 4.1 net-snmp Affected
SUSE OpenStack Cloud 7 net-snmp Unsupported
SUSE OpenStack Cloud 8 net-snmp Unsupported
SUSE OpenStack Cloud 9 net-snmp Affected
SUSE OpenStack Cloud Crowbar 8 net-snmp Unsupported
SUSE OpenStack Cloud Crowbar 9 net-snmp Affected
SUSE Package Hub 15 SP3 net-snmp Affected
openSUSE Leap 15.3 net-snmp Released


SUSE Timeline for this CVE

CVE page created: Mon Nov 7 13:00:52 2022
CVE page last modified: Sat Jan 28 01:38:13 2023