Upstream information

CVE-2022-44640 at MITRE

Description

Heimdal before 7.7.1 allows remote attackers to execute arbitrary code because of an invalid free in the ASN.1 codec used by the Key Distribution Center (KDC).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entries: 1205667 [NEW], 1206730 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP3
  • libasn1-8 >= 7.8.0-bp153.2.4.1
  • libgssapi3 >= 7.8.0-bp153.2.4.1
  • libhcrypto4 >= 7.8.0-bp153.2.4.1
  • libhdb9 >= 7.8.0-bp153.2.4.1
  • libheimbase1 >= 7.8.0-bp153.2.4.1
  • libheimdal-devel >= 7.8.0-bp153.2.4.1
  • libheimedit0 >= 7.8.0-bp153.2.4.1
  • libheimntlm0 >= 7.8.0-bp153.2.4.1
  • libhx509-5 >= 7.8.0-bp153.2.4.1
  • libkadm5clnt7 >= 7.8.0-bp153.2.4.1
  • libkadm5srv8 >= 7.8.0-bp153.2.4.1
  • libkafs0 >= 7.8.0-bp153.2.4.1
  • libkdc2 >= 7.8.0-bp153.2.4.1
  • libkrb5-26 >= 7.8.0-bp153.2.4.1
  • libotp0 >= 7.8.0-bp153.2.4.1
  • libroken18 >= 7.8.0-bp153.2.4.1
  • libsl0 >= 7.8.0-bp153.2.4.1
  • libwind0 >= 7.8.0-bp153.2.4.1
Patchnames:
openSUSE-2023-20
SUSE Package Hub 15 SP4
  • libasn1-8 >= 7.8.0-bp154.2.4.1
  • libgssapi3 >= 7.8.0-bp154.2.4.1
  • libhcrypto4 >= 7.8.0-bp154.2.4.1
  • libhdb9 >= 7.8.0-bp154.2.4.1
  • libheimbase1 >= 7.8.0-bp154.2.4.1
  • libheimdal-devel >= 7.8.0-bp154.2.4.1
  • libheimedit0 >= 7.8.0-bp154.2.4.1
  • libheimntlm0 >= 7.8.0-bp154.2.4.1
  • libhx509-5 >= 7.8.0-bp154.2.4.1
  • libkadm5clnt7 >= 7.8.0-bp154.2.4.1
  • libkadm5srv8 >= 7.8.0-bp154.2.4.1
  • libkafs0 >= 7.8.0-bp154.2.4.1
  • libkdc2 >= 7.8.0-bp154.2.4.1
  • libkrb5-26 >= 7.8.0-bp154.2.4.1
  • libotp0 >= 7.8.0-bp154.2.4.1
  • libroken18 >= 7.8.0-bp154.2.4.1
  • libsl0 >= 7.8.0-bp154.2.4.1
  • libwind0 >= 7.8.0-bp154.2.4.1
Patchnames:
openSUSE-2023-19
openSUSE Leap 15.3
  • libasn1-8 >= 7.8.0-bp153.2.4.1
  • libgssapi3 >= 7.8.0-bp153.2.4.1
  • libhcrypto4 >= 7.8.0-bp153.2.4.1
  • libhdb9 >= 7.8.0-bp153.2.4.1
  • libheimbase1 >= 7.8.0-bp153.2.4.1
  • libheimdal-devel >= 7.8.0-bp153.2.4.1
  • libheimedit0 >= 7.8.0-bp153.2.4.1
  • libheimntlm0 >= 7.8.0-bp153.2.4.1
  • libhx509-5 >= 7.8.0-bp153.2.4.1
  • libkadm5clnt7 >= 7.8.0-bp153.2.4.1
  • libkadm5srv8 >= 7.8.0-bp153.2.4.1
  • libkafs0 >= 7.8.0-bp153.2.4.1
  • libkdc2 >= 7.8.0-bp153.2.4.1
  • libkrb5-26 >= 7.8.0-bp153.2.4.1
  • libotp0 >= 7.8.0-bp153.2.4.1
  • libroken18 >= 7.8.0-bp153.2.4.1
  • libsl0 >= 7.8.0-bp153.2.4.1
  • libwind0 >= 7.8.0-bp153.2.4.1
Patchnames:
openSUSE-2023-20
openSUSE Leap 15.4
  • libasn1-8 >= 7.8.0-bp154.2.4.1
  • libgssapi3 >= 7.8.0-bp154.2.4.1
  • libhcrypto4 >= 7.8.0-bp154.2.4.1
  • libhdb9 >= 7.8.0-bp154.2.4.1
  • libheimbase1 >= 7.8.0-bp154.2.4.1
  • libheimdal-devel >= 7.8.0-bp154.2.4.1
  • libheimedit0 >= 7.8.0-bp154.2.4.1
  • libheimntlm0 >= 7.8.0-bp154.2.4.1
  • libhx509-5 >= 7.8.0-bp154.2.4.1
  • libkadm5clnt7 >= 7.8.0-bp154.2.4.1
  • libkadm5srv8 >= 7.8.0-bp154.2.4.1
  • libkafs0 >= 7.8.0-bp154.2.4.1
  • libkdc2 >= 7.8.0-bp154.2.4.1
  • libkrb5-26 >= 7.8.0-bp154.2.4.1
  • libotp0 >= 7.8.0-bp154.2.4.1
  • libroken18 >= 7.8.0-bp154.2.4.1
  • libsl0 >= 7.8.0-bp154.2.4.1
  • libwind0 >= 7.8.0-bp154.2.4.1
Patchnames:
openSUSE-2023-19
openSUSE Tumbleweed
  • ctdb >= 4.17.4+git.300.305b22bfce-1.1
  • ctdb-pcp-pmda >= 4.17.4+git.300.305b22bfce-1.1
  • libasn1-8 >= 7.8.0-1.1
  • libgssapi3 >= 7.8.0-1.1
  • libhcrypto4 >= 7.8.0-1.1
  • libhdb9 >= 7.8.0-1.1
  • libheimbase1 >= 7.8.0-1.1
  • libheimdal-devel >= 7.8.0-1.1
  • libheimedit0 >= 7.8.0-1.1
  • libheimntlm0 >= 7.8.0-1.1
  • libhx509-5 >= 7.8.0-1.1
  • libkadm5clnt7 >= 7.8.0-1.1
  • libkadm5srv8 >= 7.8.0-1.1
  • libkafs0 >= 7.8.0-1.1
  • libkdc2 >= 7.8.0-1.1
  • libkrb5-26 >= 7.8.0-1.1
  • libotp0 >= 7.8.0-1.1
  • libroken18 >= 7.8.0-1.1
  • libsamba-policy-devel >= 4.17.4+git.300.305b22bfce-1.1
  • libsamba-policy-python3-devel >= 4.17.4+git.300.305b22bfce-1.1
  • libsamba-policy0-python3 >= 4.17.4+git.300.305b22bfce-1.1
  • libsamba-policy0-python3-32bit >= 4.17.4+git.300.305b22bfce-1.1
  • libsl0 >= 7.8.0-1.1
  • libwind0 >= 7.8.0-1.1
  • samba >= 4.17.4+git.300.305b22bfce-1.1
  • samba-ad-dc >= 4.17.4+git.300.305b22bfce-1.1
  • samba-ad-dc-libs >= 4.17.4+git.300.305b22bfce-1.1
  • samba-ad-dc-libs-32bit >= 4.17.4+git.300.305b22bfce-1.1
  • samba-ceph >= 4.17.4+git.300.305b22bfce-1.1
  • samba-client >= 4.17.4+git.300.305b22bfce-1.1
  • samba-client-32bit >= 4.17.4+git.300.305b22bfce-1.1
  • samba-client-libs >= 4.17.4+git.300.305b22bfce-1.1
  • samba-client-libs-32bit >= 4.17.4+git.300.305b22bfce-1.1
  • samba-devel >= 4.17.4+git.300.305b22bfce-1.1
  • samba-devel-32bit >= 4.17.4+git.300.305b22bfce-1.1
  • samba-doc >= 4.17.4+git.300.305b22bfce-1.1
  • samba-dsdb-modules >= 4.17.4+git.300.305b22bfce-1.1
  • samba-gpupdate >= 4.17.4+git.300.305b22bfce-1.1
  • samba-ldb-ldap >= 4.17.4+git.300.305b22bfce-1.1
  • samba-libs >= 4.17.4+git.300.305b22bfce-1.1
  • samba-libs-32bit >= 4.17.4+git.300.305b22bfce-1.1
  • samba-libs-python3 >= 4.17.4+git.300.305b22bfce-1.1
  • samba-libs-python3-32bit >= 4.17.4+git.300.305b22bfce-1.1
  • samba-python3 >= 4.17.4+git.300.305b22bfce-1.1
  • samba-test >= 4.17.4+git.300.305b22bfce-1.1
  • samba-tool >= 4.17.4+git.300.305b22bfce-1.1
  • samba-winbind >= 4.17.4+git.300.305b22bfce-1.1
  • samba-winbind-libs >= 4.17.4+git.300.305b22bfce-1.1
  • samba-winbind-libs-32bit >= 4.17.4+git.300.305b22bfce-1.1
Patchnames:
openSUSE Tumbleweed GA ctdb-4.17.4+git.300.305b22bfce-1.1
openSUSE Tumbleweed GA libasn1-8-7.8.0-1.1


SUSE Timeline for this CVE

CVE page created: Tue Nov 22 22:00:09 2022
CVE page last modified: Mon Jan 16 22:50:25 2023