Upstream information

CVE-2022-41751 at MITRE

Description

Jhead 3.06.0.1 allows attackers to execute arbitrary OS commands by placing them in a JPEG filename and then using the regeneration -rgt50 option.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1204409 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP3
  • jhead >= 3.00-bp153.3.3.1
Patchnames:
openSUSE-2022-10178
SUSE Package Hub 15 SP4
  • jhead >= 3.06.0.1-bp154.2.3.1
Patchnames:
openSUSE-2022-10179
openSUSE Leap 15.3
  • jhead >= 3.00-bp153.3.3.1
Patchnames:
openSUSE-2022-10178
openSUSE Leap 15.4
  • jhead >= 3.06.0.1-bp154.2.3.1
Patchnames:
openSUSE-2022-10179
openSUSE Tumbleweed
  • jhead >= 3.06.0.1-2.1
Patchnames:
openSUSE Tumbleweed GA jhead-3.06.0.1-2.1


SUSE Timeline for this CVE

CVE page created: Tue Oct 18 00:00:16 2022
CVE page last modified: Sat Nov 12 17:46:59 2022