Upstream information

CVE-2022-40023 at MITRE

Description

Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.9
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1203246 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion OpenStack 8
  • python-Mako >= 1.0.7-3.3.1
Patchnames:
HPE-Helion-OpenStack-8-2022-3701
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • python2-Mako >= 1.0.7-150000.3.3.1
  • python3-Mako >= 1.0.7-150000.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-3979
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2022-3979
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • python2-Mako >= 1.0.7-150000.3.3.1
  • python3-Mako >= 1.0.7-150000.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2022-3979
SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2022-3979
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • python3-Mako >= 1.0.7-150000.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-3979
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • python3-Mako >= 1.0.7-150000.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2022-3979
SUSE Linux Enterprise Module for Package Hub 15 SP3
  • python2-Mako >= 1.0.7-150000.3.3.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2022-3979
SUSE Linux Enterprise Module for Package Hub 15 SP4
  • python2-Mako >= 1.0.7-150000.3.3.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2022-3979
SUSE OpenStack Cloud 8
  • python-Mako >= 1.0.7-3.3.1
Patchnames:
SUSE-OpenStack-Cloud-8-2022-3701
SUSE OpenStack Cloud 9
  • python-Mako >= 1.0.7-4.3.1
Patchnames:
SUSE-OpenStack-Cloud-9-2022-3700
SUSE OpenStack Cloud Crowbar 8
  • python-Mako >= 1.0.7-3.3.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2022-3701
SUSE OpenStack Cloud Crowbar 9
  • python-Mako >= 1.0.7-4.3.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2022-3700
openSUSE Leap 15.3
  • python2-Mako >= 1.0.7-150000.3.3.1
  • python3-Mako >= 1.0.7-150000.3.3.1
Patchnames:
openSUSE-SLE-15.3-2022-3979
openSUSE Leap 15.4
  • python3-Mako >= 1.0.7-150000.3.3.1
Patchnames:
openSUSE-SLE-15.4-2022-3979


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 python-Mako Affected
SUSE Enterprise Storage 7.1 python-Mako Released
SUSE Linux Enterprise Desktop 15 SP4 python-Mako Released
SUSE Linux Enterprise High Performance Computing 15 SP4 python-Mako Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 python-Mako Released
SUSE Linux Enterprise Module for Package Hub 15 SP4 python-Mako Released
SUSE Linux Enterprise Real Time 15 SP3 python-Mako Affected
SUSE Linux Enterprise Server 15 SP4 python-Mako Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 python-Mako Released
SUSE Manager Proxy 4.2 python-Mako Released
SUSE Manager Proxy 4.3 python-Mako Released
SUSE Manager Retail Branch Server 4.2 python-Mako Released
SUSE Manager Retail Branch Server 4.3 python-Mako Released
SUSE Manager Server 4.2 python-Mako Released
SUSE Manager Server 4.3 python-Mako Released
SUSE Package Hub 15 SP4 python-Mako Released
openSUSE Leap 15.4 python-Mako Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 python-Mako Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 python-Mako Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS python-Mako Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS python-Mako Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 python-Mako Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS python-Mako Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS python-Mako Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 python-Mako Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS python-Mako Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS python-Mako Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS python-Mako Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS python-Mako Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 python-Mako Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 python-Mako Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 python-Mako Released
SUSE Linux Enterprise Server 15 SP1 python-Mako Affected
SUSE Linux Enterprise Server 15 SP1-LTSS python-Mako Affected
SUSE Linux Enterprise Server 15 SP2 python-Mako Affected
SUSE Linux Enterprise Server 15 SP2-LTSS python-Mako Affected
SUSE Linux Enterprise Server 15 SP3 python-Mako Released
SUSE Linux Enterprise Server 15 SP3-LTSS python-Mako Affected
SUSE Linux Enterprise Server 15-ESPOS python-Mako Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 python-Mako Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 python-Mako Affected
SUSE Linux Enterprise Server for SAP Applications 15 python-Mako Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python-Mako Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 python-Mako Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 python-Mako Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 python-Mako Released
SUSE CaaS Platform 4.0 python-Mako Affected
SUSE Enterprise Storage 6 python-Mako Affected
SUSE Linux Enterprise Desktop 15 python-Mako Affected
SUSE Linux Enterprise Desktop 15 SP1 python-Mako Affected
SUSE Linux Enterprise Desktop 15 SP2 python-Mako Affected
SUSE Linux Enterprise Desktop 15 SP3 python-Mako Released
SUSE Linux Enterprise Module for Basesystem 15 python-Mako Affected
SUSE Linux Enterprise Module for Package Hub 15 python-Mako Affected
SUSE Linux Enterprise Module for Package Hub 15 SP1 python-Mako Affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 python-Mako Affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 python-Mako Released
SUSE Linux Enterprise Real Time 15 SP2 python-Mako Affected
SUSE Linux Enterprise Server 15 python-Mako Affected
SUSE Linux Enterprise Server 15 SP1-BCL python-Mako Affected
SUSE Linux Enterprise Server 15 SP2-BCL python-Mako Affected
SUSE Linux Enterprise Server 15 SP3-BCL python-Mako Affected
SUSE Linux Enterprise Server 15-LTSS python-Mako Affected
SUSE Manager Proxy 4.0 python-Mako Affected
SUSE Manager Proxy 4.1 python-Mako Affected
SUSE Manager Retail Branch Server 4.0 python-Mako Affected
SUSE Manager Retail Branch Server 4.1 python-Mako Affected
SUSE Manager Server 4.0 python-Mako Affected
SUSE Manager Server 4.1 python-Mako Affected
SUSE OpenStack Cloud 8 python-Mako Released
SUSE OpenStack Cloud 9 python-Mako Released
SUSE OpenStack Cloud Crowbar 8 python-Mako Released
SUSE OpenStack Cloud Crowbar 9 python-Mako Released
SUSE Package Hub 15 SP3 python-Mako Released


SUSE Timeline for this CVE

CVE page created: Wed Sep 7 18:00:05 2022
CVE page last modified: Tue Jan 24 12:16:46 2023