Upstream information

CVE-2022-36227 at MITRE

Description

In libarchive before 3.6.2, the software does not check for an error after calling calloc function that can return with a NULL pointer if the function fails, which leads to a resultant NULL pointer dereference. NOTE: the discoverer cites this CWE-476 remark but third parties dispute the code-execution impact: "In rare circumstances, when NULL is equivalent to the 0x0 memory address and privileged code can access it, then writing or reading memory is possible, which may lead to code execution."

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 3.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1205629 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
Image SLES15-SP4-SAP
Image SLES15-SP4-SAP-EC2
Image SLES15-SP4-SAPCAL
Image SLES15-SP4-SAPCAL-EC2
  • libarchive13 >= 3.5.1-150400.3.12.1
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • bsdtar >= 3.4.2-150200.4.15.1
  • libarchive-devel >= 3.4.2-150200.4.15.1
  • libarchive13 >= 3.4.2-150200.4.15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-4202
SUSE-SLE-Module-Development-Tools-15-SP3-2022-4202
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • bsdtar >= 3.5.1-150400.3.12.1
  • libarchive-devel >= 3.5.1-150400.3.12.1
  • libarchive13 >= 3.5.1-150400.3.12.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2022-4209
SUSE-SLE-Module-Development-Tools-15-SP4-2022-4209
SUSE Linux Enterprise Micro 5.3
  • libarchive13 >= 3.5.1-150400.3.12.1
Patchnames:
SUSE-SLE-Micro-5.3-2022-4209
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libarchive-devel >= 3.4.2-150200.4.15.1
  • libarchive13 >= 3.4.2-150200.4.15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-4202
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libarchive-devel >= 3.5.1-150400.3.12.1
  • libarchive13 >= 3.5.1-150400.3.12.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2022-4209
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • bsdtar >= 3.4.2-150200.4.15.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2022-4202
SUSE Linux Enterprise Module for Development Tools 15 SP4
  • bsdtar >= 3.5.1-150400.3.12.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP4-2022-4209
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libarchive-devel >= 3.3.3-32.8.1
  • libarchive13 >= 3.3.3-32.8.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-4296
SUSE-SLE-SERVER-12-SP5-2022-4296
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libarchive-devel >= 3.3.3-32.8.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-4296
openSUSE Leap 15.3
  • bsdtar >= 3.4.2-150200.4.15.1
  • libarchive-devel >= 3.4.2-150200.4.15.1
  • libarchive13 >= 3.4.2-150200.4.15.1
  • libarchive13-32bit >= 3.4.2-150200.4.15.1
Patchnames:
openSUSE-SLE-15.3-2022-4202
openSUSE Leap 15.4
  • bsdtar >= 3.5.1-150400.3.12.1
  • libarchive-devel >= 3.5.1-150400.3.12.1
  • libarchive13 >= 3.5.1-150400.3.12.1
  • libarchive13-32bit >= 3.5.1-150400.3.12.1
Patchnames:
openSUSE-SLE-15.4-2022-4209
openSUSE Leap Micro 5.3
  • libarchive13 >= 3.5.1-150400.3.12.1
Patchnames:
openSUSE-Leap-Micro-5.3-2022-4209
openSUSE Tumbleweed
  • bsdtar >= 3.6.2-1.1
  • libarchive-devel >= 3.6.2-1.1
  • libarchive13 >= 3.6.2-1.1
  • libarchive13-32bit >= 3.6.2-1.1
Patchnames:
openSUSE Tumbleweed GA bsdtar-3.6.2-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 libarchive Affected
SUSE Enterprise Storage 7.1 libarchive Released
SUSE Linux Enterprise Desktop 15 SP4 libarchive Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libarchive Released
SUSE Linux Enterprise High Performance Computing 15 SP4 libarchive Released
SUSE Linux Enterprise Micro 5.3 libarchive Released
SUSE Linux Enterprise Micro for Rancher 5.3 libarchive Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 libarchive Released
SUSE Linux Enterprise Module for Development Tools 15 SP4 libarchive Released
SUSE Linux Enterprise Real Time 15 SP3 libarchive Released
SUSE Linux Enterprise Server 12 SP5 libarchive Released
SUSE Linux Enterprise Server 12-LTSS libarchive Affected
SUSE Linux Enterprise Server 15 SP4 libarchive Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libarchive Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libarchive Released
SUSE Linux Enterprise Software Development Kit 12 SP5 libarchive Released
SUSE Manager Proxy 4.2 libarchive Released
SUSE Manager Proxy 4.3 libarchive Released
SUSE Manager Retail Branch Server 4.2 libarchive Released
SUSE Manager Retail Branch Server 4.3 libarchive Released
SUSE Manager Server 4.2 libarchive Released
SUSE Manager Server 4.3 libarchive Released
openSUSE Leap 15.4 libarchive Released
openSUSE Leap Micro 5.3 libarchive Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 libarchive Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libarchive Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS libarchive Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS libarchive Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 libarchive Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS libarchive Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS libarchive Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 libarchive Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS libarchive Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS libarchive Released
SUSE Linux Enterprise High Performance Computing 15-ESPOS libarchive Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS libarchive Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 libarchive Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 libarchive Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 libarchive Released
SUSE Linux Enterprise Module for Development Tools 15 SP1 libarchive Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 libarchive Affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 libarchive Released
SUSE Linux Enterprise Server 12 SP2-BCL libarchive Affected
SUSE Linux Enterprise Server 12 SP4 libarchive Affected
SUSE Linux Enterprise Server 12 SP4-LTSS libarchive Affected
SUSE Linux Enterprise Server 15 SP1 libarchive Affected
SUSE Linux Enterprise Server 15 SP1-LTSS libarchive Affected
SUSE Linux Enterprise Server 15 SP2 libarchive Affected
SUSE Linux Enterprise Server 15 SP2-LTSS libarchive Affected
SUSE Linux Enterprise Server 15 SP3 libarchive Released
SUSE Linux Enterprise Server 15 SP3-LTSS libarchive Affected
SUSE Linux Enterprise Server 15-ESPOS libarchive Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libarchive Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libarchive Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 libarchive Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 15 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libarchive Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 libarchive Affected
SUSE CaaS Platform 4.0 libarchive Affected
SUSE Enterprise Storage 6 libarchive Affected
SUSE Linux Enterprise Desktop 11 SP4 bsdtar Not affected
SUSE Linux Enterprise Desktop 12 libarchive Affected
SUSE Linux Enterprise Desktop 12 SP1 libarchive Affected
SUSE Linux Enterprise Desktop 12 SP2 libarchive Affected
SUSE Linux Enterprise Desktop 12 SP3 libarchive Affected
SUSE Linux Enterprise Desktop 12 SP4 libarchive Affected
SUSE Linux Enterprise Desktop 15 libarchive Affected
SUSE Linux Enterprise Desktop 15 SP1 libarchive Affected
SUSE Linux Enterprise Desktop 15 SP2 libarchive Affected
SUSE Linux Enterprise Desktop 15 SP3 libarchive Released
SUSE Linux Enterprise Module for Basesystem 15 libarchive Affected
SUSE Linux Enterprise Module for Development Tools 15 libarchive Affected
SUSE Linux Enterprise Real Time 15 SP2 libarchive Affected
SUSE Linux Enterprise Server 11 SP3 bsdtar Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS bsdtar Not affected
SUSE Linux Enterprise Server 11 SP4 bsdtar Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS bsdtar Not affected
SUSE Linux Enterprise Server 12 libarchive Affected
SUSE Linux Enterprise Server 12 SP1 libarchive Affected
SUSE Linux Enterprise Server 12 SP1-LTSS libarchive Affected
SUSE Linux Enterprise Server 12 SP2 libarchive Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS libarchive Affected
SUSE Linux Enterprise Server 12 SP2-LTSS libarchive Affected
SUSE Linux Enterprise Server 12 SP3 libarchive Affected
SUSE Linux Enterprise Server 12 SP3-BCL libarchive Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS libarchive Affected
SUSE Linux Enterprise Server 12 SP3-LTSS libarchive Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS libarchive Affected
SUSE Linux Enterprise Server 15 libarchive Affected
SUSE Linux Enterprise Server 15 SP1-BCL libarchive Affected
SUSE Linux Enterprise Server 15 SP2-BCL libarchive Affected
SUSE Linux Enterprise Server 15 SP3-BCL libarchive Affected
SUSE Linux Enterprise Server 15-LTSS libarchive Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 bsdtar Not affected
SUSE Linux Enterprise Server for SAP Applications 12 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libarchive Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 bsdtar Not affected
SUSE Linux Enterprise Software Development Kit 12 libarchive Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libarchive Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libarchive Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libarchive Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libarchive Affected
SUSE Manager Proxy 4.0 libarchive Affected
SUSE Manager Proxy 4.1 libarchive Unsupported
SUSE Manager Retail Branch Server 4.0 libarchive Affected
SUSE Manager Retail Branch Server 4.1 libarchive Unsupported
SUSE Manager Server 4.0 libarchive Affected
SUSE Manager Server 4.1 libarchive Unsupported
SUSE OpenStack Cloud 7 libarchive Affected
SUSE OpenStack Cloud 8 libarchive Affected
SUSE OpenStack Cloud 9 libarchive Affected
SUSE OpenStack Cloud Crowbar 8 libarchive Affected
SUSE OpenStack Cloud Crowbar 9 libarchive Affected


SUSE Timeline for this CVE

CVE page created: Tue Nov 22 09:51:49 2022
CVE page last modified: Wed Jan 25 01:43:33 2023