Upstream information

CVE-2022-34903 at MITRE

Description

GnuPG through 2.3.6, in unusual situations where an attacker possesses any secret-key information from a victim's keyring and other constraints (e.g., use of GPGME) are met, allows signature forgery via injection into the status line.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 6.8
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
Access Vector Network Network
Access Complexity High High
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact Low High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1201225 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/bci-init:15.3.17.26
Container bci/nodejs:12-16.116
Container bci/python:3.9-18.34
Container ses/7.1/rook/ceph:1.8.10.0.4.5.106
Container suse/sle-micro-rancher/5.2:latest
Container suse/sle-micro-rancher/5.3:latest
Container suse/sle15:15.3.17.20.5
Container suse/sle15:15.4.27.11.5
Image SLES15-SP4
Image SLES15-SP4-Azure-Basic
Image SLES15-SP4-Azure-Standard
Image SLES15-SP4-HPC
Image SLES15-SP4-HPC-Azure
Image SLES15-SP4-SUSE-Rancher-Setup-BYOS
Image SLES15-SP4-SUSE-Rancher-Setup-BYOS-EC2-HVM
  • gpg2 >= 2.2.27-150300.3.5.1
Container suse/sles12sp4:26.480
Container suse/sles12sp5:6.5.353
  • gpg2 >= 2.0.24-9.11.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • dirmngr >= 2.2.27-150300.3.5.1
  • gpg2 >= 2.2.27-150300.3.5.1
  • gpg2-lang >= 2.2.27-150300.3.5.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-2546
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • dirmngr >= 2.2.27-150300.3.5.1
  • gpg2 >= 2.2.27-150300.3.5.1
  • gpg2-lang >= 2.2.27-150300.3.5.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2022-2546
SUSE Linux Enterprise Micro 5.1
  • gpg2 >= 2.2.27-150300.3.5.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2022-2546
SUSE Linux Enterprise Micro 5.2
  • gpg2 >= 2.2.27-150300.3.5.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2022-2546
SUSE Linux Enterprise Server 12 SP2-BCL
  • gpg2 >= 2.0.24-9.11.1
  • gpg2-lang >= 2.0.24-9.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2022-2529
SUSE Linux Enterprise Server 12 SP3-BCL
  • gpg2 >= 2.0.24-9.11.1
  • gpg2-lang >= 2.0.24-9.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2022-2529
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • gpg2 >= 2.0.24-9.11.1
  • gpg2-lang >= 2.0.24-9.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2022-2529
SUSE Linux Enterprise Server 12 SP4-LTSS
  • gpg2 >= 2.0.24-9.11.1
  • gpg2-lang >= 2.0.24-9.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2022-2529
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • gpg2 >= 2.0.24-9.11.1
  • gpg2-lang >= 2.0.24-9.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2022-2529
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • gpg2 >= 2.0.24-9.11.1
  • gpg2-lang >= 2.0.24-9.11.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2022-2529
SUSE OpenStack Cloud 9
  • gpg2 >= 2.0.24-9.11.1
  • gpg2-lang >= 2.0.24-9.11.1
Patchnames:
SUSE-OpenStack-Cloud-9-2022-2529
SUSE OpenStack Cloud Crowbar 9
  • gpg2 >= 2.0.24-9.11.1
  • gpg2-lang >= 2.0.24-9.11.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2022-2529
openSUSE Leap 15.3
  • dirmngr >= 2.2.27-150300.3.5.1
  • gpg2 >= 2.2.27-150300.3.5.1
  • gpg2-lang >= 2.2.27-150300.3.5.1
Patchnames:
openSUSE-SLE-15.3-2022-2546
openSUSE Leap 15.4
  • dirmngr >= 2.2.27-150300.3.5.1
  • gpg2 >= 2.2.27-150300.3.5.1
  • gpg2-lang >= 2.2.27-150300.3.5.1
Patchnames:
openSUSE-SLE-15.4-2022-2546
openSUSE Leap Micro 5.2
  • gpg2 >= 2.2.27-150300.3.5.1
Patchnames:
openSUSE-Leap-Micro-5.2-2022-2546
openSUSE Tumbleweed
  • dirmngr >= 2.3.7-1.1
  • gpg2 >= 2.3.7-1.1
  • gpg2-lang >= 2.3.7-1.1
  • gpg2-tpm >= 2.3.7-1.1
Patchnames:
openSUSE Tumbleweed GA dirmngr-2.3.7-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 gpg2 Released
SLES15-EC2-CHOST-HVM-BYOS gpg2 Affected
SLES15-SP1-CHOST-BYOS-Azure gpg2 Affected
SLES15-SP1-CHOST-BYOS-EC2 gpg2 Affected
SLES15-SP1-CHOST-BYOS-GCE gpg2 Affected
SLES15-SP2-CHOST-BYOS-Aliyun gpg2 Affected
SLES15-SP2-CHOST-BYOS-Azure gpg2 Affected
SLES15-SP2-CHOST-BYOS-EC2 gpg2 Affected
SLES15-SP2-CHOST-BYOS-GCE gpg2 Affected
SLES15-SP3-CHOST-BYOS-Aliyun gpg2 In progress
SLES15-SP3-CHOST-BYOS-Azure gpg2 In progress
SLES15-SP3-CHOST-BYOS-EC2 gpg2 In progress
SLES15-SP3-CHOST-BYOS-GCE gpg2 In progress
SLES15-SP4-CHOST-BYOS gpg2 In progress
SLES15-SP4-CHOST-BYOS-Aliyun gpg2 In progress
SLES15-SP4-CHOST-BYOS-Azure gpg2 In progress
SLES15-SP4-CHOST-BYOS-EC2 gpg2 In progress
SLES15-SP4-CHOST-BYOS-GCE gpg2 In progress
SUSE CaaS Platform 4.0 gpg2 Affected
SUSE Enterprise Storage 6 gpg2 Affected
SUSE Enterprise Storage 7 gpg2 Affected
SUSE Linux Enterprise Desktop 15 SP3 gpg2 Released
SUSE Linux Enterprise Desktop 15 SP4 gpg2 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 gpg2 Released
SUSE Linux Enterprise High Performance Computing 15 LTSS gpg2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS gpg2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS gpg2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS gpg2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS gpg2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 gpg2 Released
SUSE Linux Enterprise High Performance Computing 15 SP4 gpg2 Released
SUSE Linux Enterprise Micro 5.1 gpg2 Released
SUSE Linux Enterprise Micro 5.2 gpg2 Released
SUSE Linux Enterprise Micro for Rancher 5.2 gpg2 Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 gpg2 Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 gpg2 Released
SUSE Linux Enterprise Server 12 SP2 BCL gpg2 Released
SUSE Linux Enterprise Server 12 SP3 BCL gpg2 Released
SUSE Linux Enterprise Server 12 SP3 ESPOS gpg2 Released
SUSE Linux Enterprise Server 12 SP3 LTSS gpg2 Released
SUSE Linux Enterprise Server 12 SP4 ESPOS gpg2 Released
SUSE Linux Enterprise Server 12 SP4 LTSS gpg2 Released
SUSE Linux Enterprise Server 12 SP5 gpg2 Released
SUSE Linux Enterprise Server 15 ESPOS gpg2 Affected
SUSE Linux Enterprise Server 15 LTSS gpg2 Affected
SUSE Linux Enterprise Server 15 SP1 LTSS gpg2 Affected
SUSE Linux Enterprise Server 15 SP2 LTSS gpg2 Affected
SUSE Linux Enterprise Server 15 SP3 gpg2 Released
SUSE Linux Enterprise Server 15 SP4 gpg2 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 gpg2 Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 gpg2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gpg2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gpg2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gpg2 Released
SUSE Linux Enterprise Server for SAP Applications 15 gpg2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 gpg2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 gpg2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 gpg2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 gpg2 Released
SUSE Linux Enterprise Storage 7.1 gpg2 Released
SUSE Manager Proxy 4.1 gpg2 Affected
SUSE Manager Proxy 4.2 gpg2 Released
SUSE Manager Proxy 4.3 gpg2 Released
SUSE Manager Retail Branch Server 4.1 gpg2 Affected
SUSE Manager Retail Branch Server 4.2 gpg2 Released
SUSE Manager Retail Branch Server 4.3 gpg2 Released
SUSE Manager Server 4.1 gpg2 Affected
SUSE Manager Server 4.2 gpg2 Released
SUSE Manager Server 4.3 gpg2 Released
SUSE OpenStack Cloud 8 gpg2 Released
SUSE OpenStack Cloud 9 gpg2 Released
SUSE OpenStack Cloud Crowbar 8 gpg2 Released
SUSE OpenStack Cloud Crowbar 9 gpg2 Released
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
ses/7/ceph/ceph
ses/7/ceph/grafana
ses/7/ceph/prometheus-alertmanager
ses/7/ceph/prometheus-node-exporter
ses/7/ceph/prometheus-server
ses/7/cephcsi/cephcsi
ses/7/cephcsi/csi-attacher:v2.1.0
ses/7/cephcsi/csi-attacher:v3.3.0
ses/7/cephcsi/csi-livenessprobe:v1.1.0
ses/7/cephcsi/csi-node-driver-registrar:v1.2.0
ses/7/cephcsi/csi-node-driver-registrar:v2.3.0
ses/7/cephcsi/csi-provisioner:v1.6.0
ses/7/cephcsi/csi-provisioner:v3.0.0
ses/7/cephcsi/csi-resizer:v0.4.0
ses/7/cephcsi/csi-resizer:v1.3.0
ses/7/cephcsi/csi-snapshotter:v2.1.0
ses/7/cephcsi/csi-snapshotter:v2.1.1
ses/7/cephcsi/csi-snapshotter:v4.2.0
ses/7/prometheus-webhook-snmp
ses/7/rook/ceph
suse/sle-micro/5.0/toolbox
suse/sle15:15.0
suse/sle15:15.1
suse/sle15:15.2
gpg2Affected
bci/bci-init:15.3
bci/node:12
bci/python:3
ses/7.1/rook/ceph
suse/sle-micro-rancher/5.2
suse/sle-micro-rancher/5.3
suse/sle15:15.3
suse/sle15:15.4
suse/sles12sp4
suse/sles12sp5
gpg2Released
bci/golang
bci/golang:1.16
bci/golang:1.17
bci/node:14
bci/nodejs
bci/openjdk
bci/openjdk-devel:11
bci/ruby
ses/7.1/ceph/grafana
ses/7.1/ceph/haproxy
ses/7.1/ceph/keepalived
ses/7.1/ceph/prometheus-alertmanager
ses/7.1/ceph/prometheus-node-exporter
ses/7.1/ceph/prometheus-server
ses/7.1/ceph/prometheus-snmp_notifier
ses/7.1/cephcsi/cephcsi
ses/7.1/cephcsi/csi-attacher:v3.4.0
ses/7.1/cephcsi/csi-node-driver-registrar:v2.5.0
ses/7.1/cephcsi/csi-provisioner:v3.1.0
ses/7.1/cephcsi/csi-resizer:v1.4.0
ses/7.1/cephcsi/csi-snapshotter:v5.0.1
suse/manager/4.3/proxy-httpd
suse/manager/4.3/proxy-salt-broker
suse/rmt-server
suse/rmt-server:2.7
suse/sle-micro/5.1/toolbox
suse/sle-micro/5.2/toolbox
suse/sle-micro/5.3/toolbox
suse/sles/15.3/cdi-importer:1.37.1
suse/sles/15.3/libguestfs-tools:0.45.0
suse/sles/15.4/cdi-importer:1.43.0
suse/sles/15.4/libguestfs-tools:0.49.0
suse/sles12sp3
gpg2In progress