Upstream information

CVE-2022-32213 at MITRE

Description

The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not correctly parse and validate Transfer-Encoding headers and can lead to HTTP Request Smuggling (HRS).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 6.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact Low None
Integrity Impact Low High
Availability Impact None High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1201325 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/nodejs:12-17.11
  • nodejs12 >= 12.22.12-150200.4.38.1
  • npm12 >= 12.22.12-150200.4.38.1
Container bci/nodejs:14-34.10
  • nodejs14 >= 14.20.1-150200.15.37.1
  • npm14 >= 14.20.1-150200.15.37.1
Container bci/nodejs:16-11.6
  • nodejs16 >= 16.17.1-150400.3.9.1
  • npm16 >= 16.17.1-150400.3.9.1
SUSE CaaS Platform 4.0
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • npm10 >= 10.24.1-150000.1.47.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2022-2855
SUSE Enterprise Storage 6
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • npm10 >= 10.24.1-150000.1.47.1
Patchnames:
SUSE-Storage-6-2022-2855
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Web and Scripting 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • nodejs12 >= 12.22.12-150200.4.38.1
  • nodejs12-devel >= 12.22.12-150200.4.38.1
  • nodejs12-docs >= 12.22.12-150200.4.38.1
  • nodejs14 >= 14.20.1-150200.15.37.1
  • nodejs14-devel >= 14.20.1-150200.15.37.1
  • nodejs14-docs >= 14.20.1-150200.15.37.1
  • nodejs16 >= 16.17.1-150300.7.12.1
  • nodejs16-devel >= 16.17.1-150300.7.12.1
  • nodejs16-docs >= 16.17.1-150300.7.12.1
  • npm12 >= 12.22.12-150200.4.38.1
  • npm14 >= 14.20.1-150200.15.37.1
  • npm16 >= 16.17.1-150300.7.12.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP3-2022-2425
SUSE-SLE-Module-Web-Scripting-15-SP3-2022-2430
SUSE-SLE-Module-Web-Scripting-15-SP3-2022-2551
SUSE-SLE-Module-Web-Scripting-15-SP3-2022-3614
SUSE-SLE-Module-Web-Scripting-15-SP3-2022-3615
SUSE-SLE-Module-Web-Scripting-15-SP3-2022-3616
SUSE Enterprise Storage 7
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • nodejs12 >= 12.22.12-150200.4.35.1
  • nodejs12-devel >= 12.22.12-150200.4.35.1
  • nodejs12-docs >= 12.22.12-150200.4.35.1
  • nodejs14 >= 14.20.0-150200.15.34.1
  • nodejs14-devel >= 14.20.0-150200.15.34.1
  • nodejs14-docs >= 14.20.0-150200.15.34.1
  • npm10 >= 10.24.1-150000.1.47.1
  • npm12 >= 12.22.12-150200.4.35.1
  • npm14 >= 14.20.0-150200.15.34.1
Patchnames:
SUSE-Storage-7-2022-2425
SUSE-Storage-7-2022-2430
SUSE-Storage-7-2022-2855
SUSE Linux Enterprise High Performance Computing 12
SUSE Linux Enterprise Module for Web and Scripting 12
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • nodejs12 >= 12.22.12-1.54.1
  • nodejs12-devel >= 12.22.12-1.54.1
  • nodejs12-docs >= 12.22.12-1.54.1
  • nodejs14 >= 14.20.1-6.34.1
  • nodejs14-devel >= 14.20.1-6.34.1
  • nodejs14-docs >= 14.20.1-6.34.1
  • nodejs16 >= 16.17.1-8.12.1
  • nodejs16-devel >= 16.17.1-8.12.1
  • nodejs16-docs >= 16.17.1-8.12.1
  • npm12 >= 12.22.12-1.54.1
  • npm14 >= 14.20.1-6.34.1
  • npm16 >= 16.17.1-8.12.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2022-2415
SUSE-SLE-Module-Web-Scripting-12-2022-2416
SUSE-SLE-Module-Web-Scripting-12-2022-2417
SUSE-SLE-Module-Web-Scripting-12-2022-3503
SUSE-SLE-Module-Web-Scripting-12-2022-3516
SUSE-SLE-Module-Web-Scripting-12-2022-3524
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • npm10 >= 10.24.1-150000.1.47.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-2855
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • npm10 >= 10.24.1-150000.1.47.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-2855
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • nodejs12 >= 12.22.12-150200.4.35.1
  • nodejs12-devel >= 12.22.12-150200.4.35.1
  • nodejs12-docs >= 12.22.12-150200.4.35.1
  • nodejs14 >= 14.20.0-150200.15.34.1
  • nodejs14-devel >= 14.20.0-150200.15.34.1
  • nodejs14-docs >= 14.20.0-150200.15.34.1
  • npm10 >= 10.24.1-150000.1.47.1
  • npm12 >= 12.22.12-150200.4.35.1
  • npm14 >= 14.20.0-150200.15.34.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-2425
SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-2430
SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-2855
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • nodejs12 >= 12.22.12-150200.4.35.1
  • nodejs12-devel >= 12.22.12-150200.4.35.1
  • nodejs12-docs >= 12.22.12-150200.4.35.1
  • nodejs14 >= 14.20.0-150200.15.34.1
  • nodejs14-devel >= 14.20.0-150200.15.34.1
  • nodejs14-docs >= 14.20.0-150200.15.34.1
  • npm10 >= 10.24.1-150000.1.47.1
  • npm12 >= 12.22.12-150200.4.35.1
  • npm14 >= 14.20.0-150200.15.34.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-2425
SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-2430
SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-2855
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Web and Scripting 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • nodejs16 >= 16.17.1-150400.3.9.1
  • nodejs16-devel >= 16.17.1-150400.3.9.1
  • nodejs16-docs >= 16.17.1-150400.3.9.1
  • npm16 >= 16.17.1-150400.3.9.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP4-2022-2491
SUSE-SLE-Module-Web-Scripting-15-SP4-2022-3656
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • npm10 >= 10.24.1-150000.1.47.1
Patchnames:
SUSE-SLE-Product-HPC-15-2022-2855
SUSE Linux Enterprise Server 15 SP1-BCL
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • npm10 >= 10.24.1-150000.1.47.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2022-2855
SUSE Linux Enterprise Server 15 SP1-LTSS
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • npm10 >= 10.24.1-150000.1.47.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-2855
SUSE Linux Enterprise Server 15 SP2-BCL
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • nodejs12 >= 12.22.12-150200.4.35.1
  • nodejs12-devel >= 12.22.12-150200.4.35.1
  • nodejs12-docs >= 12.22.12-150200.4.35.1
  • nodejs14 >= 14.20.0-150200.15.34.1
  • nodejs14-devel >= 14.20.0-150200.15.34.1
  • nodejs14-docs >= 14.20.0-150200.15.34.1
  • npm10 >= 10.24.1-150000.1.47.1
  • npm12 >= 12.22.12-150200.4.35.1
  • npm14 >= 14.20.0-150200.15.34.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-BCL-2022-2425
SUSE-SLE-Product-SLES-15-SP2-BCL-2022-2430
SUSE-SLE-Product-SLES-15-SP2-BCL-2022-2855
SUSE Linux Enterprise Server 15 SP2-LTSS
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • nodejs12 >= 12.22.12-150200.4.35.1
  • nodejs12-devel >= 12.22.12-150200.4.35.1
  • nodejs12-docs >= 12.22.12-150200.4.35.1
  • nodejs14 >= 14.20.0-150200.15.34.1
  • nodejs14-devel >= 14.20.0-150200.15.34.1
  • nodejs14-docs >= 14.20.0-150200.15.34.1
  • npm10 >= 10.24.1-150000.1.47.1
  • npm12 >= 12.22.12-150200.4.35.1
  • npm14 >= 14.20.0-150200.15.34.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-2425
SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-2430
SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-2855
SUSE Linux Enterprise Server 15-LTSS
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • npm10 >= 10.24.1-150000.1.47.1
Patchnames:
SUSE-SLE-Product-SLES-15-2022-2855
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • npm10 >= 10.24.1-150000.1.47.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2022-2855
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • nodejs12 >= 12.22.12-150200.4.35.1
  • nodejs12-devel >= 12.22.12-150200.4.35.1
  • nodejs12-docs >= 12.22.12-150200.4.35.1
  • nodejs14 >= 14.20.0-150200.15.34.1
  • nodejs14-devel >= 14.20.0-150200.15.34.1
  • nodejs14-docs >= 14.20.0-150200.15.34.1
  • npm10 >= 10.24.1-150000.1.47.1
  • npm12 >= 12.22.12-150200.4.35.1
  • npm14 >= 14.20.0-150200.15.34.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2022-2425
SUSE-SLE-Product-SLES_SAP-15-SP2-2022-2430
SUSE-SLE-Product-SLES_SAP-15-SP2-2022-2855
SUSE Linux Enterprise Server for SAP Applications 15
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • npm10 >= 10.24.1-150000.1.47.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2022-2855
SUSE Manager Proxy 4.1
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • nodejs12 >= 12.22.12-150200.4.35.1
  • nodejs12-devel >= 12.22.12-150200.4.35.1
  • nodejs12-docs >= 12.22.12-150200.4.35.1
  • nodejs14 >= 14.20.0-150200.15.34.1
  • nodejs14-devel >= 14.20.0-150200.15.34.1
  • nodejs14-docs >= 14.20.0-150200.15.34.1
  • npm10 >= 10.24.1-150000.1.47.1
  • npm12 >= 12.22.12-150200.4.35.1
  • npm14 >= 14.20.0-150200.15.34.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-2425
SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-2430
SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-2855
SUSE Manager Retail Branch Server 4.1
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • nodejs12 >= 12.22.12-150200.4.35.1
  • nodejs12-devel >= 12.22.12-150200.4.35.1
  • nodejs12-docs >= 12.22.12-150200.4.35.1
  • nodejs14 >= 14.20.0-150200.15.34.1
  • nodejs14-devel >= 14.20.0-150200.15.34.1
  • nodejs14-docs >= 14.20.0-150200.15.34.1
  • npm10 >= 10.24.1-150000.1.47.1
  • npm12 >= 12.22.12-150200.4.35.1
  • npm14 >= 14.20.0-150200.15.34.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-2425
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-2430
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-2855
SUSE Manager Server 4.1
  • nodejs10 >= 10.24.1-150000.1.47.1
  • nodejs10-devel >= 10.24.1-150000.1.47.1
  • nodejs10-docs >= 10.24.1-150000.1.47.1
  • nodejs12 >= 12.22.12-150200.4.35.1
  • nodejs12-devel >= 12.22.12-150200.4.35.1
  • nodejs12-docs >= 12.22.12-150200.4.35.1
  • nodejs14 >= 14.20.0-150200.15.34.1
  • nodejs14-devel >= 14.20.0-150200.15.34.1
  • nodejs14-docs >= 14.20.0-150200.15.34.1
  • npm10 >= 10.24.1-150000.1.47.1
  • npm12 >= 12.22.12-150200.4.35.1
  • npm14 >= 14.20.0-150200.15.34.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-2425
SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-2430
SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-2855
openSUSE Leap 15.3
  • nodejs10 >= 10.24.1-150000.1.50.1
  • nodejs10-devel >= 10.24.1-150000.1.50.1
  • nodejs10-docs >= 10.24.1-150000.1.50.1
  • nodejs12 >= 12.22.12-150200.4.38.1
  • nodejs12-devel >= 12.22.12-150200.4.38.1
  • nodejs12-docs >= 12.22.12-150200.4.38.1
  • nodejs14 >= 14.20.1-150200.15.37.1
  • nodejs14-devel >= 14.20.1-150200.15.37.1
  • nodejs14-docs >= 14.20.1-150200.15.37.1
  • nodejs16 >= 16.17.1-150300.7.12.1
  • nodejs16-devel >= 16.17.1-150300.7.12.1
  • nodejs16-docs >= 16.17.1-150300.7.12.1
  • npm10 >= 10.24.1-150000.1.50.1
  • npm12 >= 12.22.12-150200.4.38.1
  • npm14 >= 14.20.1-150200.15.37.1
  • npm16 >= 16.17.1-150300.7.12.1
Patchnames:
openSUSE-SLE-15.3-2022-2425
openSUSE-SLE-15.3-2022-2430
openSUSE-SLE-15.3-2022-2551
openSUSE-SLE-15.3-2022-2855
openSUSE-SLE-15.3-2022-3614
openSUSE-SLE-15.3-2022-3615
openSUSE-SLE-15.3-2022-3616
openSUSE-SLE-15.3-2022-3835
openSUSE Leap 15.4
  • corepack14 >= 14.20.1-150200.15.37.1
  • corepack16 >= 16.17.1-150400.3.9.1
  • nodejs10 >= 10.24.1-150000.1.50.1
  • nodejs10-devel >= 10.24.1-150000.1.50.1
  • nodejs10-docs >= 10.24.1-150000.1.50.1
  • nodejs12 >= 12.22.12-150200.4.38.1
  • nodejs12-devel >= 12.22.12-150200.4.38.1
  • nodejs12-docs >= 12.22.12-150200.4.38.1
  • nodejs14 >= 14.20.1-150200.15.37.1
  • nodejs14-devel >= 14.20.1-150200.15.37.1
  • nodejs14-docs >= 14.20.1-150200.15.37.1
  • nodejs16 >= 16.17.1-150400.3.9.1
  • nodejs16-devel >= 16.17.1-150400.3.9.1
  • nodejs16-docs >= 16.17.1-150400.3.9.1
  • npm10 >= 10.24.1-150000.1.50.1
  • npm12 >= 12.22.12-150200.4.38.1
  • npm14 >= 14.20.1-150200.15.37.1
  • npm16 >= 16.17.1-150400.3.9.1
Patchnames:
openSUSE-SLE-15.4-2022-2425
openSUSE-SLE-15.4-2022-2430
openSUSE-SLE-15.4-2022-2491
openSUSE-SLE-15.4-2022-2855
openSUSE-SLE-15.4-2022-3614
openSUSE-SLE-15.4-2022-3616
openSUSE-SLE-15.4-2022-3656
openSUSE-SLE-15.4-2022-3835
openSUSE Tumbleweed
  • corepack16 >= 16.16.0-1.1
  • corepack18 >= 18.9.0-1.1
  • nodejs16 >= 16.16.0-1.1
  • nodejs16-devel >= 16.16.0-1.1
  • nodejs16-docs >= 16.16.0-1.1
  • nodejs18 >= 18.9.0-1.1
  • nodejs18-devel >= 18.9.0-1.1
  • nodejs18-docs >= 18.9.0-1.1
  • npm16 >= 16.16.0-1.1
  • npm18 >= 18.9.0-1.1
  • python310-httptools >= 0.5.0-1.1
  • python38-httptools >= 0.5.0-1.1
  • python39-httptools >= 0.5.0-1.1
Patchnames:
openSUSE Tumbleweed GA corepack16-16.16.0-1.1
openSUSE Tumbleweed GA corepack18-18.9.0-1.1
openSUSE Tumbleweed GA python310-httptools-0.5.0-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 nodejs10 Released
SUSE Enterprise Storage 7 nodejs12 Released
SUSE Enterprise Storage 7 nodejs14 Released
SUSE Enterprise Storage 7 nodejs8 Unsupported
SUSE Enterprise Storage 7.1 nodejs12 Released
SUSE Enterprise Storage 7.1 nodejs14 Released
SUSE Enterprise Storage 7.1 nodejs16 Released
SUSE Linux Enterprise High Performance Computing 12 nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 12 nodejs12 Released
SUSE Linux Enterprise High Performance Computing 12 nodejs14 Released
SUSE Linux Enterprise High Performance Computing 12 nodejs16 Released
SUSE Linux Enterprise High Performance Computing 12 nodejs4 Unsupported
SUSE Linux Enterprise High Performance Computing 12 nodejs6 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4 nodejs16 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs10 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs12 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs14 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs16 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs6 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 SP4 nodejs16 Released
SUSE Linux Enterprise Server 12 SP5 nodejs10 Unsupported
SUSE Linux Enterprise Server 12 SP5 nodejs12 Released
SUSE Linux Enterprise Server 12 SP5 nodejs14 Released
SUSE Linux Enterprise Server 12 SP5 nodejs16 Released
SUSE Linux Enterprise Server 12 SP5 nodejs4 Unsupported
SUSE Linux Enterprise Server 12 SP5 nodejs6 Unsupported
SUSE Linux Enterprise Server 15 SP4 nodejs16 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs12 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs14 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs16 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs4 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs6 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP4 nodejs16 Released
SUSE Manager Proxy 4.2 nodejs12 Released
SUSE Manager Proxy 4.2 nodejs14 Released
SUSE Manager Proxy 4.2 nodejs16 Released
SUSE Manager Proxy 4.3 nodejs16 Released
SUSE Manager Retail Branch Server 4.2 nodejs12 Released
SUSE Manager Retail Branch Server 4.2 nodejs14 Released
SUSE Manager Retail Branch Server 4.2 nodejs16 Released
SUSE Manager Retail Branch Server 4.3 nodejs16 Released
SUSE Manager Server 4.2 nodejs12 Released
SUSE Manager Server 4.2 nodejs14 Released
SUSE Manager Server 4.2 nodejs16 Released
SUSE Manager Server 4.3 nodejs16 Released
openSUSE Leap 15.4 nodejs10 Released
openSUSE Leap 15.4 nodejs16 Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 nodejs10 Affected
SUSE Linux Enterprise High Performance Computing 15 nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 nodejs10 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS nodejs10 Released
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS nodejs10 Released
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2 nodejs10 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 nodejs12 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 nodejs14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS nodejs10 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS nodejs12 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS nodejs14 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS nodejs10 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS nodejs12 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS nodejs14 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 nodejs12 Released
SUSE Linux Enterprise High Performance Computing 15 SP3 nodejs14 Released
SUSE Linux Enterprise High Performance Computing 15 SP3 nodejs16 Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS nodejs12 Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS nodejs14 Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS nodejs16 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS nodejs12 Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS nodejs14 Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS nodejs16 Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS nodejs10 Released
SUSE Linux Enterprise High Performance Computing 15-ESPOS nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS nodejs10 Released
SUSE Linux Enterprise High Performance Computing 15-LTSS nodejs8 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 SP1 nodejs10 Affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP1 nodejs8 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs10 Affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs12 Affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs14 Affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs8 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 nodejs12 Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 nodejs14 Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 nodejs16 Released
SUSE Linux Enterprise Server 12 SP4 nodejs10 Unsupported
SUSE Linux Enterprise Server 12 SP4 nodejs12 Released
SUSE Linux Enterprise Server 12 SP4 nodejs14 Released
SUSE Linux Enterprise Server 12 SP4 nodejs16 Released
SUSE Linux Enterprise Server 12 SP4 nodejs4 Unsupported
SUSE Linux Enterprise Server 12 SP4 nodejs6 Unsupported
SUSE Linux Enterprise Server 15 SP1 nodejs10 Affected
SUSE Linux Enterprise Server 15 SP1 nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS nodejs10 Released
SUSE Linux Enterprise Server 15 SP1-LTSS nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP2 nodejs10 Affected
SUSE Linux Enterprise Server 15 SP2 nodejs12 Affected
SUSE Linux Enterprise Server 15 SP2 nodejs14 Affected
SUSE Linux Enterprise Server 15 SP2 nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS nodejs10 Released
SUSE Linux Enterprise Server 15 SP2-LTSS nodejs12 Released
SUSE Linux Enterprise Server 15 SP2-LTSS nodejs14 Released
SUSE Linux Enterprise Server 15 SP2-LTSS nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP3 nodejs12 Released
SUSE Linux Enterprise Server 15 SP3 nodejs14 Released
SUSE Linux Enterprise Server 15 SP3 nodejs16 Released
SUSE Linux Enterprise Server 15 SP3-LTSS nodejs12 Affected
SUSE Linux Enterprise Server 15 SP3-LTSS nodejs14 Affected
SUSE Linux Enterprise Server 15 SP3-LTSS nodejs16 Affected
SUSE Linux Enterprise Server 15-ESPOS nodejs10 Released
SUSE Linux Enterprise Server 15-ESPOS nodejs8 Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 nodejs10 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 nodejs8 Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 nodejs10 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 nodejs12 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 nodejs14 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 nodejs8 Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 nodejs12 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 nodejs14 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 nodejs16 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs12 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs14 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs16 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs4 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs6 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 nodejs10 Released
SUSE Linux Enterprise Server for SAP Applications 15 nodejs8 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 nodejs10 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 nodejs8 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 nodejs10 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 nodejs12 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 nodejs14 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 nodejs8 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 nodejs12 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 nodejs14 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 nodejs16 Released
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 nodejs10 Released
SUSE CaaS Platform 4.0 nodejs8 Unsupported
SUSE Enterprise Storage 4 nodejs4 Unsupported
SUSE Enterprise Storage 4 nodejs6 Unsupported
SUSE Enterprise Storage 6 nodejs10 Released
SUSE Enterprise Storage 6 nodejs8 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs10 Affected
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs8 Unsupported
SUSE Linux Enterprise Server 12 nodejs10 Unsupported
SUSE Linux Enterprise Server 12 nodejs12 Released
SUSE Linux Enterprise Server 12 nodejs14 Released
SUSE Linux Enterprise Server 12 nodejs16 Released
SUSE Linux Enterprise Server 12 nodejs4 Unsupported
SUSE Linux Enterprise Server 12 nodejs6 Unsupported
SUSE Linux Enterprise Server 12 SP3 nodejs10 Unsupported
SUSE Linux Enterprise Server 12 SP3 nodejs12 Released
SUSE Linux Enterprise Server 12 SP3 nodejs14 Released
SUSE Linux Enterprise Server 12 SP3 nodejs16 Released
SUSE Linux Enterprise Server 12 SP3 nodejs4 Unsupported
SUSE Linux Enterprise Server 12 SP3 nodejs6 Unsupported
SUSE Linux Enterprise Server 15 nodejs10 Affected
SUSE Linux Enterprise Server 15 nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL nodejs10 Released
SUSE Linux Enterprise Server 15 SP1-BCL nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL nodejs10 Released
SUSE Linux Enterprise Server 15 SP2-BCL nodejs12 Released
SUSE Linux Enterprise Server 15 SP2-BCL nodejs14 Released
SUSE Linux Enterprise Server 15 SP2-BCL nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL nodejs12 Affected
SUSE Linux Enterprise Server 15 SP3-BCL nodejs14 Affected
SUSE Linux Enterprise Server 15 SP3-BCL nodejs16 Affected
SUSE Linux Enterprise Server 15-LTSS nodejs10 Released
SUSE Linux Enterprise Server 15-LTSS nodejs8 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 nodejs12 Released
SUSE Linux Enterprise Server for SAP Applications 12 nodejs14 Released
SUSE Linux Enterprise Server for SAP Applications 12 nodejs16 Released
SUSE Linux Enterprise Server for SAP Applications 12 nodejs4 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 nodejs6 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs12 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs14 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs16 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs4 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs6 Unsupported
SUSE Manager Proxy 4.0 nodejs10 Affected
SUSE Manager Proxy 4.0 nodejs8 Unsupported
SUSE Manager Proxy 4.1 nodejs10 Released
SUSE Manager Proxy 4.1 nodejs12 Released
SUSE Manager Proxy 4.1 nodejs14 Released
SUSE Manager Proxy 4.1 nodejs8 Unsupported
SUSE Manager Retail Branch Server 4.0 nodejs10 Affected
SUSE Manager Retail Branch Server 4.0 nodejs8 Unsupported
SUSE Manager Retail Branch Server 4.1 nodejs10 Released
SUSE Manager Retail Branch Server 4.1 nodejs12 Released
SUSE Manager Retail Branch Server 4.1 nodejs14 Released
SUSE Manager Retail Branch Server 4.1 nodejs8 Unsupported
SUSE Manager Server 4.0 nodejs10 Affected
SUSE Manager Server 4.0 nodejs8 Unsupported
SUSE Manager Server 4.1 nodejs10 Released
SUSE Manager Server 4.1 nodejs12 Released
SUSE Manager Server 4.1 nodejs14 Released
SUSE Manager Server 4.1 nodejs8 Unsupported
SUSE OpenStack Cloud 7 nodejs6 Unsupported
SUSE OpenStack Cloud Crowbar 8 nodejs6 Unsupported
SUSE OpenStack Cloud Crowbar 9 nodejs6 Unsupported
openSUSE Leap 15.3 nodejs16 Released
Container Status
bci/node:12 nodejs12Released
bci/node:14 nodejs14Released
bci/nodejs nodejs16Released


SUSE Timeline for this CVE

CVE page created: Fri Jul 8 12:30:15 2022
CVE page last modified: Fri Jan 20 16:37:23 2023