Upstream information

CVE-2022-31015 at MITRE

Description

Waitress is a Web Server Gateway Interface server for Python 2 and 3. Waitress versions 2.1.0 and 2.1.1 may terminate early due to a thread closing a socket while the main thread is about to call select(). This will lead to the main thread raising an exception that is not handled and then causing the entire application to be killed. This issue has been fixed in Waitress 2.1.2 by no longer allowing the WSGI thread to close the socket. Instead, that is always delegated to the main thread. There is no work-around for this issue. However, users using waitress behind a reverse proxy server are less likely to have issues if the reverse proxy always reads the full response.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 5.9
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity High High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1200126 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • python310-waitress >= 2.1.2-3.1
  • python38-waitress >= 2.1.2-3.1
  • python39-waitress >= 2.1.2-3.1
Patchnames:
openSUSE Tumbleweed GA python310-waitress-2.1.2-3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 python-waitress Not affected
SUSE CaaS Platform 4.0 python-waitress Not affected
SUSE Enterprise Storage 6 python-waitress Not affected
SUSE Enterprise Storage 7 python-waitress Not affected
SUSE Linux Enterprise Desktop 15 SP3 python-waitress Not affected
SUSE Linux Enterprise Desktop 15 SP4 python-waitress Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS python-waitress Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS python-waitress Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS python-waitress Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS python-waitress Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS python-waitress Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 python-waitress Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 python-waitress Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 python-waitress Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 python-waitress Not affected
SUSE Linux Enterprise Server 15 ESPOS python-waitress Not affected
SUSE Linux Enterprise Server 15 LTSS python-waitress Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS python-waitress Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS python-waitress Not affected
SUSE Linux Enterprise Server 15 SP3 python-waitress Not affected
SUSE Linux Enterprise Server 15 SP4 python-waitress Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 python-waitress Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 python-waitress Not affected
SUSE Linux Enterprise Server for SAP Applications 15 python-waitress Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python-waitress Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 python-waitress Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 python-waitress Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 python-waitress Not affected
SUSE Linux Enterprise Storage 7.1 python-waitress Not affected
SUSE Manager Proxy 4.1 python-waitress Not affected
SUSE Manager Proxy 4.2 python-waitress Not affected
SUSE Manager Proxy 4.3 python-waitress Not affected
SUSE Manager Retail Branch Server 4.1 python-waitress Not affected
SUSE Manager Retail Branch Server 4.2 python-waitress Not affected
SUSE Manager Retail Branch Server 4.3 python-waitress Not affected
SUSE Manager Server 4.1 python-waitress Not affected
SUSE Manager Server 4.2 python-waitress Not affected
SUSE Manager Server 4.3 python-waitress Not affected
SUSE OpenStack Cloud 8 python-waitress Not affected
SUSE OpenStack Cloud 9 python-waitress Not affected
SUSE OpenStack Cloud Crowbar 8 python-waitress Not affected
SUSE OpenStack Cloud Crowbar 9 python-waitress Not affected