Upstream information

CVE-2022-31008 at MITRE

Description

RabbitMQ is a multi-protocol messaging and streaming broker. In affected versions the shovel and federation plugins perform URI obfuscation in their worker (link) state. The encryption key used to encrypt the URI was seeded with a predictable secret. This means that in case of certain exceptions related to Shovel and Federation plugins, reasonably easily deobfuscatable data could appear in the node log. Patched versions correctly use a cluster-wide secret for that purpose. This issue has been addressed and Patched versions: `3.10.2`, `3.9.18`, `3.8.32` are available. Users unable to upgrade should disable the Shovel and Federation plugins.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1205267 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Server Applications 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • erlang-rabbitmq-client >= 3.8.11-150300.3.11.1
  • rabbitmq-server >= 3.8.11-150300.3.11.1
  • rabbitmq-server-plugins >= 3.8.11-150300.3.11.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP3-2022-4378
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Server Applications 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • erlang-rabbitmq-client >= 3.8.11-150300.3.11.1
  • rabbitmq-server >= 3.8.11-150300.3.11.1
  • rabbitmq-server-plugins >= 3.8.11-150300.3.11.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP4-2022-4378
openSUSE Leap 15.3
  • erlang-rabbitmq-client >= 3.8.11-150300.3.11.1
  • rabbitmq-server >= 3.8.11-150300.3.11.1
  • rabbitmq-server-plugins >= 3.8.11-150300.3.11.1
Patchnames:
openSUSE-SLE-15.3-2022-4378
openSUSE Leap 15.4
  • erlang-rabbitmq-client >= 3.8.11-150300.3.11.1
  • rabbitmq-server >= 3.8.11-150300.3.11.1
  • rabbitmq-server-plugins >= 3.8.11-150300.3.11.1
Patchnames:
openSUSE-SLE-15.4-2022-4378


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 rabbitmq-server Unsupported
SUSE Enterprise Storage 7.1 rabbitmq-server Released
SUSE Linux Enterprise High Performance Computing 15 SP4 rabbitmq-server Released
SUSE Linux Enterprise Module for Server Applications 15 SP4 rabbitmq-server Released
SUSE Linux Enterprise Real Time 15 SP3 rabbitmq-server Released
SUSE Linux Enterprise Server 15 SP4 rabbitmq-server Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 rabbitmq-server Released
SUSE Manager Proxy 4.2 rabbitmq-server Released
SUSE Manager Proxy 4.3 rabbitmq-server Released
SUSE Manager Retail Branch Server 4.2 rabbitmq-server Released
SUSE Manager Retail Branch Server 4.3 rabbitmq-server Released
SUSE Manager Server 4.2 rabbitmq-server Released
SUSE Manager Server 4.3 rabbitmq-server Released
openSUSE Leap 15.4 rabbitmq-server Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 rabbitmq-server Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS rabbitmq-server Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS rabbitmq-server Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 rabbitmq-server Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS rabbitmq-server Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS rabbitmq-server Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 rabbitmq-server Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP3 rabbitmq-server Released
SUSE Linux Enterprise Server 15 SP2 rabbitmq-server Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS rabbitmq-server Unsupported
SUSE Linux Enterprise Server 15 SP3 rabbitmq-server Released
SUSE Linux Enterprise Server 15 SP3-LTSS rabbitmq-server Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 rabbitmq-server Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 rabbitmq-server Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 rabbitmq-server Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rabbitmq-server Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 rabbitmq-server Unsupported
SUSE Linux Enterprise Real Time 15 SP2 rabbitmq-server Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL rabbitmq-server Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL rabbitmq-server Affected
SUSE Manager Proxy 4.1 rabbitmq-server Unsupported
SUSE Manager Retail Branch Server 4.1 rabbitmq-server Unsupported
SUSE Manager Server 4.1 rabbitmq-server Unsupported
SUSE OpenStack Cloud 8 rabbitmq-server Unsupported
SUSE OpenStack Cloud 9 rabbitmq-server Unsupported
SUSE OpenStack Cloud Crowbar 8 rabbitmq-server Unsupported
SUSE OpenStack Cloud Crowbar 9 rabbitmq-server Unsupported
openSUSE Leap 15.3 rabbitmq-server Released


SUSE Timeline for this CVE

CVE page created: Fri Oct 7 02:01:26 2022
CVE page last modified: Fri Jan 20 16:35:59 2023