Upstream information

CVE-2022-30122 at MITRE

Description

A possible denial of service vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 in the multipart parsing component of Rack.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1200748 [RESOLVED / FIXED], 1201588 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP1-SAP-Azure-LI-BYOS-Production
Image SLES15-SP1-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-SAP-Azure
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-SAP-BYOS-Azure
Image SLES15-SP2-SAP-BYOS-EC2-HVM
Image SLES15-SP2-SAP-BYOS-GCE
Image SLES15-SP2-SAP-EC2-HVM
Image SLES15-SP2-SAP-GCE
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-BYOS-Azure
Image SLES15-SP3-SAP-BYOS-EC2-HVM
Image SLES15-SP3-SAP-BYOS-GCE
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP4-SAP-BYOS
Image SLES15-SP4-SAP-BYOS-Azure
Image SLES15-SP4-SAP-BYOS-EC2
Image SLES15-SP4-SAP-BYOS-GCE
Image SLES15-SP4-SAP-Hardened-BYOS
Image SLES15-SP4-SAP-Hardened-BYOS-Azure
Image SLES15-SP4-SAP-Hardened-BYOS-EC2
Image SLES15-SP4-SAP-Hardened-BYOS-GCE
  • ruby2.5-rubygem-rack >= 2.0.8-150000.3.6.1
SUSE Linux Enterprise High Availability Extension 15 SP1
  • ruby2.5-rubygem-rack >= 2.0.8-150000.3.6.1
Patchnames:
SUSE-SLE-Product-HA-15-SP1-2022-2192
SUSE Linux Enterprise High Availability Extension 15 SP2
  • ruby2.5-rubygem-rack >= 2.0.8-150000.3.6.1
Patchnames:
SUSE-SLE-Product-HA-15-SP2-2022-2192
SUSE Linux Enterprise High Availability Extension 15 SP3
  • ruby2.5-rubygem-rack >= 2.0.8-150000.3.6.1
Patchnames:
SUSE-SLE-Product-HA-15-SP3-2022-2192
SUSE Linux Enterprise High Availability Extension 15 SP4
  • ruby2.5-rubygem-rack >= 2.0.8-150000.3.6.1
Patchnames:
SUSE-SLE-Product-HA-15-SP4-2022-2192
SUSE Linux Enterprise High Availability Extension 15
  • ruby2.5-rubygem-rack >= 2.0.8-150000.3.6.1
Patchnames:
SUSE-SLE-Product-HA-15-2022-2192
SUSE OpenStack Cloud Crowbar 8
  • ruby2.1-rubygem-rack >= 1.6.13-3.13.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2022-2526
SUSE OpenStack Cloud Crowbar 9
  • ruby2.1-rubygem-rack >= 1.6.13-3.13.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2022-2526
openSUSE Leap 15.3
  • ruby2.5-rubygem-rack >= 2.0.8-150000.3.6.1
  • ruby2.5-rubygem-rack-doc >= 2.0.8-150000.3.6.1
  • ruby2.5-rubygem-rack-testsuite >= 2.0.8-150000.3.6.1
Patchnames:
openSUSE-SLE-15.3-2022-2192
openSUSE Leap 15.4
  • ruby2.5-rubygem-rack >= 2.0.8-150000.3.6.1
  • ruby2.5-rubygem-rack-doc >= 2.0.8-150000.3.6.1
  • ruby2.5-rubygem-rack-testsuite >= 2.0.8-150000.3.6.1
Patchnames:
openSUSE-SLE-15.4-2022-2192
openSUSE Tumbleweed
  • ruby3.1-rubygem-rack >= 2.2.3.1-1.1
  • ruby3.1-rubygem-rack-2.2 >= 2.2.4-1.1
Patchnames:
openSUSE Tumbleweed GA ruby3.1-rubygem-rack-2.2-2.2.4-1.1
openSUSE Tumbleweed GA ruby3.1-rubygem-rack-2.2.3.1-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Availability Extension 15 SP4 rubygem-rack Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-rack Released
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-rack Released
SUSE Linux Enterprise High Availability Extension 15 SP3 rubygem-rack Released
Products past their end of life and not receiving proactive updates anymore.
SUSE Enterprise Storage 2.1 rubygem-rack Affected
SUSE Enterprise Storage 3 rubygem-rack Affected
SUSE Enterprise Storage 4 rubygem-rack Affected
SUSE Linux Enterprise High Availability Extension 15 rubygem-rack Released
SUSE OpenStack Cloud 6 rubygem-rack Affected
SUSE OpenStack Cloud 6-LTSS rubygem-rack Affected
SUSE OpenStack Cloud 7 rubygem-rack Affected
SUSE OpenStack Cloud Crowbar 8 rubygem-rack Released
SUSE OpenStack Cloud Crowbar 9 rubygem-rack Released


SUSE Timeline for this CVE

CVE page created: Tue Jun 21 10:04:22 2022
CVE page last modified: Wed Feb 8 15:52:51 2023