Upstream information

CVE-2022-28331 at MITRE

Description

On Windows, Apache Portable Runtime 1.7.0 and earlier may write beyond the end of a stack based buffer in apr_socket_sendv(). This is a result of integer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1207871 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 apr Not affected
SUSE Linux Enterprise Desktop 15 SP5 apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 apr Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP5 apr Not affected
SUSE Linux Enterprise Real Time 15 SP3 apr Not affected
SUSE Linux Enterprise Server 15 SP5 apr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 apr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 apr Not affected
SUSE Manager Proxy 4.3 apr Not affected
SUSE Manager Retail Branch Server 4.3 apr Not affected
SUSE Manager Server 4.3 apr Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 apr Not affected
SUSE Linux Enterprise High Performance Computing 15 apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS apr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS apr Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS apr Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS apr Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 apr Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 apr Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 apr Not affected
SUSE Linux Enterprise Server 15 SP2 apr Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS apr Not affected
SUSE Linux Enterprise Server 15 SP3 apr Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS apr Not affected
SUSE Linux Enterprise Server 15 SP4 apr Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS apr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 apr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 apr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 apr Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 apr Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 apr Not affected
SUSE Enterprise Storage 6 apr Not affected
SUSE Enterprise Storage 7 apr Not affected
SUSE Linux Enterprise Desktop 15 apr Not affected
SUSE Linux Enterprise Desktop 15 SP1 apr Not affected
SUSE Linux Enterprise Desktop 15 SP2 apr Not affected
SUSE Linux Enterprise Desktop 15 SP3 apr Not affected
SUSE Linux Enterprise Module for Basesystem 15 apr Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 apr Not affected
SUSE Linux Enterprise Real Time 15 SP2 apr Not affected
SUSE Linux Enterprise Real Time 15 SP4 apr Not affected
SUSE Linux Enterprise Server 15 apr Not affected
SUSE Linux Enterprise Server 15 SP1 apr Not affected
SUSE Linux Enterprise Server 15 SP1-BCL apr Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS apr Not affected
SUSE Linux Enterprise Server 15 SP2-BCL apr Not affected
SUSE Linux Enterprise Server 15 SP3-BCL apr Not affected
SUSE Linux Enterprise Server 15-LTSS apr Not affected
SUSE Manager Proxy 4.0 apr Not affected
SUSE Manager Proxy 4.1 apr Not affected
SUSE Manager Proxy 4.2 apr Not affected
SUSE Manager Retail Branch Server 4.0 apr Not affected
SUSE Manager Retail Branch Server 4.1 apr Not affected
SUSE Manager Retail Branch Server 4.2 apr Not affected
SUSE Manager Server 4.0 apr Not affected
SUSE Manager Server 4.1 apr Not affected
SUSE Manager Server 4.2 apr Not affected


SUSE Timeline for this CVE

CVE page created: Thu Feb 2 21:00:16 2023
CVE page last modified: Thu Feb 22 17:20:45 2024