Upstream information

CVE-2022-26280 at MITRE

Description

Libarchive v3.6.0 was discovered to contain an out-of-bounds read via the component zipx_lzma_alone_init.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.1 7.4
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1197634 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP3-Manager-4-2-Server-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Server-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Server-BYOS-GCE
Image SLES15-SP3-SAPCAL-Azure
Image SLES15-SP3-SAPCAL-EC2-HVM
Image SLES15-SP3-SAPCAL-GCE
  • libarchive13 >= 3.4.2-150200.4.6.1
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-Azure
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Server-4-3-BYOS-GCE
Image SLES15-SP4-SAP
Image SLES15-SP4-SAP-Azure
Image SLES15-SP4-SAP-EC2
Image SLES15-SP4-SAP-GCE
Image SLES15-SP4-SAPCAL
Image SLES15-SP4-SAPCAL-Azure
Image SLES15-SP4-SAPCAL-EC2
Image SLES15-SP4-SAPCAL-GCE
  • libarchive13 >= 3.5.1-150400.3.3.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • bsdtar >= 3.4.2-150200.4.6.1
  • libarchive-devel >= 3.4.2-150200.4.6.1
  • libarchive13 >= 3.4.2-150200.4.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-1803
SUSE-SLE-Module-Development-Tools-15-SP3-2022-1803
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • bsdtar >= 3.5.1-150400.3.3.1
  • libarchive-devel >= 3.5.1-150400.3.3.1
  • libarchive13 >= 3.5.1-150400.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2022-1930
SUSE-SLE-Module-Development-Tools-15-SP4-2022-1930
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libarchive-devel >= 3.4.2-150200.4.6.1
  • libarchive13 >= 3.4.2-150200.4.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-1803
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libarchive-devel >= 3.5.1-150400.3.3.1
  • libarchive13 >= 3.5.1-150400.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2022-1930
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • bsdtar >= 3.4.2-150200.4.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2022-1803
SUSE Linux Enterprise Module for Development Tools 15 SP4
  • bsdtar >= 3.5.1-150400.3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP4-2022-1930
openSUSE Leap 15.3
  • bsdtar >= 3.4.2-150200.4.6.1
  • libarchive-devel >= 3.4.2-150200.4.6.1
  • libarchive13 >= 3.4.2-150200.4.6.1
  • libarchive13-32bit >= 3.4.2-150200.4.6.1
Patchnames:
openSUSE-SLE-15.3-2022-1803
openSUSE Leap 15.4
  • bsdtar >= 3.5.1-150400.3.3.1
  • libarchive-devel >= 3.5.1-150400.3.3.1
  • libarchive13 >= 3.5.1-150400.3.3.1
  • libarchive13-32bit >= 3.5.1-150400.3.3.1
Patchnames:
openSUSE-SLE-15.4-2022-1930


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libarchive Not affected
SUSE CaaS Platform 4.0 libarchive Not affected
SUSE Enterprise Storage 6 libarchive Not affected
SUSE Enterprise Storage 7 libarchive Released
SUSE Linux Enterprise Desktop 15 SP3 libarchive Released
SUSE Linux Enterprise Desktop 15 SP4 libarchive Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libarchive Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS libarchive Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS libarchive Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS libarchive Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS libarchive Released
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS libarchive Released
SUSE Linux Enterprise High Performance Computing 15 SP3 libarchive Released
SUSE Linux Enterprise High Performance Computing 15 SP4 libarchive Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 libarchive Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 libarchive Released
SUSE Linux Enterprise Module for Development Tools 15 SP3 libarchive Released
SUSE Linux Enterprise Module for Development Tools 15 SP4 libarchive Released
SUSE Linux Enterprise Real Time 15 SP2 libarchive Released
SUSE Linux Enterprise Server 12 SP2 BCL libarchive Not affected
SUSE Linux Enterprise Server 12 SP3 BCL libarchive Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS libarchive Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS libarchive Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS libarchive Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS libarchive Not affected
SUSE Linux Enterprise Server 12 SP5 libarchive Not affected
SUSE Linux Enterprise Server 15 ESPOS libarchive Not affected
SUSE Linux Enterprise Server 15 LTSS libarchive Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS libarchive Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS libarchive Released
SUSE Linux Enterprise Server 15 SP3 libarchive Released
SUSE Linux Enterprise Server 15 SP4 libarchive Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libarchive Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libarchive Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libarchive Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libarchive Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libarchive Not affected
SUSE Linux Enterprise Server for SAP Applications 15 libarchive Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libarchive Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libarchive Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libarchive Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libarchive Released
SUSE Linux Enterprise Storage 7.1 libarchive Released
SUSE Manager Proxy 4.1 libarchive Released
SUSE Manager Proxy 4.2 libarchive Released
SUSE Manager Proxy 4.3 libarchive Released
SUSE Manager Retail Branch Server 4.1 libarchive Released
SUSE Manager Retail Branch Server 4.2 libarchive Released
SUSE Manager Retail Branch Server 4.3 libarchive Released
SUSE Manager Server 4.1 libarchive Released
SUSE Manager Server 4.2 libarchive Released
SUSE Manager Server 4.3 libarchive Released
SUSE OpenStack Cloud 8 libarchive Not affected
SUSE OpenStack Cloud 9 libarchive Not affected
SUSE OpenStack Cloud Crowbar 8 libarchive Not affected
SUSE OpenStack Cloud Crowbar 9 libarchive Not affected