Upstream information

CVE-2022-24828 at MITRE

Description

Composer is a dependency manager for the PHP programming language. Integrators using Composer code to call `VcsDriver::getFileContent` can have a code injection vulnerability if the user can control the `$file` or `$identifier` argument. This leads to a vulnerability on packagist.org for example where the composer.json's `readme` field can be used as a vector for injecting parameters into hg/Mercurial via the `$file` argument, or git via the `$identifier` argument if you allow arbitrary data there (Packagist does not, but maybe other integrators do). Composer itself should not be affected by the vulnerability as it does not call `getFileContent` with arbitrary data into `$file`/`$identifier`. To the best of our knowledge this was not abused, and the vulnerability has been patched on packagist.org and Private Packagist within a day of the vulnerability report.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.3 7
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Network Local
Attack Complexity High High
Privileges Required None None
User Interaction Required Required
Scope Changed Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1198494 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/php-apache:8-4.1
Container bci/php-apache:latest
Container bci/php-fpm:8-4.1
Container bci/php-fpm:latest
Container bci/php:8-4.1
Container bci/php:latest
  • php-composer2 >= 2.2.3-150400.3.3.1
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Web and Scripting 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • php-composer2 >= 2.2.3-150400.3.3.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP4-2022-3020
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Web and Scripting 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • php-composer2 >= 2.2.3-150400.3.3.1
Patchnames:
SUSE Linux Enterprise Module for Web and Scripting 15 SP5 GA php-composer2-2.2.3-150400.3.3.1
SUSE Package Hub 15 SP3
  • php-composer >= 1.10.26-bp153.2.6.1
Patchnames:
openSUSE-2022-132
openSUSE Leap 15.3
  • php-composer >= 1.10.26-bp153.2.6.1
Patchnames:
openSUSE-2022-132
openSUSE Leap 15.4
  • php-composer2 >= 2.2.3-150400.3.3.1
Patchnames:
openSUSE-SLE-15.4-2022-3020
openSUSE Tumbleweed
  • php-composer >= 1.10.26-1.1
  • php-composer2 >= 2.3.5-1.1
Patchnames:
openSUSE-Tumbleweed-2024-12048
openSUSE-Tumbleweed-2024-12054


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP5 php-composer2 Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP5 php-composer2 Released
SUSE Linux Enterprise Server 15 SP5 php-composer2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 php-composer2 Released
SUSE Manager Proxy 4.3 php-composer2 Released
SUSE Manager Retail Branch Server 4.3 php-composer2 Released
SUSE Manager Server 4.3 php-composer2 Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP4 php-composer2 Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS php-composer2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS php-composer2 Affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP4 php-composer2 Released
SUSE Linux Enterprise Server 15 SP4 php-composer2 Released
SUSE Linux Enterprise Server 15 SP4-LTSS php-composer2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 php-composer2 Released
Products past their end of life and not receiving proactive updates anymore.
SUSE Package Hub 15 SP3 php-composer Released
Container Status
bci/php
bci/php-apache
bci/php-apache:8
bci/php-fpm
bci/php-fpm:8
bci/php:8
php-composer2Released


SUSE Timeline for this CVE

CVE page created: Thu Apr 14 02:00:35 2022
CVE page last modified: Sun Jun 16 02:19:27 2024