Upstream information

CVE-2022-24349 at MITRE

Description

An authenticated user can create a link with reflected XSS payload for actions’ pages, and send it to other users. Malicious code has access to all the same objects as the rest of the web page and can make arbitrary modifications to the contents of the page being displayed to a victim. This attack can be implemented with the help of social engineering and expiration of a number of factors - an attacker should have authorized access to the Zabbix Frontend and allowed network connection between a malicious server and victim’s computer, understand attacked infrastructure, be recognized by the victim as a trustee and use trusted communication channel.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:N/AC:H/Au:S/C:N/I:P/A:N
Access Vector Network
Access Complexity High
Authentication Single
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.6 4.6
Vector CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L
Attack Vector Network Network
Attack Complexity High High
Privileges Required Low Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1196944 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • zabbix-agent >= 4.0.12-4.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP5-2022-1254
openSUSE Tumbleweed
  • zabbix-agent >= 4.0.39-1.1
  • zabbix-java-gateway >= 4.0.39-1.1
  • zabbix-phpfrontend >= 4.0.39-1.1
  • zabbix-proxy >= 4.0.39-1.1
  • zabbix-proxy-mysql >= 4.0.39-1.1
  • zabbix-proxy-postgresql >= 4.0.39-1.1
  • zabbix-proxy-sqlite >= 4.0.39-1.1
  • zabbix-server >= 4.0.39-1.1
  • zabbix-server-mysql >= 4.0.39-1.1
  • zabbix-server-postgresql >= 4.0.39-1.1
Patchnames:
openSUSE Tumbleweed GA zabbix-agent-4.0.39-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 zabbix Released
SUSE Linux Enterprise Server 12 SP5 zabbix Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 zabbix Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 zabbix Affected
SUSE Linux Enterprise Server 12 SP3-BCL zabbix Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS zabbix Unsupported
SUSE Linux Enterprise Server 12 SP3-LTSS zabbix Unsupported
SUSE Linux Enterprise Server 12 SP4 zabbix Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS zabbix Affected
SUSE Linux Enterprise Server 12 SP4-LTSS zabbix Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 zabbix Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 zabbix Affected
SUSE OpenStack Cloud 8 zabbix Affected
SUSE OpenStack Cloud 9 zabbix Affected
SUSE OpenStack Cloud Crowbar 8 zabbix Affected
SUSE OpenStack Cloud Crowbar 9 zabbix Affected


SUSE Timeline for this CVE

CVE page created: Thu Mar 10 05:00:20 2022
CVE page last modified: Mon Sep 11 21:29:39 2023