Upstream information

CVE-2022-23634 at MITRE

Description

Puma is a Ruby/Rack web server built for parallelism. Prior to `puma` version `5.6.2`, `puma` may not always call `close` on the response body. Rails, prior to version `7.0.2.2`, depended on the response body being closed in order for its `CurrentAttributes` implementation to work correctly. The combination of these two behaviors (Puma not closing the body + Rails' Executor implementation) causes information leakage. This problem is fixed in Puma versions 5.6.2 and 4.3.11. This problem is fixed in Rails versions 7.02.2, 6.1.4.6, 6.0.4.6, and 5.2.6.2. Upgrading to a patched Rails _or_ Puma version fixes the vulnerability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 6.1
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
Access Vector Network Network
Access Complexity High High
Privileges Required None None
User Interaction None Required
Scope Unchanged Changed
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1196222 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SAP-Azure-BYOS
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP1-SAP-Azure-BYOS
Image SLES15-SP1-SAP-Azure-LI-BYOS-Production
Image SLES15-SP1-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-SAP-Azure
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-SAP-BYOS-Azure
Image SLES15-SP2-SAP-BYOS-GCE
Image SLES15-SP2-SAP-GCE
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-BYOS-Azure
Image SLES15-SP3-SAP-BYOS-GCE
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP4-SAP-BYOS
Image SLES15-SP4-SAP-BYOS-Azure
Image SLES15-SP4-SAP-BYOS-EC2
Image SLES15-SP4-SAP-BYOS-GCE
  • ruby2.5-rubygem-puma >= 4.3.11-150000.3.6.2
SUSE Linux Enterprise High Availability 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • ruby2.5-rubygem-puma >= 4.3.11-150000.3.6.2
Patchnames:
SUSE-SLE-Product-HA-15-SP1-2022-1515
SUSE Linux Enterprise High Availability 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • ruby2.5-rubygem-puma >= 4.3.11-150000.3.6.2
Patchnames:
SUSE-SLE-Product-HA-15-SP2-2022-1515
SUSE Linux Enterprise High Availability 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • ruby2.5-rubygem-puma >= 4.3.11-150000.3.6.2
Patchnames:
SUSE-SLE-Product-HA-15-SP3-2022-1515
SUSE Linux Enterprise High Availability 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • ruby2.5-rubygem-puma >= 4.3.11-150000.3.6.2
Patchnames:
SUSE-SLE-Product-HA-15-2022-1515
openSUSE Leap 15.3
  • ruby2.5-rubygem-puma >= 4.3.11-150000.3.6.2
  • ruby2.5-rubygem-puma-doc >= 4.3.11-150000.3.6.2
Patchnames:
openSUSE-SLE-15.3-2022-1515
openSUSE Leap 15.4
  • ruby2.5-rubygem-puma >= 4.3.11-150000.3.6.2
  • ruby2.5-rubygem-puma-doc >= 4.3.11-150000.3.6.2
Patchnames:
openSUSE-SLE-15.4-2022-1515
openSUSE Tumbleweed
  • ruby3.1-rubygem-puma >= 5.6.2-1.1
Patchnames:
openSUSE Tumbleweed GA ruby3.1-rubygem-puma-5.6.2-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability Extension 15 rubygem-puma Released
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-puma Released
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-puma Released
SUSE Linux Enterprise High Availability Extension 15 SP3 rubygem-puma Released
SUSE Linux Enterprise High Availability Extension 15 SP4 rubygem-puma Released
SUSE Linux Enterprise High Performance Computing 15 rubygem-puma Released
SUSE Linux Enterprise High Performance Computing 15 SP1 rubygem-puma Released
SUSE Linux Enterprise High Performance Computing 15 SP2 rubygem-puma Released
SUSE Linux Enterprise High Performance Computing 15 SP3 rubygem-puma Released
SUSE Linux Enterprise High Performance Computing 15 SP4 rubygem-puma Released
SUSE Linux Enterprise Server 15 rubygem-puma Released
SUSE Linux Enterprise Server 15 SP1 rubygem-puma Released
SUSE Linux Enterprise Server 15 SP2 rubygem-puma Released
SUSE Linux Enterprise Server 15 SP3 rubygem-puma Released
SUSE Linux Enterprise Server 15 SP4 rubygem-puma Released
SUSE Linux Enterprise Server for SAP Applications 15 rubygem-puma Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 rubygem-puma Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 rubygem-puma Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rubygem-puma Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 rubygem-puma Released
SUSE Manager Proxy 4.0 rubygem-puma Released
SUSE Manager Proxy 4.1 rubygem-puma Released
SUSE Manager Proxy 4.2 rubygem-puma Released
SUSE Manager Proxy 4.3 rubygem-puma Released
SUSE Manager Retail Branch Server 4.0 rubygem-puma Released
SUSE Manager Retail Branch Server 4.1 rubygem-puma Released
SUSE Manager Retail Branch Server 4.2 rubygem-puma Released
SUSE Manager Retail Branch Server 4.3 rubygem-puma Released
SUSE Manager Server 4.0 rubygem-puma Released
SUSE Manager Server 4.1 rubygem-puma Released
SUSE Manager Server 4.2 rubygem-puma Released
SUSE Manager Server 4.3 rubygem-puma Released
SUSE OpenStack Cloud Crowbar 8 rubygem-puma Not affected
SUSE OpenStack Cloud Crowbar 9 rubygem-puma Not affected