Upstream information

CVE-2022-23527 at MITRE

Description

mod_auth_openidc is an OpenID Certifiedâ„¢ authentication and authorization module for the Apache 2.x HTTP server. Versions prior to 2.4.12.2 are vulnerable to Open Redirect. When providing a logout parameter to the redirect URI, the existing code in oidc_validate_redirect_url() does not properly check for URLs that start with /\t, leading to an open redirect. This issue has been patched in version 2.4.12.2. Users unable to upgrade can mitigate the issue by configuring mod_auth_openidc to only allow redirection when the destination matches a given regular expression with OIDCRedirectURLsAllowed.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.7 5.4
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Changed Unchanged
Confidentiality Impact None Low
Integrity Impact Low Low
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1206441 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 8
  • cjose >= 0.6.1-4.module+el8.9.0+19469+5b493da9
  • cjose-devel >= 0.6.1-4.module+el8.9.0+19469+5b493da9
  • mod_auth_openidc >= 2.4.9.4-5.module+el8.9.0+18723+672ccf5d
Patchnames:
RHSA-2023:6940
SUSE Liberty Linux 9
  • mod_auth_openidc >= 2.4.9.4-4.el9
Patchnames:
RHSA-2023:6365
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Server Applications 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • apache2-mod_auth_openidc >= 2.3.8-150100.3.22.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP4-2023-215
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Server Applications 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • apache2-mod_auth_openidc >= 2.3.8-150100.3.22.1
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP5 GA apache2-mod_auth_openidc-2.3.8-150100.3.25.1
SUSE Linux Enterprise Real Time 15 SP3
  • apache2-mod_auth_openidc >= 2.3.8-150100.3.22.1
Patchnames:
SUSE-SLE-Product-RT-15-SP3-2023-215
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • apache2-mod_auth_openidc >= 2.4.0-7.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2023-1837
SUSE Linux Enterprise Server 12 SP4-LTSS
  • apache2-mod_auth_openidc >= 2.4.0-7.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2023-1837
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • apache2-mod_auth_openidc >= 2.4.0-7.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2023-1837
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • apache2-mod_auth_openidc >= 2.4.0-7.9.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2023-1837
SUSE OpenStack Cloud 9
  • apache2-mod_auth_openidc >= 2.4.0-7.9.1
Patchnames:
SUSE-OpenStack-Cloud-9-2023-1837
SUSE OpenStack Cloud Crowbar 9
  • apache2-mod_auth_openidc >= 2.4.0-7.9.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2023-1837
openSUSE Leap 15.4
  • apache2-mod_auth_openidc >= 2.3.8-150100.3.22.1
Patchnames:
openSUSE-SLE-15.4-2023-215
openSUSE Tumbleweed
  • apache2-mod_auth_openidc >= 2.4.12.2-1.1
Patchnames:
openSUSE Tumbleweed GA apache2-mod_auth_openidc-2.4.12.2-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 apache2-mod_auth_openidc Released
SUSE Linux Enterprise High Performance Computing 15 SP5 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Module for Server Applications 15 SP5 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Real Time 15 SP3 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server 12 SP5 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server 15 SP5 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 apache2-mod_auth_openidc Released
SUSE Manager Proxy 4.3 apache2-mod_auth_openidc Released
SUSE Manager Retail Branch Server 4.3 apache2-mod_auth_openidc Released
SUSE Manager Server 4.3 apache2-mod_auth_openidc Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP1 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS apache2-mod_auth_openidc Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS apache2-mod_auth_openidc Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS apache2-mod_auth_openidc Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS apache2-mod_auth_openidc Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 apache2-mod_auth_openidc Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS apache2-mod_auth_openidc Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS apache2-mod_auth_openidc Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 apache2-mod_auth_openidc Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS apache2-mod_auth_openidc Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 apache2-mod_auth_openidc Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP4 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server 15 SP2 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server 15 SP2-LTSS apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server 15 SP3 apache2-mod_auth_openidc Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server 15 SP4 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server 15 SP4-LTSS apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 apache2-mod_auth_openidc Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 apache2-mod_auth_openidc Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 apache2-mod_auth_openidc Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 apache2-mod_auth_openidc Unsupported
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 apache2-mod_auth_openidc Affected
SUSE Enterprise Storage 6 apache2-mod_auth_openidc Unsupported
SUSE Enterprise Storage 7 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Real Time 15 SP2 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Real Time 15 SP4 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server 12 SP4-LTSS apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server 15 SP1 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server 15 SP1-BCL apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server 15 SP1-LTSS apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server 15 SP2-BCL apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server 15 SP3-BCL apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 apache2-mod_auth_openidc Released
SUSE Manager Proxy 4.0 apache2-mod_auth_openidc Affected
SUSE Manager Proxy 4.1 apache2-mod_auth_openidc Unsupported
SUSE Manager Proxy 4.2 apache2-mod_auth_openidc Unsupported
SUSE Manager Retail Branch Server 4.0 apache2-mod_auth_openidc Affected
SUSE Manager Retail Branch Server 4.1 apache2-mod_auth_openidc Unsupported
SUSE Manager Retail Branch Server 4.2 apache2-mod_auth_openidc Unsupported
SUSE Manager Server 4.0 apache2-mod_auth_openidc Affected
SUSE Manager Server 4.1 apache2-mod_auth_openidc Unsupported
SUSE Manager Server 4.2 apache2-mod_auth_openidc Unsupported
SUSE OpenStack Cloud 9 apache2-mod_auth_openidc Released
SUSE OpenStack Cloud Crowbar 9 apache2-mod_auth_openidc Released
openSUSE Leap 15.4 apache2-mod_auth_openidc Released


SUSE Timeline for this CVE

CVE page created: Wed Dec 14 21:00:18 2022
CVE page last modified: Thu Feb 1 01:43:09 2024