Upstream information

CVE-2022-21449 at MITRE

Description

Vulnerability in the Oracle Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Libraries). Supported versions that are affected are Oracle Java SE: 17.0.2 and 18; Oracle GraalVM Enterprise Edition: 21.3.1 and 22.0.0.2. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Oracle Java SE, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability can also be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. CVSS 3.1 Base Score 7.5 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1198670 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • java-17-openjdk >= 17.0.3.0-150400.1.8
  • java-17-openjdk-demo >= 17.0.3.0-150400.1.8
  • java-17-openjdk-devel >= 17.0.3.0-150400.1.8
  • java-17-openjdk-headless >= 17.0.3.0-150400.1.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA java-17-openjdk-17.0.3.0-150400.1.8
openSUSE Tumbleweed
  • java-15-openjdk >= 15.0.7.0-1.1
  • java-15-openjdk-accessibility >= 15.0.7.0-1.1
  • java-15-openjdk-demo >= 15.0.7.0-1.1
  • java-15-openjdk-devel >= 15.0.7.0-1.1
  • java-15-openjdk-headless >= 15.0.7.0-1.1
  • java-15-openjdk-javadoc >= 15.0.7.0-1.1
  • java-15-openjdk-jmods >= 15.0.7.0-1.1
  • java-15-openjdk-src >= 15.0.7.0-1.1
  • java-17-openjdk >= 17.0.3.0-1.1
  • java-17-openjdk-accessibility >= 17.0.3.0-1.1
  • java-17-openjdk-demo >= 17.0.3.0-1.1
  • java-17-openjdk-devel >= 17.0.3.0-1.1
  • java-17-openjdk-headless >= 17.0.3.0-1.1
  • java-17-openjdk-javadoc >= 17.0.3.0-1.1
  • java-17-openjdk-jmods >= 17.0.3.0-1.1
  • java-17-openjdk-src >= 17.0.3.0-1.1
  • java-18-openjdk >= 18.0.1.0-1.1
  • java-18-openjdk-accessibility >= 18.0.1.0-1.1
  • java-18-openjdk-demo >= 18.0.1.0-1.1
  • java-18-openjdk-devel >= 18.0.1.0-1.1
  • java-18-openjdk-headless >= 18.0.1.0-1.1
  • java-18-openjdk-javadoc >= 18.0.1.0-1.1
  • java-18-openjdk-jmods >= 18.0.1.0-1.1
  • java-18-openjdk-src >= 18.0.1.0-1.1
Patchnames:
openSUSE Tumbleweed GA java-15-openjdk-15.0.7.0-1.1
openSUSE Tumbleweed GA java-17-openjdk-17.0.3.0-1.1
openSUSE Tumbleweed GA java-18-openjdk-18.0.1.0-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 java-1_7_0-openjdk Not affected
HPE Helion OpenStack 8 java-1_8_0-openjdk Not affected
SUSE CaaS Platform 4.0 java-10-openjdk Not affected
SUSE CaaS Platform 4.0 java-11-openjdk Not affected
SUSE CaaS Platform 4.0 java-1_8_0-openjdk Not affected
SUSE Enterprise Storage 6 java-10-openjdk Not affected
SUSE Enterprise Storage 6 java-11-openjdk Not affected
SUSE Enterprise Storage 6 java-1_8_0-openjdk Not affected
SUSE Enterprise Storage 7 java-11-openjdk Not affected
SUSE Enterprise Storage 7 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Desktop 15 SP3 java-11-openjdk Not affected
SUSE Linux Enterprise Desktop 15 SP4 java-11-openjdk Not affected
SUSE Linux Enterprise Desktop 15 SP4 java-17-openjdk Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 java-11-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 java-1_7_0-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS java-10-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS java-11-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS java-11-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS java-11-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS java-11-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS java-11-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 java-11-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 java-11-openjdk Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 java-17-openjdk Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 java-11-openjdk Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 java-11-openjdk Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 java-17-openjdk Already fixed
SUSE Linux Enterprise Module for Legacy 15 SP3 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Module for Legacy 15 SP4 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Real Time 15 SP2 java-11-openjdk Not affected
SUSE Linux Enterprise Server 12 SP2 BCL java-1_7_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP2 BCL java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP3 BCL java-1_7_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP3 BCL java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS java-1_7_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS java-1_7_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP5 java-11-openjdk Not affected
SUSE Linux Enterprise Server 12 SP5 java-1_7_0-openjdk Not affected
SUSE Linux Enterprise Server 12 SP5 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 15 ESPOS java-10-openjdk Not affected
SUSE Linux Enterprise Server 15 ESPOS java-11-openjdk Not affected
SUSE Linux Enterprise Server 15 LTSS java-10-openjdk Not affected
SUSE Linux Enterprise Server 15 LTSS java-11-openjdk Not affected
SUSE Linux Enterprise Server 15 LTSS java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS java-10-openjdk Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS java-11-openjdk Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS java-11-openjdk Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 15 SP3 java-11-openjdk Not affected
SUSE Linux Enterprise Server 15 SP3 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server 15 SP4 java-11-openjdk Not affected
SUSE Linux Enterprise Server 15 SP4 java-17-openjdk Already fixed
SUSE Linux Enterprise Server 15 SP4 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 java-10-openjdk Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 java-11-openjdk Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 java-11-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 java-1_7_0-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 java-11-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 java-1_7_0-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 java-10-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 java-11-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 java-10-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 java-11-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 java-11-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 java-11-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 java-11-openjdk Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 java-17-openjdk Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 java-1_8_0-openjdk Not affected
SUSE Linux Enterprise Storage 7.1 java-11-openjdk Not affected
SUSE Linux Enterprise Storage 7.1 java-1_8_0-openjdk Not affected
SUSE Manager Proxy 4.1 java-11-openjdk Not affected
SUSE Manager Proxy 4.1 java-1_8_0-openjdk Not affected
SUSE Manager Proxy 4.2 java-11-openjdk Not affected
SUSE Manager Proxy 4.2 java-1_8_0-openjdk Not affected
SUSE Manager Proxy 4.3 java-11-openjdk Not affected
SUSE Manager Proxy 4.3 java-17-openjdk Already fixed
SUSE Manager Proxy 4.3 java-1_8_0-openjdk Not affected
SUSE Manager Retail Branch Server 4.1 java-11-openjdk Not affected
SUSE Manager Retail Branch Server 4.1 java-1_8_0-openjdk Not affected
SUSE Manager Retail Branch Server 4.2 java-11-openjdk Not affected
SUSE Manager Retail Branch Server 4.2 java-1_8_0-openjdk Not affected
SUSE Manager Retail Branch Server 4.3 java-11-openjdk Not affected
SUSE Manager Retail Branch Server 4.3 java-17-openjdk Already fixed
SUSE Manager Retail Branch Server 4.3 java-1_8_0-openjdk Not affected
SUSE Manager Server 4.1 java-11-openjdk Not affected
SUSE Manager Server 4.1 java-1_8_0-openjdk Not affected
SUSE Manager Server 4.2 java-11-openjdk Not affected
SUSE Manager Server 4.2 java-1_8_0-openjdk Not affected
SUSE Manager Server 4.3 java-11-openjdk Not affected
SUSE Manager Server 4.3 java-17-openjdk Already fixed
SUSE Manager Server 4.3 java-1_8_0-openjdk Not affected
SUSE OpenStack Cloud 8 java-1_7_0-openjdk Not affected
SUSE OpenStack Cloud 8 java-1_8_0-openjdk Not affected
SUSE OpenStack Cloud 9 java-1_8_0-openjdk Not affected
SUSE OpenStack Cloud Crowbar 8 java-1_7_0-openjdk Not affected
SUSE OpenStack Cloud Crowbar 8 java-1_8_0-openjdk Not affected
SUSE OpenStack Cloud Crowbar 9 java-1_8_0-openjdk Not affected
bci/openjdk
bci/openjdk-devel
bci/openjdk-devel:11
java-11-openjdkNot affected
bci/openjdk:17 java-17-openjdkAlready fixed