Upstream information

CVE-2022-1664 at MITRE

Description

Dpkg::Source::Archive in dpkg, the Debian package management system, before version 1.21.8, 1.20.10, 1.19.8, 1.18.26 is prone to a directory traversal vulnerability. When extracting untrusted source packages in v2 and v3 source package formats that include a debian.tar, the in-place extraction can lead to directory traversal situations on specially crafted orig.tar and debian.tar tarballs.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 4.4
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None High
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High None
Availability Impact High None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1199944 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • update-alternatives >= 1.18.4-16.3.5
Patchnames:
SUSE-SLE-SERVER-12-SP5-2022-2689
openSUSE Tumbleweed
  • dpkg >= 1.21.8-1.1
  • dpkg-devel >= 1.21.8-1.1
  • dpkg-lang >= 1.21.8-1.1
Patchnames:
openSUSE Tumbleweed GA dpkg-1.21.8-1.1

List of packages in QA

Product(s) Package(s)
SUSE CaaS Platform 4.0
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Enterprise Storage 6
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Enterprise Storage 7
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server 15 SP3
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Desktop 15 SP3
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise High Performance Computing 15 SP3
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Manager Server 4.2
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Manager Proxy 4.2
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Manager Retail Branch Server 4.2
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Storage 7.1
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Module for Development Tools 15 SP4
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server 15 SP4
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Desktop 15 SP4
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise High Performance Computing 15 SP4
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Manager Server 4.3
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Manager Proxy 4.3
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Manager Retail Branch Server 4.3
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server 15 SP1-BCL
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server 15 SP1-LTSS
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server 15 SP2-BCL
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server 15 SP2-LTSS
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server 15-LTSS
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server for SAP Applications 15
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Manager Proxy 4.1
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Manager Retail Branch Server 4.1
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1
SUSE Manager Server 4.1
  • dpkg >= 1.19.0.4-150000.4.3.1
  • dpkg-devel >= 1.19.0.4-150000.4.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 dpkg In progress
SUSE Enterprise Storage 6 dpkg In progress
SUSE Enterprise Storage 7 dpkg In progress
SUSE Linux Enterprise Desktop 15 SP3 dpkg In progress
SUSE Linux Enterprise Desktop 15 SP4 dpkg In progress
SUSE Linux Enterprise Desktop 15 SP4 update-alternatives Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 update-alternatives Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS dpkg In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS dpkg In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS dpkg In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS dpkg In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS dpkg In progress
SUSE Linux Enterprise High Performance Computing 15 SP3 dpkg In progress
SUSE Linux Enterprise High Performance Computing 15 SP4 dpkg In progress
SUSE Linux Enterprise High Performance Computing 15 SP4 update-alternatives Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 update-alternatives Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 dpkg In progress
SUSE Linux Enterprise Module for Development Tools 15 SP4 dpkg In progress
SUSE Linux Enterprise Real Time 15 SP2 dpkg In progress
SUSE Linux Enterprise Server 12 SP5 update-alternatives Not affected
SUSE Linux Enterprise Server 15 ESPOS dpkg In progress
SUSE Linux Enterprise Server 15 LTSS dpkg In progress
SUSE Linux Enterprise Server 15 SP1 LTSS dpkg In progress
SUSE Linux Enterprise Server 15 SP2 LTSS dpkg In progress
SUSE Linux Enterprise Server 15 SP3 dpkg In progress
SUSE Linux Enterprise Server 15 SP4 dpkg In progress
SUSE Linux Enterprise Server 15 SP4 update-alternatives Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 dpkg In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 dpkg In progress
SUSE Linux Enterprise Server for SAP Applications 15 dpkg In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 dpkg In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP2 dpkg In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP3 dpkg In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP4 dpkg In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP4 update-alternatives Not affected
SUSE Linux Enterprise Storage 7.1 dpkg In progress
SUSE Manager Proxy 4.1 dpkg In progress
SUSE Manager Proxy 4.2 dpkg In progress
SUSE Manager Proxy 4.3 dpkg In progress
SUSE Manager Proxy 4.3 update-alternatives Not affected
SUSE Manager Retail Branch Server 4.1 dpkg In progress
SUSE Manager Retail Branch Server 4.2 dpkg In progress
SUSE Manager Retail Branch Server 4.3 dpkg In progress
SUSE Manager Retail Branch Server 4.3 update-alternatives Not affected
SUSE Manager Server 4.1 dpkg In progress
SUSE Manager Server 4.2 dpkg In progress
SUSE Manager Server 4.3 dpkg In progress
SUSE Manager Server 4.3 update-alternatives Not affected
suse/sles12sp3 update-alternativesNot affected