Upstream information

CVE-2022-0582 at MITRE

Description

Unaligned access in the CSN.1 protocol dissector in Wireshark 3.6.0 to 3.6.1 and 3.4.0 to 3.4.11 allows denial of service via packet injection or crafted capture file

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1195869 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP1-SAP-Azure-LI-BYOS-Production
Image SLES15-SP1-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
SUSE CaaS Platform 4.0
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2022-722
SUSE Enterprise Storage 6
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-Storage-6-2022-722
SUSE Enterprise Storage 7
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-Storage-7-2022-722
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-722
SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-722
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libwireshark15-3.6.2-3.71.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA wireshark-devel-3.6.2-3.71.1
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-722
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-722
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-722
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-722
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-HPC-15-2022-722
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-722
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libwireshark15-3.6.2-3.71.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-722
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA wireshark-devel-3.6.2-3.71.1
SUSE Linux Enterprise Real Time 15 SP2
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-RT-15-SP2-2022-722
SUSE Linux Enterprise Server 15 SP1-BCL
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2022-722
SUSE Linux Enterprise Server 15 SP1-LTSS
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-722
SUSE Linux Enterprise Server 15 SP2-BCL
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-BCL-2022-722
SUSE Linux Enterprise Server 15 SP2-LTSS
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-722
SUSE Linux Enterprise Server 15-LTSS
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SLES-15-2022-722
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2022-722
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2022-722
SUSE Linux Enterprise Server for SAP Applications 15
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2022-722
SUSE Manager Proxy 4.1
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-722
SUSE Manager Retail Branch Server 4.1
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-722
SUSE Manager Server 4.1
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-722
openSUSE Leap 15.3
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwsutil13 >= 3.6.2-3.71.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
openSUSE-SLE-15.3-2022-722
openSUSE Tumbleweed
  • libwireshark15 >= 3.6.2-2.1
  • libwiretap12 >= 3.6.2-2.1
  • libwsutil13 >= 3.6.2-2.1
  • wireshark >= 3.6.2-2.1
  • wireshark-devel >= 3.6.2-2.1
  • wireshark-ui-qt >= 3.6.2-2.1
Patchnames:
openSUSE Tumbleweed GA libwireshark15-3.6.2-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 wireshark Not affected
SUSE CaaS Platform 4.0 wireshark Released
SUSE Enterprise Storage 6 wireshark Released
SUSE Enterprise Storage 7 wireshark Released
SUSE Linux Enterprise Desktop 15 SP3 wireshark Released
SUSE Linux Enterprise Desktop 15 SP4 wireshark Released
SUSE Linux Enterprise High Performance Computing 12 SP5 wireshark Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS wireshark Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS wireshark Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS wireshark Released
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS wireshark Released
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS wireshark Released
SUSE Linux Enterprise High Performance Computing 15 SP3 wireshark Released
SUSE Linux Enterprise High Performance Computing 15 SP4 wireshark Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 wireshark Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 wireshark Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 wireshark Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 wireshark Released
SUSE Linux Enterprise Real Time 15 SP2 wireshark Released
SUSE Linux Enterprise Server 11 SP1 wireshark Not affected
SUSE Linux Enterprise Server 11 SP3 wireshark Not affected
SUSE Linux Enterprise Server 12 SP2 BCL wireshark Not affected
SUSE Linux Enterprise Server 12 SP3 BCL wireshark Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS wireshark Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS wireshark Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS wireshark Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS wireshark Not affected
SUSE Linux Enterprise Server 12 SP5 wireshark Not affected
SUSE Linux Enterprise Server 15 ESPOS wireshark Released
SUSE Linux Enterprise Server 15 LTSS wireshark Released
SUSE Linux Enterprise Server 15 SP1 LTSS wireshark Released
SUSE Linux Enterprise Server 15 SP2 LTSS wireshark Released
SUSE Linux Enterprise Server 15 SP3 wireshark Released
SUSE Linux Enterprise Server 15 SP4 wireshark Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 wireshark Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 wireshark Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 wireshark Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 wireshark Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 wireshark Not affected
SUSE Linux Enterprise Server for SAP Applications 15 wireshark Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 wireshark Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 wireshark Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 wireshark Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 wireshark Released
SUSE Linux Enterprise Storage 7.1 wireshark Released
SUSE Manager Proxy 4.1 wireshark Released
SUSE Manager Proxy 4.2 wireshark Released
SUSE Manager Proxy 4.3 wireshark Released
SUSE Manager Retail Branch Server 4.1 wireshark Released
SUSE Manager Retail Branch Server 4.2 wireshark Released
SUSE Manager Retail Branch Server 4.3 wireshark Released
SUSE Manager Server 4.1 wireshark Released
SUSE Manager Server 4.2 wireshark Released
SUSE Manager Server 4.3 wireshark Released
SUSE OpenStack Cloud 8 wireshark Not affected
SUSE OpenStack Cloud 9 wireshark Not affected
SUSE OpenStack Cloud Crowbar 8 wireshark Not affected
SUSE OpenStack Cloud Crowbar 9 wireshark Not affected