Upstream information

CVE-2021-46657 at MITRE

Description

get_sort_by_table in MariaDB before 10.6.2 allows an application crash via certain subquery uses of ORDER BY.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 3.7
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Local Network
Access Complexity Low High
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1195325 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/rmt-mariadb-client:10.5-4.6
  • mariadb-client >= 10.5.15-150300.3.15.1
  • mariadb-errormessages >= 10.5.15-150300.3.15.1
Container suse/rmt-mariadb:10.5-3.5
  • mariadb >= 10.5.15-150300.3.15.1
  • mariadb-client >= 10.5.15-150300.3.15.1
  • mariadb-errormessages >= 10.5.15-150300.3.15.1
  • mariadb-tools >= 10.5.15-150300.3.15.1
SUSE CaaS Platform 4.0
  • libmysqld-devel >= 10.2.43-3.51.1
  • libmysqld19 >= 10.2.43-3.51.1
  • mariadb >= 10.2.43-3.51.1
  • mariadb-client >= 10.2.43-3.51.1
  • mariadb-errormessages >= 10.2.43-3.51.1
  • mariadb-tools >= 10.2.43-3.51.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2022-725
SUSE Enterprise Storage 6
  • libmysqld-devel >= 10.2.43-3.51.1
  • libmysqld19 >= 10.2.43-3.51.1
  • mariadb >= 10.2.43-3.51.1
  • mariadb-client >= 10.2.43-3.51.1
  • mariadb-errormessages >= 10.2.43-3.51.1
  • mariadb-tools >= 10.2.43-3.51.1
Patchnames:
SUSE-Storage-6-2022-725
SUSE Enterprise Storage 7
  • libmariadbd-devel >= 10.4.24-3.25.1
  • libmariadbd19 >= 10.4.24-3.25.1
  • mariadb >= 10.4.24-3.25.1
  • mariadb-client >= 10.4.24-3.25.1
  • mariadb-errormessages >= 10.4.24-3.25.1
  • mariadb-tools >= 10.4.24-3.25.1
Patchnames:
SUSE-Storage-7-2022-726
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • libmysqld-devel >= 10.2.43-3.51.1
  • libmysqld19 >= 10.2.43-3.51.1
  • mariadb >= 10.2.43-3.51.1
  • mariadb-client >= 10.2.43-3.51.1
  • mariadb-errormessages >= 10.2.43-3.51.1
  • mariadb-tools >= 10.2.43-3.51.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-725
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • libmysqld-devel >= 10.2.43-3.51.1
  • libmysqld19 >= 10.2.43-3.51.1
  • mariadb >= 10.2.43-3.51.1
  • mariadb-client >= 10.2.43-3.51.1
  • mariadb-errormessages >= 10.2.43-3.51.1
  • mariadb-tools >= 10.2.43-3.51.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-725
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS
  • libmariadbd-devel >= 10.4.24-3.25.1
  • libmariadbd19 >= 10.4.24-3.25.1
  • mariadb >= 10.4.24-3.25.1
  • mariadb-client >= 10.4.24-3.25.1
  • mariadb-errormessages >= 10.4.24-3.25.1
  • mariadb-tools >= 10.4.24-3.25.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-726
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • libmariadbd-devel >= 10.4.24-3.25.1
  • libmariadbd19 >= 10.4.24-3.25.1
  • mariadb >= 10.4.24-3.25.1
  • mariadb-client >= 10.4.24-3.25.1
  • mariadb-errormessages >= 10.4.24-3.25.1
  • mariadb-tools >= 10.4.24-3.25.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-726
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Server Applications 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libmariadbd-devel >= 10.5.15-150300.3.15.1
  • libmariadbd19 >= 10.5.15-150300.3.15.1
  • mariadb >= 10.5.15-150300.3.15.1
  • mariadb-client >= 10.5.15-150300.3.15.1
  • mariadb-errormessages >= 10.5.15-150300.3.15.1
  • mariadb-tools >= 10.5.15-150300.3.15.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP3-2022-731
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Server Applications 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libmariadbd-devel >= 10.6.8-150400.3.7.1
  • libmariadbd19 >= 10.6.8-150400.3.7.1
  • mariadb >= 10.6.8-150400.3.7.1
  • mariadb-client >= 10.6.8-150400.3.7.1
  • mariadb-errormessages >= 10.6.8-150400.3.7.1
  • mariadb-tools >= 10.6.8-150400.3.7.1
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA libmariadbd-devel-10.6.7-150400.1.4
SUSE-SLE-Module-Server-Applications-15-SP4-2022-2561
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • libmysqld-devel >= 10.2.43-3.51.1
  • libmysqld19 >= 10.2.43-3.51.1
  • mariadb >= 10.2.43-3.51.1
  • mariadb-client >= 10.2.43-3.51.1
  • mariadb-errormessages >= 10.2.43-3.51.1
  • mariadb-tools >= 10.2.43-3.51.1
Patchnames:
SUSE-SLE-Product-HPC-15-2022-725
SUSE Linux Enterprise Real Time 15 SP2
  • libmariadbd-devel >= 10.4.24-3.25.1
  • libmariadbd19 >= 10.4.24-3.25.1
  • mariadb >= 10.4.24-3.25.1
  • mariadb-client >= 10.4.24-3.25.1
  • mariadb-errormessages >= 10.4.24-3.25.1
  • mariadb-tools >= 10.4.24-3.25.1
Patchnames:
SUSE-SLE-Product-RT-15-SP2-2022-726
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • mariadb >= 10.2.43-3.47.1
  • mariadb-client >= 10.2.43-3.47.1
  • mariadb-errormessages >= 10.2.43-3.47.1
  • mariadb-tools >= 10.2.43-3.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2022-782
SUSE Linux Enterprise Server 12 SP4-LTSS
  • mariadb >= 10.2.43-3.47.1
  • mariadb-client >= 10.2.43-3.47.1
  • mariadb-errormessages >= 10.2.43-3.47.1
  • mariadb-tools >= 10.2.43-3.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2022-782
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • mariadb >= 10.2.43-3.47.1
  • mariadb-client >= 10.2.43-3.47.1
  • mariadb-errormessages >= 10.2.43-3.47.1
  • mariadb-tools >= 10.2.43-3.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2022-782
SUSE Linux Enterprise Server 15 SP1-BCL
  • libmysqld-devel >= 10.2.43-3.51.1
  • libmysqld19 >= 10.2.43-3.51.1
  • mariadb >= 10.2.43-3.51.1
  • mariadb-client >= 10.2.43-3.51.1
  • mariadb-errormessages >= 10.2.43-3.51.1
  • mariadb-tools >= 10.2.43-3.51.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2022-725
SUSE Linux Enterprise Server 15 SP1-LTSS
  • libmysqld-devel >= 10.2.43-3.51.1
  • libmysqld19 >= 10.2.43-3.51.1
  • mariadb >= 10.2.43-3.51.1
  • mariadb-client >= 10.2.43-3.51.1
  • mariadb-errormessages >= 10.2.43-3.51.1
  • mariadb-tools >= 10.2.43-3.51.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-725
SUSE Linux Enterprise Server 15 SP2-BCL
  • libmariadbd-devel >= 10.4.24-3.25.1
  • libmariadbd19 >= 10.4.24-3.25.1
  • mariadb >= 10.4.24-3.25.1
  • mariadb-client >= 10.4.24-3.25.1
  • mariadb-errormessages >= 10.4.24-3.25.1
  • mariadb-tools >= 10.4.24-3.25.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-BCL-2022-726
SUSE Linux Enterprise Server 15 SP2-LTSS
  • libmariadbd-devel >= 10.4.24-3.25.1
  • libmariadbd19 >= 10.4.24-3.25.1
  • mariadb >= 10.4.24-3.25.1
  • mariadb-client >= 10.4.24-3.25.1
  • mariadb-errormessages >= 10.4.24-3.25.1
  • mariadb-tools >= 10.4.24-3.25.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-726
SUSE Linux Enterprise Server 15-LTSS
  • libmysqld-devel >= 10.2.43-3.51.1
  • libmysqld19 >= 10.2.43-3.51.1
  • mariadb >= 10.2.43-3.51.1
  • mariadb-client >= 10.2.43-3.51.1
  • mariadb-errormessages >= 10.2.43-3.51.1
  • mariadb-tools >= 10.2.43-3.51.1
Patchnames:
SUSE-SLE-Product-SLES-15-2022-725
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • mariadb >= 10.2.43-3.47.1
  • mariadb-client >= 10.2.43-3.47.1
  • mariadb-errormessages >= 10.2.43-3.47.1
  • mariadb-tools >= 10.2.43-3.47.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2022-782
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • libmysqld-devel >= 10.2.43-3.51.1
  • libmysqld19 >= 10.2.43-3.51.1
  • mariadb >= 10.2.43-3.51.1
  • mariadb-client >= 10.2.43-3.51.1
  • mariadb-errormessages >= 10.2.43-3.51.1
  • mariadb-tools >= 10.2.43-3.51.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2022-725
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • libmariadbd-devel >= 10.4.24-3.25.1
  • libmariadbd19 >= 10.4.24-3.25.1
  • mariadb >= 10.4.24-3.25.1
  • mariadb-client >= 10.4.24-3.25.1
  • mariadb-errormessages >= 10.4.24-3.25.1
  • mariadb-tools >= 10.4.24-3.25.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2022-726
SUSE Linux Enterprise Server for SAP Applications 15
  • libmysqld-devel >= 10.2.43-3.51.1
  • libmysqld19 >= 10.2.43-3.51.1
  • mariadb >= 10.2.43-3.51.1
  • mariadb-client >= 10.2.43-3.51.1
  • mariadb-errormessages >= 10.2.43-3.51.1
  • mariadb-tools >= 10.2.43-3.51.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2022-725
SUSE Manager Proxy 4.1
  • libmariadbd-devel >= 10.4.24-3.25.1
  • libmariadbd19 >= 10.4.24-3.25.1
  • mariadb >= 10.4.24-3.25.1
  • mariadb-client >= 10.4.24-3.25.1
  • mariadb-errormessages >= 10.4.24-3.25.1
  • mariadb-tools >= 10.4.24-3.25.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-726
SUSE Manager Retail Branch Server 4.1
  • libmariadbd-devel >= 10.4.24-3.25.1
  • libmariadbd19 >= 10.4.24-3.25.1
  • mariadb >= 10.4.24-3.25.1
  • mariadb-client >= 10.4.24-3.25.1
  • mariadb-errormessages >= 10.4.24-3.25.1
  • mariadb-tools >= 10.4.24-3.25.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-726
SUSE Manager Server 4.1
  • libmariadbd-devel >= 10.4.24-3.25.1
  • libmariadbd19 >= 10.4.24-3.25.1
  • mariadb >= 10.4.24-3.25.1
  • mariadb-client >= 10.4.24-3.25.1
  • mariadb-errormessages >= 10.4.24-3.25.1
  • mariadb-tools >= 10.4.24-3.25.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-726
SUSE OpenStack Cloud 9
  • mariadb >= 10.2.43-3.47.1
  • mariadb-client >= 10.2.43-3.47.1
  • mariadb-errormessages >= 10.2.43-3.47.1
  • mariadb-galera >= 10.2.43-3.47.1
  • mariadb-tools >= 10.2.43-3.47.1
Patchnames:
SUSE-OpenStack-Cloud-9-2022-782
SUSE OpenStack Cloud Crowbar 9
  • mariadb >= 10.2.43-3.47.1
  • mariadb-client >= 10.2.43-3.47.1
  • mariadb-errormessages >= 10.2.43-3.47.1
  • mariadb-galera >= 10.2.43-3.47.1
  • mariadb-tools >= 10.2.43-3.47.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2022-782
openSUSE Leap 15.3
  • libmariadbd-devel >= 10.5.15-150300.3.15.1
  • libmariadbd19 >= 10.5.15-150300.3.15.1
  • mariadb >= 10.5.15-150300.3.15.1
  • mariadb-bench >= 10.5.15-150300.3.15.1
  • mariadb-client >= 10.5.15-150300.3.15.1
  • mariadb-errormessages >= 10.5.15-150300.3.15.1
  • mariadb-rpm-macros >= 10.5.15-150300.3.15.1
  • mariadb-test >= 10.5.15-150300.3.15.1
  • mariadb-tools >= 10.5.15-150300.3.15.1
Patchnames:
openSUSE-SLE-15.3-2022-731
openSUSE Leap 15.4
  • libmariadbd-devel >= 10.6.8-150400.3.7.1
  • libmariadbd19 >= 10.6.7-150400.1.4
  • mariadb >= 10.6.7-150400.1.4
  • mariadb-bench >= 10.6.8-150400.3.7.1
  • mariadb-client >= 10.6.7-150400.1.4
  • mariadb-errormessages >= 10.6.7-150400.1.4
  • mariadb-galera >= 10.6.8-150400.3.7.1
  • mariadb-rpm-macros >= 10.6.8-150400.3.7.1
  • mariadb-test >= 10.6.8-150400.3.7.1
  • mariadb-tools >= 10.6.8-150400.3.7.1
Patchnames:
openSUSE Leap 15.4 GA libmariadbd19-10.6.7-150400.1.4
openSUSE-SLE-15.4-2022-2561
openSUSE-SLE-15.4-2022-731
openSUSE Tumbleweed
  • libmariadbd-devel >= 10.7.3-1.1
  • libmariadbd19 >= 10.7.3-1.1
  • mariadb >= 10.7.3-1.1
  • mariadb-bench >= 10.7.3-1.1
  • mariadb-client >= 10.7.3-1.1
  • mariadb-errormessages >= 10.7.3-1.1
  • mariadb-galera >= 10.7.3-1.1
  • mariadb-rpm-macros >= 10.7.3-1.1
  • mariadb-test >= 10.7.3-1.1
  • mariadb-tools >= 10.7.3-1.1
Patchnames:
openSUSE Tumbleweed GA libmariadbd-devel-10.7.3-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Galera for Ericsson 15 SP3 mariadb Released
Galera for Ericsson 15 SP4 mariadb Released
HPE Helion OpenStack 8 mariadb Ignore
SUSE CaaS Platform 4.0 mariadb Released
SUSE Enterprise Storage 6 mariadb Released
SUSE Enterprise Storage 7 mariadb Released
SUSE Linux Enterprise Desktop 12 SP5 mariadb-100 Ignore
SUSE Linux Enterprise High Performance Computing 12 SP5 mariadb Released
SUSE Linux Enterprise High Performance Computing 12 SP5 mariadb-100 Ignore
SUSE Linux Enterprise High Performance Computing 15 LTSS mariadb Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS mariadb Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS mariadb Released
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS mariadb Released
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS mariadb Released
SUSE Linux Enterprise High Performance Computing 15 SP3 mariadb Released
SUSE Linux Enterprise High Performance Computing 15 SP4 mariadb Released
SUSE Linux Enterprise Module for Server Applications 15 SP3 mariadb Released
SUSE Linux Enterprise Module for Server Applications 15 SP4 mariadb Released
SUSE Linux Enterprise Real Time 15 SP2 mariadb Released
SUSE Linux Enterprise Server 12 SP2 BCL mariadb Ignore
SUSE Linux Enterprise Server 12 SP3 BCL mariadb Ignore
SUSE Linux Enterprise Server 12 SP3 ESPOS mariadb Ignore
SUSE Linux Enterprise Server 12 SP3 LTSS mariadb Ignore
SUSE Linux Enterprise Server 12 SP4 ESPOS mariadb Released
SUSE Linux Enterprise Server 12 SP4 ESPOS mariadb-100 Ignore
SUSE Linux Enterprise Server 12 SP4 LTSS mariadb Released
SUSE Linux Enterprise Server 12 SP4 LTSS mariadb-100 Ignore
SUSE Linux Enterprise Server 12 SP5 mariadb Released
SUSE Linux Enterprise Server 12 SP5 mariadb-100 Ignore
SUSE Linux Enterprise Server 15 ESPOS mariadb Released
SUSE Linux Enterprise Server 15 LTSS mariadb Released
SUSE Linux Enterprise Server 15 SP1 LTSS mariadb Released
SUSE Linux Enterprise Server 15 SP2 LTSS mariadb Released
SUSE Linux Enterprise Server 15 SP3 mariadb Released
SUSE Linux Enterprise Server 15 SP4 mariadb Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 mariadb Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 mariadb Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 mariadb Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP4 mariadb Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 mariadb-100 Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP5 mariadb In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 mariadb-100 Ignore
SUSE Linux Enterprise Server for SAP Applications 15 mariadb Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 mariadb Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 mariadb Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 mariadb Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 mariadb Released
SUSE Linux Enterprise Storage 7.1 mariadb Released
SUSE Linux Enterprise Workstation Extension 12 SP5 mariadb-100 Ignore
SUSE Manager Proxy 4.1 mariadb Released
SUSE Manager Proxy 4.2 mariadb Released
SUSE Manager Proxy 4.3 mariadb Released
SUSE Manager Retail Branch Server 4.1 mariadb Released
SUSE Manager Retail Branch Server 4.2 mariadb Released
SUSE Manager Retail Branch Server 4.3 mariadb Released
SUSE Manager Server 4.1 mariadb Released
SUSE Manager Server 4.2 mariadb Released
SUSE Manager Server 4.3 mariadb Released
SUSE OpenStack Cloud 8 mariadb Ignore
SUSE OpenStack Cloud 9 mariadb Released
SUSE OpenStack Cloud 9 mariadb-100 Ignore
SUSE OpenStack Cloud Crowbar 8 mariadb Ignore
SUSE OpenStack Cloud Crowbar 9 mariadb Released
SUSE OpenStack Cloud Crowbar 9 mariadb-100 Ignore
suse/rmt-mariadb mariadbReleased
suse/rmt-mariadb:10.6 mariadbIn progress