Upstream information

CVE-2021-45696 at MITRE

Description

An issue was discovered in the sha2 crate 0.9.7 before 0.9.8 for Rust. Hashes of long messages may be incorrect when the AVX2-accelerated backend is used.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

SUSE Bugzilla entry: 1194133 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 rust Not affected
SUSE CaaS Platform 4.5 rust Not affected
SUSE Enterprise Storage 6 rust Not affected
SUSE Enterprise Storage 7 rust Not affected
SUSE Linux Enterprise Desktop 15 SP2 rust Not affected
SUSE Linux Enterprise Desktop 15 SP3 rust Not affected
SUSE Linux Enterprise Desktop 15 SP3 rust1.43 Not affected
SUSE Linux Enterprise Desktop 15 SP3 rust1.53 Not affected
SUSE Linux Enterprise Desktop 15 SP3 rust1.54 Not affected
SUSE Linux Enterprise Desktop 15 SP3 rust1.55 Not affected
SUSE Linux Enterprise Desktop 15 SP3 rust1.56 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS rust Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS rust Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS rust Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 rust Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS rust Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS rust Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 rust Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 rust1.43 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 rust1.53 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 rust1.54 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 rust1.55 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 rust1.56 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 rust Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 rust Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 rust1.43 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 rust1.53 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 rust1.54 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 rust1.55 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 rust1.56 Not affected
SUSE Linux Enterprise Server 15 ESPOS rust Not affected
SUSE Linux Enterprise Server 15 LTSS rust Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS rust Not affected
SUSE Linux Enterprise Server 15 SP2 rust Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS rust Not affected
SUSE Linux Enterprise Server 15 SP3 rust Not affected
SUSE Linux Enterprise Server 15 SP3 rust1.43 Not affected
SUSE Linux Enterprise Server 15 SP3 rust1.53 Not affected
SUSE Linux Enterprise Server 15 SP3 rust1.54 Not affected
SUSE Linux Enterprise Server 15 SP3 rust1.55 Not affected
SUSE Linux Enterprise Server 15 SP3 rust1.56 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 rust Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 rust Not affected
SUSE Linux Enterprise Server for SAP Applications 15 rust Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 rust Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 rust Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rust Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rust1.43 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rust1.53 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rust1.54 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rust1.55 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rust1.56 Not affected
SUSE Linux Enterprise Storage 7 rust Not affected
SUSE Linux Enterprise Storage 7.1 rust Not affected
SUSE Linux Enterprise Storage 7.1 rust1.43 Not affected
SUSE Linux Enterprise Storage 7.1 rust1.53 Not affected
SUSE Linux Enterprise Storage 7.1 rust1.54 Not affected
SUSE Linux Enterprise Storage 7.1 rust1.55 Not affected
SUSE Linux Enterprise Storage 7.1 rust1.56 Not affected
SUSE Manager Proxy 4.1 rust Not affected
SUSE Manager Proxy 4.2 rust Not affected
SUSE Manager Proxy 4.2 rust1.43 Not affected
SUSE Manager Proxy 4.2 rust1.53 Not affected
SUSE Manager Proxy 4.2 rust1.54 Not affected
SUSE Manager Proxy 4.2 rust1.55 Not affected
SUSE Manager Proxy 4.2 rust1.56 Not affected
SUSE Manager Retail Branch Server 4.1 rust Not affected
SUSE Manager Retail Branch Server 4.2 rust Not affected
SUSE Manager Retail Branch Server 4.2 rust1.43 Not affected
SUSE Manager Retail Branch Server 4.2 rust1.53 Not affected
SUSE Manager Retail Branch Server 4.2 rust1.54 Not affected
SUSE Manager Retail Branch Server 4.2 rust1.55 Not affected
SUSE Manager Retail Branch Server 4.2 rust1.56 Not affected
SUSE Manager Server 4.1 rust Not affected
SUSE Manager Server 4.2 rust Not affected
SUSE Manager Server 4.2 rust1.43 Not affected
SUSE Manager Server 4.2 rust1.53 Not affected
SUSE Manager Server 4.2 rust1.54 Not affected
SUSE Manager Server 4.2 rust1.55 Not affected
SUSE Manager Server 4.2 rust1.56 Not affected
bci/rust:1.56 rust1.56Not affected