Upstream information

CVE-2021-44540 at MITRE

Description

A vulnerability was found in Privoxy which was fixed in get_url_spec_param() by freeing memory of compiled pattern spec before bailing.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1193584 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP3
  • privoxy >= 3.0.33-bp153.2.3.1
  • privoxy-doc >= 3.0.33-bp153.2.3.1
Patchnames:
openSUSE-2021-1646
SUSE Package Hub 15 SP4
  • privoxy >= 3.0.33-bp154.3.3.1
  • privoxy-doc >= 3.0.33-bp154.3.3.1
Patchnames:
openSUSE-2022-10186
openSUSE Leap 15.2
  • privoxy >= 3.0.33-lp152.3.12.1
  • privoxy-doc >= 3.0.33-lp152.3.12.1
Patchnames:
openSUSE-2021-1646
openSUSE Leap 15.3
  • privoxy >= 3.0.33-bp153.2.3.1
  • privoxy-doc >= 3.0.33-bp153.2.3.1
Patchnames:
openSUSE-2021-1646
openSUSE Leap 15.4
  • privoxy >= 3.0.33-bp154.3.3.1
  • privoxy-doc >= 3.0.33-bp154.3.3.1
Patchnames:
openSUSE-2022-10186
openSUSE Tumbleweed
  • privoxy >= 3.0.33-1.1
  • privoxy-doc >= 3.0.33-1.1
Patchnames:
openSUSE Tumbleweed GA privoxy-3.0.33-1.1


SUSE Timeline for this CVE

CVE page created: Thu Dec 9 14:00:03 2021
CVE page last modified: Tue Nov 15 17:42:32 2022