Upstream information

CVE-2021-43816 at MITRE

Description

containerd is an open source container runtime. On installations using SELinux, such as EL8 (CentOS, RHEL), Fedora, or SUSE MicroOS, with containerd since v1.5.0-beta.0 as the backing container runtime interface (CRI), an unprivileged pod scheduled to the node may bind mount, via hostPath volume, any privileged, regular file on disk for complete read/write access (sans delete). Such is achieved by placing the in-container location of the hostPath volume mount at either `/etc/hosts`, `/etc/hostname`, or `/etc/resolv.conf`. These locations are being relabeled indiscriminately to match the container process-label which effectively elevates permissions for savvy containers that would not normally be able to access privileged host files. This issue has been resolved in version 1.5.9. Users are advised to upgrade as soon as possible.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6
Vector AV:N/AC:M/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.1 8
Vector CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required High High
User Interaction None None
Scope Changed Changed
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1194359 [RESOLVED / UPSTREAM]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES15-EC2-CHOST-HVM-BYOS containerd Not affected
SLES15-SP1-CHOST-BYOS-Azure containerd Not affected
SLES15-SP1-CHOST-BYOS-EC2 containerd Not affected
SLES15-SP1-CHOST-BYOS-GCE containerd Not affected
SLES15-SP2-CHOST-BYOS-Aliyun containerd Not affected
SLES15-SP2-CHOST-BYOS-Azure containerd Not affected
SLES15-SP2-CHOST-BYOS-EC2 containerd Not affected
SLES15-SP2-CHOST-BYOS-GCE containerd Not affected
SLES15-SP3-CHOST-BYOS-Aliyun containerd Not affected
SLES15-SP3-CHOST-BYOS-Azure containerd Not affected
SLES15-SP3-CHOST-BYOS-EC2 containerd Not affected
SLES15-SP3-CHOST-BYOS-GCE containerd Not affected
SLES15-SP4-CHOST-BYOS containerd Not affected
SLES15-SP4-CHOST-BYOS-Aliyun containerd Not affected
SLES15-SP4-CHOST-BYOS-Azure containerd Not affected
SLES15-SP4-CHOST-BYOS-EC2 containerd Not affected
SLES15-SP4-CHOST-BYOS-GCE containerd Not affected
SUSE CaaS Platform 3.0 containerd Not affected
SUSE CaaS Platform 4.0 containerd Not affected
SUSE CaaS Platform 4.5 containerd Not affected
SUSE Enterprise Storage 6 containerd Not affected
SUSE Enterprise Storage 7 containerd Not affected
SUSE Enterprise Storage 7.1 containerd Not affected
SUSE Linux Enterprise Desktop 15 SP2 containerd Not affected
SUSE Linux Enterprise Desktop 15 SP3 containerd Not affected
SUSE Linux Enterprise High Performance Computing 12 containerd Not affected
SUSE Linux Enterprise High Performance Computing 15 containerd Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 containerd Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS containerd Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS containerd Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 containerd Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS containerd Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS containerd Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 containerd Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 containerd Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS containerd Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS containerd Not affected
SUSE Linux Enterprise Micro 5.0 containerd Not affected
SUSE Linux Enterprise Micro 5.1 containerd Not affected
SUSE Linux Enterprise Micro 5.2 containerd Not affected
SUSE Linux Enterprise Micro 5.3 containerd Not affected
SUSE Linux Enterprise Module for Containers 12 containerd Not affected
SUSE Linux Enterprise Module for Containers 15 containerd Not affected
SUSE Linux Enterprise Module for Containers 15 SP1 containerd Not affected
SUSE Linux Enterprise Module for Containers 15 SP2 containerd Not affected
SUSE Linux Enterprise Module for Containers 15 SP3 containerd Not affected
SUSE Linux Enterprise Module for Containers 15 SP4 containerd Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 containerd Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 containerd Not affected
SUSE Linux Enterprise Server 12 containerd Not affected
SUSE Linux Enterprise Server 12 SP3 containerd Not affected
SUSE Linux Enterprise Server 12 SP4 containerd Not affected
SUSE Linux Enterprise Server 12 SP5 containerd Not affected
SUSE Linux Enterprise Server 15 containerd Not affected
SUSE Linux Enterprise Server 15 SP1 containerd Not affected
SUSE Linux Enterprise Server 15 SP1-BCL containerd Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS containerd Not affected
SUSE Linux Enterprise Server 15 SP2 containerd Not affected
SUSE Linux Enterprise Server 15 SP2-BCL containerd Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS containerd Not affected
SUSE Linux Enterprise Server 15 SP3 containerd Not affected
SUSE Linux Enterprise Server 15 SP4 containerd Not affected
SUSE Linux Enterprise Server 15-ESPOS containerd Not affected
SUSE Linux Enterprise Server 15-LTSS containerd Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 containerd Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 containerd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 containerd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 containerd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 containerd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 containerd Not affected
SUSE Linux Enterprise Server for SAP Applications 15 containerd Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 containerd Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 containerd Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 containerd Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 containerd Not affected
SUSE Manager Proxy 4.0 containerd Not affected
SUSE Manager Proxy 4.1 containerd Not affected
SUSE Manager Proxy 4.2 containerd Not affected
SUSE Manager Proxy 4.3 containerd Not affected
SUSE Manager Retail Branch Server 4.0 containerd Not affected
SUSE Manager Retail Branch Server 4.1 containerd Not affected
SUSE Manager Retail Branch Server 4.2 containerd Not affected
SUSE Manager Retail Branch Server 4.3 containerd Not affected
SUSE Manager Server 4.0 containerd Not affected
SUSE Manager Server 4.1 containerd Not affected
SUSE Manager Server 4.2 containerd Not affected
SUSE Manager Server 4.3 containerd Not affected
SUSE OpenStack Cloud 6 containerd Not affected
SUSE OpenStack Cloud 6-LTSS containerd Not affected


SUSE Timeline for this CVE

CVE page created: Wed Jan 5 23:00:06 2022
CVE page last modified: Tue Nov 29 16:00:59 2022