Upstream information

CVE-2021-42762 at MITRE

Description

BubblewrapLauncher.cpp in WebKitGTK and WPE WebKit before 2.34.1 allows a limited sandbox bypass that allows a sandboxed process to trick host processes into thinking the sandboxed process is not confined by the sandbox, by abusing VFS syscalls that manipulate its filesystem namespace. The impact is limited to host services that create UNIX sockets that WebKit mounts inside its sandbox, and the sandboxed process remains otherwise confined. NOTE: this is similar to CVE-2021-41133.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 8.8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact Low High
Integrity Impact Low High
Availability Impact Low High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1191937 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion OpenStack 8
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
HPE-Helion-OpenStack-8-2021-3768
SUSE CaaS Platform 4.0
  • libjavascriptcoregtk-4_0-18 >= 2.34.1-3.87.1
  • libwebkit2gtk-4_0-37 >= 2.34.1-3.87.1
  • libwebkit2gtk3-lang >= 2.34.1-3.87.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.34.1-3.87.1
  • webkit2gtk-4_0-injected-bundles >= 2.34.1-3.87.1
  • webkit2gtk3-devel >= 2.34.1-3.87.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-3769
SUSE Enterprise Storage 6
  • libjavascriptcoregtk-4_0-18 >= 2.34.1-3.87.1
  • libwebkit2gtk-4_0-37 >= 2.34.1-3.87.1
  • libwebkit2gtk3-lang >= 2.34.1-3.87.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.34.1-3.87.1
  • webkit2gtk-4_0-injected-bundles >= 2.34.1-3.87.1
  • webkit2gtk3-devel >= 2.34.1-3.87.1
Patchnames:
SUSE-Storage-6-2021-3769
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-15.1
  • libwebkit2gtk-4_0-37 >= 2.32.4-15.1
  • libwebkit2gtk3-lang >= 2.32.4-15.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-15.1
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-15.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-15.1
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-15.1
  • webkit2gtk3-devel >= 2.32.4-15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-3603
SUSE-SLE-Module-Desktop-Applications-15-SP3-2021-3603
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-15.1
  • libwebkit2gtk-4_0-37 >= 2.32.4-15.1
  • libwebkit2gtk3-lang >= 2.32.4-15.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-15.1
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-15.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-15.1
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-15.1
  • webkit2gtk3-devel >= 2.32.4-15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-3603
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-3603
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libjavascriptcoregtk-4_0-18 >= 2.36.0-150400.2.13
  • libjavascriptcoregtk-4_1-0 >= 2.36.0-150400.2.13
  • libjavascriptcoregtk-5_0-0 >= 2.36.0-150400.2.12
  • libwebkit2gtk-4_0-37 >= 2.36.0-150400.2.13
  • libwebkit2gtk-4_1-0 >= 2.36.0-150400.2.13
  • libwebkit2gtk-5_0-0 >= 2.36.0-150400.2.12
  • typelib-1_0-JavaScriptCore-4_0 >= 2.36.0-150400.2.13
  • typelib-1_0-JavaScriptCore-4_1 >= 2.36.0-150400.2.13
  • typelib-1_0-JavaScriptCore-5_0 >= 2.36.0-150400.2.12
  • typelib-1_0-WebKit2-4_0 >= 2.36.0-150400.2.13
  • typelib-1_0-WebKit2-4_1 >= 2.36.0-150400.2.13
  • typelib-1_0-WebKit2-5_0 >= 2.36.0-150400.2.12
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.36.0-150400.2.13
  • typelib-1_0-WebKit2WebExtension-4_1 >= 2.36.0-150400.2.13
  • webkit2gtk-4_0-injected-bundles >= 2.36.0-150400.2.13
  • webkit2gtk-4_1-injected-bundles >= 2.36.0-150400.2.13
  • webkit2gtk-5_0-injected-bundles >= 2.36.0-150400.2.12
  • webkit2gtk3-devel >= 2.36.0-150400.2.13
  • webkit2gtk3-soup2-devel >= 2.36.0-150400.2.13
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libjavascriptcoregtk-4_0-18-2.36.0-150400.2.13
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA libjavascriptcoregtk-4_1-0-2.36.0-150400.2.13
SUSE Linux Enterprise Module for Development Tools 15 SP4 GA libjavascriptcoregtk-5_0-0-2.36.0-150400.2.12
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • libjavascriptcoregtk-4_0-18 >= 2.38.6-150400.4.39.1
  • libjavascriptcoregtk-4_1-0 >= 2.38.6-150400.4.39.1
  • libjavascriptcoregtk-5_0-0 >= 2.38.6-150400.4.39.1
  • libwebkit2gtk-4_0-37 >= 2.38.6-150400.4.39.1
  • libwebkit2gtk-4_1-0 >= 2.38.6-150400.4.39.1
  • libwebkit2gtk-5_0-0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-JavaScriptCore-4_1 >= 2.38.6-150400.4.39.1
  • typelib-1_0-JavaScriptCore-5_0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-WebKit2-4_0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-WebKit2-4_1 >= 2.38.6-150400.4.39.1
  • typelib-1_0-WebKit2-5_0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-WebKit2WebExtension-4_1 >= 2.38.6-150400.4.39.1
  • webkit2gtk-4_0-injected-bundles >= 2.38.6-150400.4.39.1
  • webkit2gtk-4_1-injected-bundles >= 2.38.6-150400.4.39.1
  • webkit2gtk-5_0-injected-bundles >= 2.38.6-150400.4.39.1
  • webkit2gtk3-devel >= 2.38.6-150400.4.39.1
  • webkit2gtk3-soup2-devel >= 2.38.6-150400.4.39.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP5 GA libjavascriptcoregtk-4_0-18-2.38.6-150400.4.39.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 GA libjavascriptcoregtk-4_1-0-2.38.6-150400.4.39.1
SUSE Linux Enterprise Module for Development Tools 15 SP5 GA libjavascriptcoregtk-5_0-0-2.38.6-150400.4.39.1
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • libjavascriptcoregtk-4_0-18 >= 2.34.1-3.87.1
  • libwebkit2gtk-4_0-37 >= 2.34.1-3.87.1
  • libwebkit2gtk3-lang >= 2.34.1-3.87.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.34.1-3.87.1
  • webkit2gtk-4_0-injected-bundles >= 2.34.1-3.87.1
  • webkit2gtk3-devel >= 2.34.1-3.87.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-3769
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • libjavascriptcoregtk-4_0-18 >= 2.34.1-3.87.1
  • libwebkit2gtk-4_0-37 >= 2.34.1-3.87.1
  • libwebkit2gtk3-lang >= 2.34.1-3.87.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.34.1-3.87.1
  • webkit2gtk-4_0-injected-bundles >= 2.34.1-3.87.1
  • webkit2gtk3-devel >= 2.34.1-3.87.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-3769
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • libjavascriptcoregtk-4_0-18 >= 2.34.1-3.87.1
  • libwebkit2gtk-4_0-37 >= 2.34.1-3.87.1
  • libwebkit2gtk3-lang >= 2.34.1-3.87.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.34.1-3.87.1
  • webkit2gtk-4_0-injected-bundles >= 2.34.1-3.87.1
  • webkit2gtk3-devel >= 2.34.1-3.87.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-3769
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-15.1
  • libwebkit2gtk-4_0-37 >= 2.32.4-15.1
  • libwebkit2gtk3-lang >= 2.32.4-15.1
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-3603
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-15.1
  • libwebkit2gtk-4_0-37 >= 2.32.4-15.1
  • libwebkit2gtk3-lang >= 2.32.4-15.1
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-3603
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libjavascriptcoregtk-4_0-18 >= 2.36.0-150400.2.13
  • libwebkit2gtk-4_0-37 >= 2.36.0-150400.2.13
  • typelib-1_0-JavaScriptCore-4_0 >= 2.36.0-150400.2.13
  • typelib-1_0-WebKit2-4_0 >= 2.36.0-150400.2.13
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.36.0-150400.2.13
  • webkit2gtk-4_0-injected-bundles >= 2.36.0-150400.2.13
  • webkit2gtk3-soup2-devel >= 2.36.0-150400.2.13
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libjavascriptcoregtk-4_0-18-2.36.0-150400.2.13
SUSE Linux Enterprise Module for Basesystem 15 SP5
  • libjavascriptcoregtk-4_0-18 >= 2.38.6-150400.4.39.1
  • libwebkit2gtk-4_0-37 >= 2.38.6-150400.4.39.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-WebKit2-4_0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.38.6-150400.4.39.1
  • webkit2gtk-4_0-injected-bundles >= 2.38.6-150400.4.39.1
  • webkit2gtk3-soup2-devel >= 2.38.6-150400.4.39.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP5 GA libjavascriptcoregtk-4_0-18-2.38.6-150400.4.39.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-15.1
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-15.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-15.1
  • webkit2gtk3-devel >= 2.32.4-15.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-3603
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-15.1
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-15.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-15.1
  • webkit2gtk3-devel >= 2.32.4-15.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2021-3603
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • libjavascriptcoregtk-4_1-0 >= 2.36.0-150400.2.13
  • libwebkit2gtk-4_1-0 >= 2.36.0-150400.2.13
  • typelib-1_0-JavaScriptCore-4_1 >= 2.36.0-150400.2.13
  • typelib-1_0-WebKit2-4_1 >= 2.36.0-150400.2.13
  • typelib-1_0-WebKit2WebExtension-4_1 >= 2.36.0-150400.2.13
  • webkit2gtk-4_1-injected-bundles >= 2.36.0-150400.2.13
  • webkit2gtk3-devel >= 2.36.0-150400.2.13
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA libjavascriptcoregtk-4_1-0-2.36.0-150400.2.13
SUSE Linux Enterprise Module for Desktop Applications 15 SP5
  • libjavascriptcoregtk-4_1-0 >= 2.38.6-150400.4.39.1
  • libwebkit2gtk-4_1-0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-JavaScriptCore-4_1 >= 2.38.6-150400.4.39.1
  • typelib-1_0-WebKit2-4_1 >= 2.38.6-150400.4.39.1
  • typelib-1_0-WebKit2WebExtension-4_1 >= 2.38.6-150400.4.39.1
  • webkit2gtk-4_1-injected-bundles >= 2.38.6-150400.4.39.1
  • webkit2gtk3-devel >= 2.38.6-150400.4.39.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 GA libjavascriptcoregtk-4_1-0-2.38.6-150400.4.39.1
SUSE Linux Enterprise Module for Development Tools 15 SP4
  • libjavascriptcoregtk-5_0-0 >= 2.36.0-150400.2.12
  • libwebkit2gtk-5_0-0 >= 2.36.0-150400.2.12
  • typelib-1_0-JavaScriptCore-5_0 >= 2.36.0-150400.2.12
  • typelib-1_0-WebKit2-5_0 >= 2.36.0-150400.2.12
  • webkit2gtk-5_0-injected-bundles >= 2.36.0-150400.2.12
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP4 GA libjavascriptcoregtk-5_0-0-2.36.0-150400.2.12
SUSE Linux Enterprise Module for Development Tools 15 SP5
  • libjavascriptcoregtk-5_0-0 >= 2.38.6-150400.4.39.1
  • libwebkit2gtk-5_0-0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-JavaScriptCore-5_0 >= 2.38.6-150400.4.39.1
  • typelib-1_0-WebKit2-5_0 >= 2.38.6-150400.4.39.1
  • webkit2gtk-5_0-injected-bundles >= 2.38.6-150400.4.39.1
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP5 GA libjavascriptcoregtk-5_0-0-2.38.6-150400.4.39.1
SUSE Linux Enterprise Server 12 SP2-BCL
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
  • webkit2gtk3-devel >= 2.32.4-2.74.5
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2021-3768
SUSE Linux Enterprise Server 12 SP3-BCL
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2021-3768
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2021-3768
SUSE Linux Enterprise Server 12 SP3-LTSS
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-SLE-SERVER-12-SP3-2021-3768
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-3768
SUSE Linux Enterprise Server 12 SP4-LTSS
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-3768
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
  • webkit2gtk3-devel >= 2.32.4-2.74.5
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-3768
SUSE-SLE-SERVER-12-SP5-2021-3768
SUSE Linux Enterprise Server 15 SP1-BCL
  • libjavascriptcoregtk-4_0-18 >= 2.34.1-3.87.1
  • libwebkit2gtk-4_0-37 >= 2.34.1-3.87.1
  • libwebkit2gtk3-lang >= 2.34.1-3.87.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.34.1-3.87.1
  • webkit2gtk-4_0-injected-bundles >= 2.34.1-3.87.1
  • webkit2gtk3-devel >= 2.34.1-3.87.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-3769
SUSE Linux Enterprise Server 15 SP1-LTSS
  • libjavascriptcoregtk-4_0-18 >= 2.34.1-3.87.1
  • libwebkit2gtk-4_0-37 >= 2.34.1-3.87.1
  • libwebkit2gtk3-lang >= 2.34.1-3.87.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.34.1-3.87.1
  • webkit2gtk-4_0-injected-bundles >= 2.34.1-3.87.1
  • webkit2gtk3-devel >= 2.34.1-3.87.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-3769
SUSE Linux Enterprise Server 15-LTSS
  • libjavascriptcoregtk-4_0-18 >= 2.34.1-3.87.1
  • libwebkit2gtk-4_0-37 >= 2.34.1-3.87.1
  • libwebkit2gtk3-lang >= 2.34.1-3.87.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.34.1-3.87.1
  • webkit2gtk-4_0-injected-bundles >= 2.34.1-3.87.1
  • webkit2gtk3-devel >= 2.34.1-3.87.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-3769
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-SLE-SAP-12-SP3-2021-3768
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-3768
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • libjavascriptcoregtk-4_0-18 >= 2.34.1-3.87.1
  • libwebkit2gtk-4_0-37 >= 2.34.1-3.87.1
  • libwebkit2gtk3-lang >= 2.34.1-3.87.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.34.1-3.87.1
  • webkit2gtk-4_0-injected-bundles >= 2.34.1-3.87.1
  • webkit2gtk3-devel >= 2.34.1-3.87.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-3769
SUSE Linux Enterprise Server for SAP Applications 15
  • libjavascriptcoregtk-4_0-18 >= 2.34.1-3.87.1
  • libwebkit2gtk-4_0-37 >= 2.34.1-3.87.1
  • libwebkit2gtk3-lang >= 2.34.1-3.87.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2-4_0 >= 2.34.1-3.87.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.34.1-3.87.1
  • webkit2gtk-4_0-injected-bundles >= 2.34.1-3.87.1
  • webkit2gtk3-devel >= 2.34.1-3.87.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-3769
SUSE Linux Enterprise Software Development Kit 12 SP5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk3-devel >= 2.32.4-2.74.5
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-3768
SUSE OpenStack Cloud 8
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-OpenStack-Cloud-8-2021-3768
SUSE OpenStack Cloud 9
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-OpenStack-Cloud-9-2021-3768
SUSE OpenStack Cloud Crowbar 8
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-3768
SUSE OpenStack Cloud Crowbar 9
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-2.74.5
  • libwebkit2gtk-4_0-37 >= 2.32.4-2.74.5
  • libwebkit2gtk3-lang >= 2.32.4-2.74.5
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-2.74.5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-2.74.5
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-2.74.5
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-3768
openSUSE Leap 15.2
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-lp152.2.22.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.32.4-lp152.2.22.1
  • libwebkit2gtk-4_0-37 >= 2.32.4-lp152.2.22.1
  • libwebkit2gtk-4_0-37-32bit >= 2.32.4-lp152.2.22.1
  • libwebkit2gtk3-lang >= 2.32.4-lp152.2.22.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-lp152.2.22.1
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-lp152.2.22.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-lp152.2.22.1
  • webkit-jsc-4 >= 2.32.4-lp152.2.22.1
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-lp152.2.22.1
  • webkit2gtk3-devel >= 2.32.4-lp152.2.22.1
  • webkit2gtk3-minibrowser >= 2.32.4-lp152.2.22.1
Patchnames:
openSUSE-2021-1454
openSUSE Leap 15.3
  • libjavascriptcoregtk-4_0-18 >= 2.32.4-15.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.32.4-15.1
  • libwebkit2gtk-4_0-37 >= 2.32.4-15.1
  • libwebkit2gtk-4_0-37-32bit >= 2.32.4-15.1
  • libwebkit2gtk3-lang >= 2.32.4-15.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.32.4-15.1
  • typelib-1_0-WebKit2-4_0 >= 2.32.4-15.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.32.4-15.1
  • webkit-jsc-4 >= 2.32.4-15.1
  • webkit2gtk-4_0-injected-bundles >= 2.32.4-15.1
  • webkit2gtk3-devel >= 2.32.4-15.1
  • webkit2gtk3-minibrowser >= 2.32.4-15.1
Patchnames:
openSUSE-SLE-15.3-2021-3603
openSUSE Leap 15.4
  • WebKit2GTK-4.1-lang >= 2.36.0-150400.2.13
  • WebKit2GTK-5.0-lang >= 2.36.0-150400.2.12
  • libjavascriptcoregtk-4_0-18 >= 2.36.0-150400.2.13
  • libjavascriptcoregtk-4_1-0 >= 2.36.0-150400.2.13
  • libjavascriptcoregtk-5_0-0 >= 2.36.0-150400.2.12
  • libwebkit2gtk-4_0-37 >= 2.36.0-150400.2.13
  • libwebkit2gtk-4_1-0 >= 2.36.0-150400.2.13
  • libwebkit2gtk-5_0-0 >= 2.36.0-150400.2.12
  • typelib-1_0-JavaScriptCore-4_0 >= 2.36.0-150400.2.13
  • typelib-1_0-JavaScriptCore-5_0 >= 2.36.0-150400.2.12
  • typelib-1_0-WebKit2-4_0 >= 2.36.0-150400.2.13
  • typelib-1_0-WebKit2-5_0 >= 2.36.0-150400.2.12
  • webkit2gtk-4_0-injected-bundles >= 2.36.0-150400.2.13
  • webkit2gtk-4_1-injected-bundles >= 2.36.0-150400.2.13
  • webkit2gtk-5_0-injected-bundles >= 2.36.0-150400.2.12
Patchnames:
openSUSE Leap 15.4 GA WebKit2GTK-4.1-lang-2.36.0-150400.2.13


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 webkit2gtk3 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 webkit2gtk3 Released
SUSE Linux Enterprise Real Time 15 SP3 webkit2gtk3 Affected
SUSE Linux Enterprise Server 12 SP5 webkit2gtk3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 webkit2gtk3 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 webkit2gtk3 Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 webkit2gtk3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 webkit2gtk3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS webkit2gtk3 Released
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS webkit2gtk3 Released
SUSE Linux Enterprise High Performance Computing 15 SP2 webkit2gtk3 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS webkit2gtk3 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS webkit2gtk3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 webkit2gtk3 Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS webkit2gtk3 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS webkit2gtk3 Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS webkit2gtk3 Released
SUSE Linux Enterprise High Performance Computing 15-LTSS webkit2gtk3 Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 webkit2gtk3 Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 webkit2gtk3 Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 webkit2gtk3 Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 webkit2gtk3 Released
SUSE Linux Enterprise Server 15 SP2 webkit2gtk3 Released
SUSE Linux Enterprise Server 15 SP2-LTSS webkit2gtk3 Affected
SUSE Linux Enterprise Server 15 SP3 webkit2gtk3 Released
SUSE Linux Enterprise Server 15 SP3-LTSS webkit2gtk3 Affected
SUSE Linux Enterprise Server 15-ESPOS webkit2gtk3 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 webkit2gtk3 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 webkit2gtk3 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 webkit2gtk3 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 webkit2gtk3 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 webkit2gtk3 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 webkit2gtk3 Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 webkit2gtk3 Released
SUSE CaaS Platform 4.0 webkit2gtk3 Released
SUSE CaaS Platform 4.5 webkit2gtk3 Unsupported
SUSE Enterprise Storage 6 webkit2gtk3 Released
SUSE Enterprise Storage 7 webkit2gtk3 Released
SUSE Linux Enterprise Desktop 12 SP2 webkit2gtk3 Affected
SUSE Linux Enterprise Desktop 12 SP3 webkit2gtk3 Affected
SUSE Linux Enterprise Desktop 12 SP4 webkit2gtk3 Affected
SUSE Linux Enterprise Desktop 15 webkit2gtk3 Affected
SUSE Linux Enterprise Desktop 15 SP1 webkit2gtk3 Affected
SUSE Linux Enterprise Desktop 15 SP2 webkit2gtk3 Released
SUSE Linux Enterprise Desktop 15 SP3 webkit2gtk3 Released
SUSE Linux Enterprise Module for Basesystem 15 webkit2gtk3 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 webkit2gtk3 Affected
SUSE Linux Enterprise Module for Desktop Applications 15 webkit2gtk3 Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 webkit2gtk3 Affected
SUSE Linux Enterprise Real Time 15 SP2 webkit2gtk3 Unsupported
SUSE Linux Enterprise Server 12 SP2 webkit2gtk3 Affected
SUSE Linux Enterprise Server 12 SP2-BCL webkit2gtk3 Released
SUSE Linux Enterprise Server 12 SP2-ESPOS webkit2gtk3 Affected
SUSE Linux Enterprise Server 12 SP2-LTSS webkit2gtk3 Affected
SUSE Linux Enterprise Server 12 SP3 webkit2gtk3 Affected
SUSE Linux Enterprise Server 12 SP3-BCL webkit2gtk3 Released
SUSE Linux Enterprise Server 12 SP3-ESPOS webkit2gtk3 Released
SUSE Linux Enterprise Server 12 SP3-LTSS webkit2gtk3 Released
SUSE Linux Enterprise Server 12 SP4 webkit2gtk3 Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS webkit2gtk3 Released
SUSE Linux Enterprise Server 12 SP4-LTSS webkit2gtk3 Released
SUSE Linux Enterprise Server 15 webkit2gtk3 Affected
SUSE Linux Enterprise Server 15 SP1 webkit2gtk3 Affected
SUSE Linux Enterprise Server 15 SP1-BCL webkit2gtk3 Released
SUSE Linux Enterprise Server 15 SP1-LTSS webkit2gtk3 Released
SUSE Linux Enterprise Server 15 SP2-BCL webkit2gtk3 Affected
SUSE Linux Enterprise Server 15 SP3-BCL webkit2gtk3 Affected
SUSE Linux Enterprise Server 15-LTSS webkit2gtk3 Released
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 webkit2gtk3 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 webkit2gtk3 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 webkit2gtk3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 webkit2gtk3 Released
SUSE Linux Enterprise Software Development Kit 12 SP2 webkit2gtk3 Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 webkit2gtk3 Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 webkit2gtk3 Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 webkit2gtk3 Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 webkit2gtk3 Affected
SUSE Linux Enterprise Workstation Extension 12 SP4 webkit2gtk3 Affected
SUSE Manager Proxy 4.0 webkit2gtk3 Affected
SUSE Manager Proxy 4.1 webkit2gtk3 Released
SUSE Manager Proxy 4.2 webkit2gtk3 Released
SUSE Manager Retail Branch Server 4.0 webkit2gtk3 Affected
SUSE Manager Retail Branch Server 4.1 webkit2gtk3 Released
SUSE Manager Retail Branch Server 4.2 webkit2gtk3 Released
SUSE Manager Server 4.0 webkit2gtk3 Affected
SUSE Manager Server 4.1 webkit2gtk3 Released
SUSE Manager Server 4.2 webkit2gtk3 Released
SUSE OpenStack Cloud 7 webkit2gtk3 Affected
SUSE OpenStack Cloud 8 webkit2gtk3 Released
SUSE OpenStack Cloud 9 webkit2gtk3 Released
SUSE OpenStack Cloud Crowbar 8 webkit2gtk3 Released
SUSE OpenStack Cloud Crowbar 9 webkit2gtk3 Released


SUSE Timeline for this CVE

CVE page created: Thu Oct 21 00:00:02 2021
CVE page last modified: Fri Apr 12 17:35:14 2024