Upstream information

CVE-2021-42717 at MITRE

Description

ModSecurity 3.x through 3.0.5 mishandles excessively nested JSON objects. Crafted JSON objects with nesting tens-of-thousands deep could result in the web server being unable to service legitimate requests. Even a moderately large (e.g., 300KB) HTTP request can occupy one of the limited NGINX worker processes for minutes and consume almost all of the available CPU on the machine. Modsecurity 2 is similarly vulnerable: the affected versions include 2.8.0 through 2.9.4.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1195450 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • libmodsecurity3 >= 3.0.6-1.1
  • libmodsecurity3-32bit >= 3.0.6-1.1
  • modsecurity >= 3.0.6-1.1
  • modsecurity-devel >= 3.0.6-1.1
Patchnames:
openSUSE Tumbleweed GA libmodsecurity3-3.0.6-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 apache2-mod_security2 Not affected
SUSE Enterprise Storage 7.1 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Real Time 15 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP5 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 apache2-mod_security2 Not affected
SUSE Manager Proxy 4.2 apache2-mod_security2 Not affected
SUSE Manager Proxy 4.3 apache2-mod_security2 Not affected
SUSE Manager Retail Branch Server 4.2 apache2-mod_security2 Not affected
SUSE Manager Retail Branch Server 4.3 apache2-mod_security2 Not affected
SUSE Manager Server 4.2 apache2-mod_security2 Not affected
SUSE Manager Server 4.3 apache2-mod_security2 Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP2-BCL apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 apache2-mod_security2 Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 apache2-mod_security2 Not affected
SUSE CaaS Platform 4.0 apache2-mod_security2 Not affected
SUSE Enterprise Storage 6 apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 apache2-mod_security2 Not affected
SUSE Linux Enterprise Real Time 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 11 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 11 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP3-BCL apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP1-BCL apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 apache2-mod_security2 Not affected
SUSE Manager Proxy 4.0 apache2-mod_security2 Not affected
SUSE Manager Proxy 4.1 apache2-mod_security2 Not affected
SUSE Manager Retail Branch Server 4.0 apache2-mod_security2 Not affected
SUSE Manager Retail Branch Server 4.1 apache2-mod_security2 Not affected
SUSE Manager Server 4.0 apache2-mod_security2 Not affected
SUSE Manager Server 4.1 apache2-mod_security2 Not affected
SUSE OpenStack Cloud 7 apache2-mod_security2 Not affected
SUSE OpenStack Cloud 8 apache2-mod_security2 Not affected
SUSE OpenStack Cloud 9 apache2-mod_security2 Not affected
SUSE OpenStack Cloud Crowbar 8 apache2-mod_security2 Not affected
SUSE OpenStack Cloud Crowbar 9 apache2-mod_security2 Not affected


SUSE Timeline for this CVE

CVE page created: Wed Dec 8 01:00:41 2021
CVE page last modified: Fri Jan 20 16:10:35 2023