Upstream information

CVE-2021-41079 at MITRE

Description

Apache Tomcat 8.5.0 to 8.5.63, 9.0.0-M1 to 9.0.43 and 10.0.0-M1 to 10.0.2 did not properly validate incoming TLS packets. When Tomcat was configured to use NIO+OpenSSL or NIO2+OpenSSL for TLS, a specially crafted packet could be used to trigger an infinite loop resulting in a denial of service.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.9
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1190558 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • tomcat >= 9.0.36-4.63.1
  • tomcat-admin-webapps >= 9.0.36-4.63.1
  • tomcat-el-3_0-api >= 9.0.36-4.63.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.63.1
  • tomcat-lib >= 9.0.36-4.63.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.63.1
  • tomcat-webapps >= 9.0.36-4.63.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-3669
SUSE Enterprise Storage 6
  • tomcat >= 9.0.36-4.63.1
  • tomcat-admin-webapps >= 9.0.36-4.63.1
  • tomcat-el-3_0-api >= 9.0.36-4.63.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.63.1
  • tomcat-lib >= 9.0.36-4.63.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.63.1
  • tomcat-webapps >= 9.0.36-4.63.1
Patchnames:
SUSE-Storage-6-2021-3669
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • tomcat >= 9.0.36-4.63.1
  • tomcat-admin-webapps >= 9.0.36-4.63.1
  • tomcat-el-3_0-api >= 9.0.36-4.63.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.63.1
  • tomcat-lib >= 9.0.36-4.63.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.63.1
  • tomcat-webapps >= 9.0.36-4.63.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-3669
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • tomcat >= 9.0.36-4.63.1
  • tomcat-admin-webapps >= 9.0.36-4.63.1
  • tomcat-el-3_0-api >= 9.0.36-4.63.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.63.1
  • tomcat-lib >= 9.0.36-4.63.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.63.1
  • tomcat-webapps >= 9.0.36-4.63.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-3669
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • tomcat >= 9.0.36-3.84.1
  • tomcat-admin-webapps >= 9.0.36-3.84.1
  • tomcat-el-3_0-api >= 9.0.36-3.84.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.84.1
  • tomcat-lib >= 9.0.36-3.84.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.84.1
  • tomcat-webapps >= 9.0.36-3.84.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-3670
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • tomcat-docs-webapp >= 9.0.36-13.1
  • tomcat-embed >= 9.0.36-13.1
  • tomcat-javadoc >= 9.0.36-13.1
  • tomcat-jsvc >= 9.0.36-13.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-3672
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • tomcat-docs-webapp >= 9.0.36-13.1
  • tomcat-embed >= 9.0.36-13.1
  • tomcat-javadoc >= 9.0.36-13.1
  • tomcat-jsvc >= 9.0.36-13.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-3672
SUSE Linux Enterprise Module for Web Scripting 15 SP2
  • tomcat >= 9.0.36-13.1
  • tomcat-admin-webapps >= 9.0.36-13.1
  • tomcat-el-3_0-api >= 9.0.36-13.1
  • tomcat-jsp-2_3-api >= 9.0.36-13.1
  • tomcat-lib >= 9.0.36-13.1
  • tomcat-servlet-4_0-api >= 9.0.36-13.1
  • tomcat-webapps >= 9.0.36-13.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP2-2021-3672
SUSE Linux Enterprise Module for Web Scripting 15 SP3
  • tomcat >= 9.0.36-13.1
  • tomcat-admin-webapps >= 9.0.36-13.1
  • tomcat-el-3_0-api >= 9.0.36-13.1
  • tomcat-jsp-2_3-api >= 9.0.36-13.1
  • tomcat-lib >= 9.0.36-13.1
  • tomcat-servlet-4_0-api >= 9.0.36-13.1
  • tomcat-webapps >= 9.0.36-13.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP3-2021-3672
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • javapackages-tools >= 2.0.1-13.1
  • tomcat >= 9.0.36-3.71.1
  • tomcat-admin-webapps >= 9.0.36-3.71.1
  • tomcat-docs-webapp >= 9.0.36-3.71.1
  • tomcat-el-3_0-api >= 9.0.36-3.71.1
  • tomcat-javadoc >= 9.0.36-3.71.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.71.1
  • tomcat-lib >= 9.0.36-3.71.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.71.1
  • tomcat-webapps >= 9.0.36-3.71.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-3602
SUSE Linux Enterprise Server 12 SP4-LTSS
  • javapackages-tools >= 2.0.1-13.1
  • tomcat >= 9.0.36-3.71.1
  • tomcat-admin-webapps >= 9.0.36-3.71.1
  • tomcat-docs-webapp >= 9.0.36-3.71.1
  • tomcat-el-3_0-api >= 9.0.36-3.71.1
  • tomcat-javadoc >= 9.0.36-3.71.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.71.1
  • tomcat-lib >= 9.0.36-3.71.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.71.1
  • tomcat-webapps >= 9.0.36-3.71.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-3602
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • javapackages-tools >= 2.0.1-13.1
  • tomcat >= 9.0.36-3.71.1
  • tomcat-admin-webapps >= 9.0.36-3.71.1
  • tomcat-docs-webapp >= 9.0.36-3.71.1
  • tomcat-el-3_0-api >= 9.0.36-3.71.1
  • tomcat-javadoc >= 9.0.36-3.71.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.71.1
  • tomcat-lib >= 9.0.36-3.71.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.71.1
  • tomcat-webapps >= 9.0.36-3.71.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-3602
SUSE Linux Enterprise Server 15 SP1-BCL
  • tomcat >= 9.0.36-4.63.1
  • tomcat-admin-webapps >= 9.0.36-4.63.1
  • tomcat-el-3_0-api >= 9.0.36-4.63.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.63.1
  • tomcat-lib >= 9.0.36-4.63.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.63.1
  • tomcat-webapps >= 9.0.36-4.63.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-3669
SUSE Linux Enterprise Server 15 SP1-LTSS
  • tomcat >= 9.0.36-4.63.1
  • tomcat-admin-webapps >= 9.0.36-4.63.1
  • tomcat-el-3_0-api >= 9.0.36-4.63.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.63.1
  • tomcat-lib >= 9.0.36-4.63.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.63.1
  • tomcat-webapps >= 9.0.36-4.63.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-3669
SUSE Linux Enterprise Server 15-LTSS
  • tomcat >= 9.0.36-3.84.1
  • tomcat-admin-webapps >= 9.0.36-3.84.1
  • tomcat-el-3_0-api >= 9.0.36-3.84.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.84.1
  • tomcat-lib >= 9.0.36-3.84.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.84.1
  • tomcat-webapps >= 9.0.36-3.84.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-3670
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • javapackages-tools >= 2.0.1-13.1
  • tomcat >= 9.0.36-3.71.1
  • tomcat-admin-webapps >= 9.0.36-3.71.1
  • tomcat-docs-webapp >= 9.0.36-3.71.1
  • tomcat-el-3_0-api >= 9.0.36-3.71.1
  • tomcat-javadoc >= 9.0.36-3.71.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.71.1
  • tomcat-lib >= 9.0.36-3.71.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.71.1
  • tomcat-webapps >= 9.0.36-3.71.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-3602
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • tomcat >= 9.0.36-4.63.1
  • tomcat-admin-webapps >= 9.0.36-4.63.1
  • tomcat-el-3_0-api >= 9.0.36-4.63.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.63.1
  • tomcat-lib >= 9.0.36-4.63.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.63.1
  • tomcat-webapps >= 9.0.36-4.63.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-3669
SUSE Linux Enterprise Server for SAP Applications 15
  • tomcat >= 9.0.36-3.84.1
  • tomcat-admin-webapps >= 9.0.36-3.84.1
  • tomcat-el-3_0-api >= 9.0.36-3.84.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.84.1
  • tomcat-lib >= 9.0.36-3.84.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.84.1
  • tomcat-webapps >= 9.0.36-3.84.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-3670
SUSE OpenStack Cloud 9
  • javapackages-tools >= 2.0.1-13.1
  • tomcat >= 9.0.36-3.71.1
  • tomcat-admin-webapps >= 9.0.36-3.71.1
  • tomcat-docs-webapp >= 9.0.36-3.71.1
  • tomcat-el-3_0-api >= 9.0.36-3.71.1
  • tomcat-javadoc >= 9.0.36-3.71.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.71.1
  • tomcat-lib >= 9.0.36-3.71.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.71.1
  • tomcat-webapps >= 9.0.36-3.71.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-3602
SUSE OpenStack Cloud Crowbar 9
  • javapackages-tools >= 2.0.1-13.1
  • tomcat >= 9.0.36-3.71.1
  • tomcat-admin-webapps >= 9.0.36-3.71.1
  • tomcat-docs-webapp >= 9.0.36-3.71.1
  • tomcat-el-3_0-api >= 9.0.36-3.71.1
  • tomcat-javadoc >= 9.0.36-3.71.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.71.1
  • tomcat-lib >= 9.0.36-3.71.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.71.1
  • tomcat-webapps >= 9.0.36-3.71.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-3602
openSUSE Leap 15.2
  • tomcat >= 9.0.36-lp152.2.25.1
  • tomcat-admin-webapps >= 9.0.36-lp152.2.25.1
  • tomcat-docs-webapp >= 9.0.36-lp152.2.25.1
  • tomcat-el-3_0-api >= 9.0.36-lp152.2.25.1
  • tomcat-embed >= 9.0.36-lp152.2.25.1
  • tomcat-javadoc >= 9.0.36-lp152.2.25.1
  • tomcat-jsp-2_3-api >= 9.0.36-lp152.2.25.1
  • tomcat-jsvc >= 9.0.36-lp152.2.25.1
  • tomcat-lib >= 9.0.36-lp152.2.25.1
  • tomcat-servlet-4_0-api >= 9.0.36-lp152.2.25.1
  • tomcat-webapps >= 9.0.36-lp152.2.25.1
Patchnames:
openSUSE-2021-1490
openSUSE Leap 15.3
  • tomcat >= 9.0.36-13.1
  • tomcat-admin-webapps >= 9.0.36-13.1
  • tomcat-docs-webapp >= 9.0.36-13.1
  • tomcat-el-3_0-api >= 9.0.36-13.1
  • tomcat-embed >= 9.0.36-13.1
  • tomcat-javadoc >= 9.0.36-13.1
  • tomcat-jsp-2_3-api >= 9.0.36-13.1
  • tomcat-jsvc >= 9.0.36-13.1
  • tomcat-lib >= 9.0.36-13.1
  • tomcat-servlet-4_0-api >= 9.0.36-13.1
  • tomcat-webapps >= 9.0.36-13.1
Patchnames:
openSUSE-SLE-15.3-2021-3672
openSUSE Tumbleweed
  • tomcat >= 9.0.43-2.1
  • tomcat-admin-webapps >= 9.0.43-2.1
  • tomcat-docs-webapp >= 9.0.43-2.1
  • tomcat-el-3_0-api >= 9.0.43-2.1
  • tomcat-embed >= 9.0.43-2.1
  • tomcat-javadoc >= 9.0.43-2.1
  • tomcat-jsp-2_3-api >= 9.0.43-2.1
  • tomcat-jsvc >= 9.0.43-2.1
  • tomcat-lib >= 9.0.43-2.1
  • tomcat-servlet-4_0-api >= 9.0.43-2.1
  • tomcat-webapps >= 9.0.43-2.1
Patchnames:
openSUSE Tumbleweed GA tomcat-9.0.43-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 tomcat Not affected
SLES-LTSS-SAP tomcat Not affected
SUSE CaaS Platform 4.0 tomcat Released
SUSE Enterprise Storage 6 tomcat Released
SUSE Linux Enterprise High Performance Computing 12 SP5 tomcat Released
SUSE Linux Enterprise High Performance Computing 15 LTSS tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS tomcat Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 tomcat Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 tomcat Released
SUSE Linux Enterprise Point of Service 11 SP3 tomcat6 Not affected
SUSE Linux Enterprise Server 11 SP1 tomcat6 Analysis
SUSE Linux Enterprise Server 11 SP3 tomcat6 Analysis
SUSE Linux Enterprise Server 11 SP4 tomcat6 Analysis
SUSE Linux Enterprise Server 11 SP4 LTSS tomcat6 Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS tomcat Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS tomcat Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS tomcat Released
SUSE Linux Enterprise Server 12 SP4 LTSS tomcat Released
SUSE Linux Enterprise Server 12 SP5 tomcat Released
SUSE Linux Enterprise Server 15 ESPOS tomcat Released
SUSE Linux Enterprise Server 15 LTSS tomcat Released
SUSE Linux Enterprise Server 15 SP1 LTSS tomcat Released
SUSE Linux Enterprise Server BCL 12 SP2 tomcat Not affected
SUSE Linux Enterprise Server BCL 12 SP3 tomcat Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 tomcat Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 tomcat In progress
SUSE Linux Enterprise Server for SAP Applications 15 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 tomcat Released
SUSE OpenStack Cloud 8 tomcat Not affected
SUSE OpenStack Cloud 9 tomcat Released
SUSE OpenStack Cloud Crowbar 8 tomcat Not affected
SUSE OpenStack Cloud Crowbar 9 tomcat Released