Upstream information

CVE-2021-40528 at MITRE

Description

The ElGamal implementation in Libgcrypt before 1.9.4 allows plaintext recovery because, during interaction between two cryptographic libraries, a certain dangerous combination of the prime defined by the receiver's public key, the generator defined by the receiver's public key, and the sender's ephemeral exponents can lead to a cross-configuration attack against OpenPGP.

SUSE information

Overall state of this security issue: Analysis

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1190239 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libgcrypt Affected
SLES-LTSS-SAP libgcrypt Affected
SUSE CaaS Platform 4.0 libgcrypt Affected
SUSE Enterprise Storage 6 libgcrypt Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libgcrypt Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS libgcrypt Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS libgcrypt Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS libgcrypt Affected
SUSE Linux Enterprise Micro 5.0 libgcrypt Affected
SUSE Linux Enterprise Micro 5.1 libgcrypt Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 libgcrypt Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 libgcrypt Affected
SUSE Linux Enterprise Point of Service 11 SP3 libgcrypt Affected
SUSE Linux Enterprise Server 11 SP1 libgcrypt Analysis
SUSE Linux Enterprise Server 11 SP3 libgcrypt Analysis
SUSE Linux Enterprise Server 11 SP4 libgcrypt Analysis
SUSE Linux Enterprise Server 11 SP4 LTSS libgcrypt Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS libgcrypt Affected
SUSE Linux Enterprise Server 12 SP3 LTSS libgcrypt Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS libgcrypt Affected
SUSE Linux Enterprise Server 12 SP4 LTSS libgcrypt Affected
SUSE Linux Enterprise Server 12 SP5 libgcrypt Affected
SUSE Linux Enterprise Server 15 ESPOS libgcrypt Affected
SUSE Linux Enterprise Server 15 LTSS libgcrypt Affected
SUSE Linux Enterprise Server 15 SP1 LTSS libgcrypt Affected
SUSE Linux Enterprise Server BCL 12 SP2 libgcrypt Affected
SUSE Linux Enterprise Server BCL 12 SP3 libgcrypt Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libgcrypt Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libgcrypt Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libgcrypt Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libgcrypt Affected
SUSE Linux Enterprise Server for SAP Applications 15 libgcrypt Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libgcrypt Affected
SUSE OpenStack Cloud 8 libgcrypt Affected
SUSE OpenStack Cloud 9 libgcrypt Affected
SUSE OpenStack Cloud Crowbar 8 libgcrypt Affected
SUSE OpenStack Cloud Crowbar 9 libgcrypt Affected