Upstream information

CVE-2021-4024 at MITRE

Description

A flaw was found in podman. The `podman machine` function (used to create and manage Podman virtual machine containing a Podman process) spawns a `gvproxy` process on the host system. The `gvproxy` API is accessible on port 7777 on all IP addresses on the host. If that port is open on the host's firewall, an attacker can potentially use the `gvproxy` API to forward ports on the host to ports in the VM, making private services on the VM accessible to the network. This issue could be also used to interrupt the host's services by forwarding all ports to the VM.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 4.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1193166 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/bci-init:15.3.10.2
Container ses/7.1/ceph/haproxy:2.0.14.2.2.10
Container ses/7.1/ceph/keepalived:2.0.19.2.2.10
Container ses/7.1/cephcsi/cephcsi:v3.5.1.0
Container ses/7.1/rook/ceph:1.8.6.0.3.2.5
Container suse/sle-micro-rancher/5.2:latest
Container suse/sle-micro/5.2/toolbox:11.1-6.2.1
Container trento/trento-db:14.1-rev1.0.0-build2.2.43
Image SLES15-SP3-Azure-Basic
Image SLES15-SP3-Azure-Standard
Image SLES15-SP3-BYOS-Azure
Image SLES15-SP3-BYOS-EC2-HVM
Image SLES15-SP3-BYOS-GCE
Image SLES15-SP3-CHOST-BYOS-Aliyun
Image SLES15-SP3-CHOST-BYOS-Azure
Image SLES15-SP3-CHOST-BYOS-EC2
Image SLES15-SP3-CHOST-BYOS-GCE
Image SLES15-SP3-EC2-ECS-HVM
Image SLES15-SP3-EC2-HVM
Image SLES15-SP3-GCE
Image SLES15-SP3-HPC-Azure
Image SLES15-SP3-HPC-BYOS-Azure
Image SLES15-SP3-HPC-BYOS-EC2-HVM
Image SLES15-SP3-HPC-BYOS-GCE
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-GCE
Image SLES15-SP3-Manager-4-2-Server-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Server-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Server-BYOS-GCE
Image SLES15-SP3-Micro-5-1-BYOS-Azure
Image SLES15-SP3-Micro-5-1-BYOS-EC2-HVM
Image SLES15-SP3-Micro-5-1-BYOS-GCE
Image SLES15-SP3-Micro-5-2-BYOS-Azure
Image SLES15-SP3-Micro-5-2-BYOS-EC2-HVM
Image SLES15-SP3-Micro-5-2-BYOS-GCE
Image SLES15-SP3-SAP-Azure
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-BYOS-Azure
Image SLES15-SP3-SAP-BYOS-EC2-HVM
Image SLES15-SP3-SAP-BYOS-GCE
Image SLES15-SP3-SAP-EC2-HVM
Image SLES15-SP3-SAP-GCE
Image SLES15-SP3-SAPCAL-Azure
Image SLES15-SP3-SAPCAL-EC2-HVM
Image SLES15-SP3-SAPCAL-GCE
  • libseccomp2 >= 2.5.3-150300.10.5.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libcontainers-common >= 20210626-150300.8.3.1
  • libseccomp-devel >= 2.5.3-150300.10.5.1
  • libseccomp2 >= 2.5.3-150300.10.5.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-23018
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • conmon >= 2.0.30-150300.8.3.1
  • libcontainers-common >= 20210626-150300.8.3.1
  • libseccomp-devel >= 2.5.3-150300.10.5.1
  • libseccomp2 >= 2.5.3-150300.10.5.1
  • podman >= 3.4.4-150300.9.3.2
  • podman-cni-config >= 3.4.4-150300.9.3.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-23018
SUSE-SLE-Module-Containers-15-SP3-2022-23018
SUSE Linux Enterprise Micro 5.1
  • conmon >= 2.0.30-150300.8.3.1
  • libcontainers-common >= 20210626-150300.8.3.1
  • libseccomp2 >= 2.5.3-150300.10.5.1
  • podman >= 3.4.4-150300.9.3.2
  • podman-cni-config >= 3.4.4-150300.9.3.2
Patchnames:
SUSE-SUSE-MicroOS-5.1-2022-23018
SUSE Linux Enterprise Module for Containers 15 SP3
  • conmon >= 2.0.30-150300.8.3.1
  • podman >= 3.4.4-150300.9.3.2
  • podman-cni-config >= 3.4.4-150300.9.3.2
Patchnames:
SUSE-SLE-Module-Containers-15-SP3-2022-23018
openSUSE Leap 15.3
  • conmon >= 2.0.30-150300.8.3.1
  • libcontainers-common >= 20210626-150300.8.3.1
  • libseccomp-devel >= 2.5.3-150300.10.5.1
  • libseccomp-tools >= 2.5.3-150300.10.5.1
  • libseccomp2 >= 2.5.3-150300.10.5.1
  • libseccomp2-32bit >= 2.5.3-150300.10.5.1
  • podman >= 3.4.4-150300.9.3.2
  • podman-cni-config >= 3.4.4-150300.9.3.2
Patchnames:
openSUSE-SLE-15.3-2022-23018
openSUSE Tumbleweed
  • podman >= 3.4.4-1.1
  • podman-cni-config >= 3.4.4-1.1
  • podman-docker >= 3.4.4-1.1
  • podman-remote >= 3.4.4-1.1
Patchnames:
openSUSE Tumbleweed GA podman-3.4.4-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 podman Not affected
SUSE Enterprise Storage 6 podman Not affected
SUSE Enterprise Storage 7 podman Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS podman Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS podman Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 podman Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 podman Released
SUSE Linux Enterprise High Performance Computing 15 SP4 podman Already fixed
SUSE Linux Enterprise Micro 5.0 podman Not affected
SUSE Linux Enterprise Micro 5.1 podman Released
SUSE Linux Enterprise Module for Containers 15 SP2 podman Not affected
SUSE Linux Enterprise Module for Containers 15 SP3 podman Released
SUSE Linux Enterprise Module for Containers 15 SP4 podman Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS podman Not affected
SUSE Linux Enterprise Server 15 SP2 podman Not affected
SUSE Linux Enterprise Server 15 SP3 podman Released
SUSE Linux Enterprise Server 15 SP4 podman Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 podman Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 podman Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 podman Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 podman Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 podman Already fixed
SUSE Linux Enterprise Storage 7 podman Not affected
SUSE Linux Enterprise Storage 7.1 podman Released
SUSE Manager Proxy 4.1 podman Not affected
SUSE Manager Proxy 4.2 podman Released
SUSE Manager Proxy 4.3 podman Already fixed
SUSE Manager Retail Branch Server 4.1 podman Not affected
SUSE Manager Retail Branch Server 4.2 podman Released
SUSE Manager Retail Branch Server 4.3 podman Already fixed
SUSE Manager Server 4.1 podman Not affected
SUSE Manager Server 4.2 podman Released
SUSE Manager Server 4.3 podman Already fixed