Upstream information

CVE-2021-39365 at MITRE

Description

In GNOME grilo though 0.3.13, grl-net-wc.c does not enable TLS certificate verification on the SoupSessionAsync objects it creates, leaving users vulnerable to network MITM attacks. NOTE: this is similar to CVE-2016-20011.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1189839 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • grilo-devel >= 0.3.4-3.3.1
  • libgrilo-0_3-0 >= 0.3.4-3.3.1
  • libgrlnet-0_3-0 >= 0.3.4-3.3.1
  • libgrlpls-0_3-0 >= 0.3.4-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.4-3.3.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-3295
SUSE Enterprise Storage 6
  • grilo-devel >= 0.3.4-3.3.1
  • libgrilo-0_3-0 >= 0.3.4-3.3.1
  • libgrlnet-0_3-0 >= 0.3.4-3.3.1
  • libgrlpls-0_3-0 >= 0.3.4-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.4-3.3.1
Patchnames:
SUSE-Storage-6-2021-3295
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • grilo-devel >= 0.3.4-3.3.1
  • libgrilo-0_3-0 >= 0.3.4-3.3.1
  • libgrlnet-0_3-0 >= 0.3.4-3.3.1
  • libgrlpls-0_3-0 >= 0.3.4-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.4-3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-3295
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • grilo-devel >= 0.3.4-3.3.1
  • libgrilo-0_3-0 >= 0.3.4-3.3.1
  • libgrlnet-0_3-0 >= 0.3.4-3.3.1
  • libgrlpls-0_3-0 >= 0.3.4-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.4-3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-3295
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • grilo-devel >= 0.3.4-3.3.1
  • libgrilo-0_3-0 >= 0.3.4-3.3.1
  • libgrlnet-0_3-0 >= 0.3.4-3.3.1
  • libgrlpls-0_3-0 >= 0.3.4-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.4-3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-3295
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • grilo-devel >= 0.3.12-3.3.1
  • libgrilo-0_3-0 >= 0.3.12-3.3.1
  • libgrlnet-0_3-0 >= 0.3.12-3.3.1
  • libgrlpls-0_3-0 >= 0.3.12-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.12-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.12-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.12-3.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-3194
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • grilo-devel >= 0.3.12-3.3.1
  • libgrilo-0_3-0 >= 0.3.12-3.3.1
  • libgrlnet-0_3-0 >= 0.3.12-3.3.1
  • libgrlpls-0_3-0 >= 0.3.12-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.12-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.12-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.12-3.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2021-3194
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libgrilo-0_3-0 >= 0.3.2-7.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-3003
SUSE Linux Enterprise Server 15 SP1-BCL
  • grilo-devel >= 0.3.4-3.3.1
  • libgrilo-0_3-0 >= 0.3.4-3.3.1
  • libgrlnet-0_3-0 >= 0.3.4-3.3.1
  • libgrlpls-0_3-0 >= 0.3.4-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.4-3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-3295
SUSE Linux Enterprise Server 15 SP1-LTSS
  • grilo-devel >= 0.3.4-3.3.1
  • libgrilo-0_3-0 >= 0.3.4-3.3.1
  • libgrlnet-0_3-0 >= 0.3.4-3.3.1
  • libgrlpls-0_3-0 >= 0.3.4-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.4-3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-3295
SUSE Linux Enterprise Server 15-LTSS
  • grilo-devel >= 0.3.4-3.3.1
  • libgrilo-0_3-0 >= 0.3.4-3.3.1
  • libgrlnet-0_3-0 >= 0.3.4-3.3.1
  • libgrlpls-0_3-0 >= 0.3.4-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.4-3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-3295
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • grilo-devel >= 0.3.4-3.3.1
  • libgrilo-0_3-0 >= 0.3.4-3.3.1
  • libgrlnet-0_3-0 >= 0.3.4-3.3.1
  • libgrlpls-0_3-0 >= 0.3.4-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.4-3.3.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-3295
SUSE Linux Enterprise Server for SAP Applications 15
  • grilo-devel >= 0.3.4-3.3.1
  • libgrilo-0_3-0 >= 0.3.4-3.3.1
  • libgrlnet-0_3-0 >= 0.3.4-3.3.1
  • libgrlpls-0_3-0 >= 0.3.4-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.4-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.4-3.3.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-3295
SUSE Linux Enterprise Software Development Kit 12 SP5
  • grilo-devel >= 0.3.2-7.3.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-3003
SUSE Linux Enterprise Workstation Extension 12 SP5
  • grilo-lang >= 0.3.2-7.3.1
  • libgrlnet-0_3-0 >= 0.3.2-7.3.1
  • libgrlpls-0_3-0 >= 0.3.2-7.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.2-7.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.2-7.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.2-7.3.1
Patchnames:
SUSE-SLE-WE-12-SP5-2021-3003
SUSE Linux Enterprise Workstation Extension 15 SP2
  • grilo-lang >= 0.3.12-3.3.1
  • grilo-tools >= 0.3.12-3.3.1
Patchnames:
SUSE-SLE-Product-WE-15-SP2-2021-3194
SUSE Linux Enterprise Workstation Extension 15 SP3
  • grilo-lang >= 0.3.12-3.3.1
  • grilo-tools >= 0.3.12-3.3.1
Patchnames:
SUSE-SLE-Product-WE-15-SP3-2021-3194
openSUSE Leap 15.2
  • grilo-devel >= 0.3.12-lp152.2.3.1
  • grilo-lang >= 0.3.12-lp152.2.3.1
  • grilo-tools >= 0.3.12-lp152.2.3.1
  • libgrilo-0_3-0 >= 0.3.12-lp152.2.3.1
  • libgrlnet-0_3-0 >= 0.3.12-lp152.2.3.1
  • libgrlpls-0_3-0 >= 0.3.12-lp152.2.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.12-lp152.2.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.12-lp152.2.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.12-lp152.2.3.1
Patchnames:
openSUSE-2021-1312
openSUSE Leap 15.3
  • grilo-devel >= 0.3.12-3.3.1
  • grilo-lang >= 0.3.12-3.3.1
  • grilo-tools >= 0.3.12-3.3.1
  • libgrilo-0_3-0 >= 0.3.12-3.3.1
  • libgrlnet-0_3-0 >= 0.3.12-3.3.1
  • libgrlpls-0_3-0 >= 0.3.12-3.3.1
  • typelib-1_0-Grl-0_3 >= 0.3.12-3.3.1
  • typelib-1_0-GrlNet-0_3 >= 0.3.12-3.3.1
  • typelib-1_0-GrlPls-0_3 >= 0.3.12-3.3.1
Patchnames:
openSUSE-SLE-15.3-2021-3194
openSUSE Tumbleweed
  • grilo-devel >= 0.3.13-2.2
  • grilo-lang >= 0.3.13-2.2
  • grilo-tools >= 0.3.13-2.2
  • libgrilo-0_3-0 >= 0.3.13-2.2
  • libgrlnet-0_3-0 >= 0.3.13-2.2
  • libgrlpls-0_3-0 >= 0.3.13-2.2
  • typelib-1_0-Grl-0_3 >= 0.3.13-2.2
  • typelib-1_0-GrlNet-0_3 >= 0.3.13-2.2
  • typelib-1_0-GrlPls-0_3 >= 0.3.13-2.2
Patchnames:
openSUSE Tumbleweed GA grilo-devel-0.3.13-2.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 grilo In progress
SUSE CaaS Platform 4.0 grilo Released
SUSE Enterprise Storage 6 grilo Released
SUSE Linux Enterprise High Performance Computing 12 SP5 grilo Released
SUSE Linux Enterprise High Performance Computing 15 LTSS grilo Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS grilo Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS grilo Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 grilo Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 grilo Released
SUSE Linux Enterprise Server 12 SP3 ESPOS grilo In progress
SUSE Linux Enterprise Server 12 SP3 LTSS grilo In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS grilo In progress
SUSE Linux Enterprise Server 12 SP4 LTSS grilo In progress
SUSE Linux Enterprise Server 12 SP5 grilo Released
SUSE Linux Enterprise Server 15 ESPOS grilo Released
SUSE Linux Enterprise Server 15 LTSS grilo Released
SUSE Linux Enterprise Server 15 SP1 LTSS grilo Released
SUSE Linux Enterprise Server BCL 12 SP2 grilo In progress
SUSE Linux Enterprise Server BCL 12 SP3 grilo In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 grilo Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 grilo In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 grilo In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 grilo In progress
SUSE Linux Enterprise Server for SAP Applications 15 grilo Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 grilo Released
SUSE Linux Enterprise Software Development Kit 12 SP5 grilo Released
SUSE Linux Enterprise Workstation Extension 12 SP5 grilo Released
SUSE Linux Enterprise Workstation Extension 15 SP2 grilo Released
SUSE Linux Enterprise Workstation Extension 15 SP3 grilo Released
SUSE Manager Proxy 4.0 grilo Unsupported
SUSE Manager Retail Branch Server 4.0 grilo Unsupported
SUSE Manager Server 4.0 grilo Unsupported
SUSE OpenStack Cloud 8 grilo In progress
SUSE OpenStack Cloud 9 grilo In progress
SUSE OpenStack Cloud Crowbar 8 grilo In progress
SUSE OpenStack Cloud Crowbar 9 grilo In progress