Upstream information

CVE-2021-39359 at MITRE

Description

In GNOME libgda through 6.0.0, gda-web-provider.c does not enable TLS certificate verification on the SoupSessionSync objects it creates, leaving users vulnerable to network MITM attacks. NOTE: this is similar to CVE-2016-20011.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 7.5
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack Vector Network Network
Attack Complexity High Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1189849 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12 SP2-BCL
  • libgda-5_0-4 >= 5.2.4-9.3.1
  • libgda-5_0-mysql >= 5.2.4-9.3.1
  • libgda-5_0-postgres >= 5.2.4-9.3.1
  • libgda-5_0-sqlite >= 5.2.4-9.3.1
  • libgda-ui-5_0-4 >= 5.2.4-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2022-3016
SUSE Linux Enterprise Server 12 SP3-BCL
  • libgda-5_0-4 >= 5.2.4-9.3.1
  • libgda-5_0-mysql >= 5.2.4-9.3.1
  • libgda-5_0-postgres >= 5.2.4-9.3.1
  • libgda-5_0-sqlite >= 5.2.4-9.3.1
  • libgda-ui-5_0-4 >= 5.2.4-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2022-3016
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • libgda-5_0-4 >= 5.2.4-9.3.1
  • libgda-5_0-mysql >= 5.2.4-9.3.1
  • libgda-5_0-postgres >= 5.2.4-9.3.1
  • libgda-5_0-sqlite >= 5.2.4-9.3.1
  • libgda-ui-5_0-4 >= 5.2.4-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2022-3016
SUSE Linux Enterprise Server 12 SP4-LTSS
  • libgda-5_0-4 >= 5.2.4-9.3.1
  • libgda-5_0-mysql >= 5.2.4-9.3.1
  • libgda-5_0-postgres >= 5.2.4-9.3.1
  • libgda-5_0-sqlite >= 5.2.4-9.3.1
  • libgda-ui-5_0-4 >= 5.2.4-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2022-3016
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libgda-5_0-4 >= 5.2.4-9.3.1
  • libgda-5_0-4-lang >= 5.2.4-9.3.1
  • libgda-5_0-devel >= 5.2.4-9.3.1
  • libgda-5_0-mysql >= 5.2.4-9.3.1
  • libgda-5_0-postgres >= 5.2.4-9.3.1
  • libgda-5_0-sqlite >= 5.2.4-9.3.1
  • libgda-ui-5_0-4 >= 5.2.4-9.3.1
  • typelib-1_0-Gda-5_0 >= 5.2.4-9.3.1
  • typelib-1_0-Gdaui-5_0 >= 5.2.4-9.3.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-3016
SUSE-SLE-SERVER-12-SP5-2022-3016
SUSE-SLE-WE-12-SP5-2022-3016
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libgda-5_0-4 >= 5.2.4-9.3.1
  • libgda-5_0-mysql >= 5.2.4-9.3.1
  • libgda-5_0-postgres >= 5.2.4-9.3.1
  • libgda-5_0-sqlite >= 5.2.4-9.3.1
  • libgda-ui-5_0-4 >= 5.2.4-9.3.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2022-3016
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libgda-5_0-devel >= 5.2.4-9.3.1
  • typelib-1_0-Gda-5_0 >= 5.2.4-9.3.1
  • typelib-1_0-Gdaui-5_0 >= 5.2.4-9.3.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-3016
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libgda-5_0-4-lang >= 5.2.4-9.3.1
Patchnames:
SUSE-SLE-WE-12-SP5-2022-3016
SUSE OpenStack Cloud 9
  • libgda-5_0-4 >= 5.2.4-9.3.1
  • libgda-5_0-mysql >= 5.2.4-9.3.1
  • libgda-5_0-postgres >= 5.2.4-9.3.1
  • libgda-5_0-sqlite >= 5.2.4-9.3.1
  • libgda-ui-5_0-4 >= 5.2.4-9.3.1
Patchnames:
SUSE-OpenStack-Cloud-9-2022-3016
SUSE OpenStack Cloud Crowbar 9
  • libgda-5_0-4 >= 5.2.4-9.3.1
  • libgda-5_0-mysql >= 5.2.4-9.3.1
  • libgda-5_0-postgres >= 5.2.4-9.3.1
  • libgda-5_0-sqlite >= 5.2.4-9.3.1
  • libgda-ui-5_0-4 >= 5.2.4-9.3.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2022-3016
openSUSE Tumbleweed
  • glade-catalog-libgda >= 6.0.0-5.1
  • libgda-6_0-6_0_0 >= 6.0.0-5.1
  • libgda-6_0-6_0_0-lang >= 6.0.0-5.1
  • libgda-6_0-devel >= 6.0.0-5.1
  • libgda-6_0-doc >= 6.0.0-5.1
  • libgda-6_0-ldap >= 6.0.0-5.1
  • libgda-6_0-mysql >= 6.0.0-5.1
  • libgda-6_0-postgres >= 6.0.0-5.1
  • libgda-6_0-sqlcipher >= 6.0.0-5.1
  • libgda-6_0-sqlite >= 6.0.0-5.1
  • libgda-6_0-tools >= 6.0.0-5.1
  • libgda-report >= 6.0.0-5.1
  • libgda-report-6_0-6_0_0 >= 6.0.0-5.1
  • libgda-ui-6_0-6_0_0 >= 6.0.0-5.1
  • libgda-ui-6_0-plugins >= 6.0.0-5.1
  • libgda-ui-6_0-tools >= 6.0.0-5.1
  • libgda-xslt-6_0-6_0_0 >= 6.0.0-5.1
  • typelib-1_0-Gda-6_0 >= 6.0.0-5.1
  • typelib-1_0-Gdaui-6_0 >= 6.0.0-5.1
Patchnames:
openSUSE Tumbleweed GA glade-catalog-libgda-6.0.0-5.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 libgda Released
SUSE Linux Enterprise Server 12 SP5 libgda Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libgda Released
SUSE Linux Enterprise Software Development Kit 12 SP5 libgda Released
SUSE Linux Enterprise Workstation Extension 12 SP5 libgda Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP2-BCL libgda Released
SUSE Linux Enterprise Server 12 SP4 libgda Affected
SUSE Linux Enterprise Server 12 SP4-LTSS libgda Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libgda Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 libgda Affected
SUSE Linux Enterprise Desktop 11 SP4 libgda Not affected
SUSE Linux Enterprise Desktop 11 SP4 libgda3 Not affected
SUSE Linux Enterprise Desktop 12 SP2 libgda Affected
SUSE Linux Enterprise Desktop 12 SP3 libgda Affected
SUSE Linux Enterprise Desktop 12 SP4 libgda Affected
SUSE Linux Enterprise Point of Service 11 SP3 libgda Not affected
SUSE Linux Enterprise Point of Service 11 SP3 libgda3 Not affected
SUSE Linux Enterprise Server 11 SP1 libgda Unsupported
SUSE Linux Enterprise Server 11 SP1 libgda3 Unsupported
SUSE Linux Enterprise Server 11 SP3 libgda Unsupported
SUSE Linux Enterprise Server 11 SP3 libgda3 Unsupported
SUSE Linux Enterprise Server 11 SP3-LTSS libgda Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS libgda3 Not affected
SUSE Linux Enterprise Server 11 SP4 libgda Not affected
SUSE Linux Enterprise Server 11 SP4 libgda3 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS libgda Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS libgda3 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS libgda Unsupported
SUSE Linux Enterprise Server 11 SP4-LTSS libgda3 Unsupported
SUSE Linux Enterprise Server 12 SP2 libgda Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS libgda Affected
SUSE Linux Enterprise Server 12 SP2-LTSS libgda Affected
SUSE Linux Enterprise Server 12 SP3 libgda Affected
SUSE Linux Enterprise Server 12 SP3-BCL libgda Released
SUSE Linux Enterprise Server 12 SP3-ESPOS libgda Affected
SUSE Linux Enterprise Server 12 SP3-LTSS libgda Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS libgda Released
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 libgda Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libgda Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libgda3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libgda Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libgda Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 libgda Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 libgda3 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libgda Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libgda Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libgda Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 libgda Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 libgda Affected
SUSE Linux Enterprise Workstation Extension 12 SP4 libgda Affected
SUSE OpenStack Cloud 7 libgda Affected
SUSE OpenStack Cloud 8 libgda Affected
SUSE OpenStack Cloud 9 libgda Released
SUSE OpenStack Cloud Crowbar 8 libgda Affected
SUSE OpenStack Cloud Crowbar 9 libgda Released


SUSE Timeline for this CVE

CVE page created: Mon Aug 23 02:00:11 2021
CVE page last modified: Fri Jan 20 16:08:37 2023