Upstream information

CVE-2021-3927 at MITRE

Description

vim is vulnerable to Heap-based Buffer Overflow

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1192481 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container ses/7.1/ceph/haproxy:2.0.14.2.2.10
Container suse/sle-micro/5.2/toolbox:11.1-6.2.1
Container suse/sles/15.4/virt-launcher:0.49.0.14.2.89
Image SLES15-Azure-BYOS
Image SLES15-SAP-Azure-BYOS
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP1-Azure-BYOS
Image SLES15-SP1-Azure-HPC-BYOS
Image SLES15-SP1-SAP-Azure-BYOS
Image SLES15-SP1-SAP-Azure-LI-BYOS-Production
Image SLES15-SP1-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-BYOS-Azure
Image SLES15-SP2-HPC-BYOS-Azure
Image SLES15-SP2-Manager-4-1-Proxy-BYOS-Azure
Image SLES15-SP2-Manager-4-1-Proxy-BYOS-EC2-HVM
Image SLES15-SP2-Manager-4-1-Proxy-BYOS-GCE
Image SLES15-SP2-Manager-4-1-Server-BYOS-Azure
Image SLES15-SP2-Manager-4-1-Server-BYOS-EC2-HVM
Image SLES15-SP2-Manager-4-1-Server-BYOS-GCE
Image SLES15-SP2-SAP-Azure
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-SAP-BYOS-Azure
Image SLES15-SP3-Azure-Basic
Image SLES15-SP3-Azure-Standard
Image SLES15-SP3-BYOS-Azure
Image SLES15-SP3-BYOS-EC2-HVM
Image SLES15-SP3-BYOS-GCE
Image SLES15-SP3-CHOST-BYOS-Aliyun
Image SLES15-SP3-CHOST-BYOS-Azure
Image SLES15-SP3-CHOST-BYOS-EC2
Image SLES15-SP3-CHOST-BYOS-GCE
Image SLES15-SP3-EC2-ECS-HVM
Image SLES15-SP3-EC2-HVM
Image SLES15-SP3-GCE
Image SLES15-SP3-HPC-Azure
Image SLES15-SP3-HPC-BYOS-Azure
Image SLES15-SP3-HPC-BYOS-EC2-HVM
Image SLES15-SP3-HPC-BYOS-GCE
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-GCE
Image SLES15-SP3-Manager-4-2-Server-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Server-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Server-BYOS-GCE
Image SLES15-SP3-SAP-Azure
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-BYOS-Azure
Image SLES15-SP3-SAP-BYOS-EC2-HVM
Image SLES15-SP3-SAP-BYOS-GCE
Image SLES15-SP3-SAP-EC2-HVM
Image SLES15-SP3-SAP-GCE
Image SLES15-SP3-SAPCAL-Azure
Image SLES15-SP3-SAPCAL-EC2-HVM
Image SLES15-SP3-SAPCAL-GCE
  • vim >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Container suse/sle-micro-rancher/5.2:latest
Image SLES15-SP3-Micro-5-1-BYOS-Azure
Image SLES15-SP3-Micro-5-1-BYOS-EC2-HVM
Image SLES15-SP3-Micro-5-1-BYOS-GCE
Image SLES15-SP3-Micro-5-2-BYOS-Azure
Image SLES15-SP3-Micro-5-2-BYOS-EC2-HVM
Image SLES15-SP3-Micro-5-2-BYOS-GCE
  • vim-data-common >= 8.0.1568-5.17.1
  • vim-small >= 8.0.1568-5.17.1
SUSE CaaS Platform 4.0
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2022-736
SUSE Enterprise Storage 6
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-Storage-6-2022-736
SUSE Enterprise Storage 7
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-Storage-7-2022-736
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
  • vim-small >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-736
SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-736
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-736
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-736
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-736
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-736
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-HPC-15-2022-736
SUSE Linux Enterprise Micro 5.0
  • vim-data-common >= 8.0.1568-5.17.1
  • vim-small >= 8.0.1568-5.17.1
Patchnames:
SUSE-SUSE-MicroOS-5.0-2022-736
SUSE Linux Enterprise Micro 5.1
  • vim-data-common >= 8.0.1568-5.17.1
  • vim-small >= 8.0.1568-5.17.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2022-736
SUSE Linux Enterprise Micro 5.2
  • vim-data-common >= 8.0.1568-5.17.1
  • vim-small >= 8.0.1568-5.17.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2022-736
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
  • vim-small >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-736
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • gvim >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-736
SUSE Linux Enterprise Real Time 15 SP2
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-RT-15-SP2-2022-736
SUSE Linux Enterprise Server 15 SP1-BCL
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2022-736
SUSE Linux Enterprise Server 15 SP1-LTSS
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-736
SUSE Linux Enterprise Server 15 SP2-BCL
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-BCL-2022-736
SUSE Linux Enterprise Server 15 SP2-LTSS
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-736
SUSE Linux Enterprise Server 15-LTSS
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SLES-15-2022-736
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2022-736
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2022-736
SUSE Linux Enterprise Server for SAP Applications 15
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2022-736
SUSE Manager Proxy 4.1
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-736
SUSE Manager Retail Branch Server 4.1
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-736
SUSE Manager Server 4.1
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-736
openSUSE Leap 15.3
  • gvim >= 8.0.1568-5.17.1
  • vim >= 8.0.1568-5.17.1
  • vim-data >= 8.0.1568-5.17.1
  • vim-data-common >= 8.0.1568-5.17.1
  • vim-small >= 8.0.1568-5.17.1
Patchnames:
openSUSE-SLE-15.3-2022-736


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 vim Affected
SLES15-EC2-CHOST-HVM-BYOS vim In progress
SLES15-SP1-CHOST-BYOS-Azure vim In progress
SLES15-SP1-CHOST-BYOS-EC2 vim In progress
SLES15-SP1-CHOST-BYOS-GCE vim In progress
SLES15-SP2-CHOST-BYOS-Aliyun vim In progress
SLES15-SP2-CHOST-BYOS-Azure vim In progress
SLES15-SP2-CHOST-BYOS-EC2 vim In progress
SLES15-SP2-CHOST-BYOS-GCE vim In progress
SLES15-SP2-CHOST-BYOS-OpenStack vim In progress
SLES15-SP3-CHOST-BYOS-Aliyun vim Released
SLES15-SP3-CHOST-BYOS-Azure vim Released
SLES15-SP3-CHOST-BYOS-EC2 vim Released
SLES15-SP3-CHOST-BYOS-GCE vim Released
SUSE CaaS Platform 4.0 vim Released
SUSE CaaS Platform 4.5 vim Released
SUSE Enterprise Storage 6 vim Released
SUSE Enterprise Storage 7 vim Released
SUSE Linux Enterprise Desktop 15 SP2 vim Released
SUSE Linux Enterprise Desktop 15 SP3 vim Released
SUSE Linux Enterprise Desktop 15 SP4 vim Released
SUSE Linux Enterprise High Performance Computing 12 SP5 vim Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS vim Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS vim Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS vim Released
SUSE Linux Enterprise High Performance Computing 15 SP2 vim Released
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS vim Released
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS vim Released
SUSE Linux Enterprise High Performance Computing 15 SP3 vim Released
SUSE Linux Enterprise High Performance Computing 15 SP4 vim Released
SUSE Linux Enterprise Micro 5.0 vim Released
SUSE Linux Enterprise Micro 5.1 vim Released
SUSE Linux Enterprise Micro 5.2 vim Released
SUSE Linux Enterprise Micro for Rancher 5.2 vim Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 vim Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 vim Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 vim Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 vim Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 vim Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 vim Released
SUSE Linux Enterprise Point of Service 11 SP3 vim Affected
SUSE Linux Enterprise Real Time 15 SP2 vim Released
SUSE Linux Enterprise Server 11 SP1 vim Unsupported
SUSE Linux Enterprise Server 11 SP3 vim Affected
SUSE Linux Enterprise Server 11 SP4 LTSS vim Affected
SUSE Linux Enterprise Server 12 SP2 BCL vim Affected
SUSE Linux Enterprise Server 12 SP3 BCL vim Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS vim Affected
SUSE Linux Enterprise Server 12 SP3 LTSS vim Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS vim Affected
SUSE Linux Enterprise Server 12 SP4 LTSS vim Affected
SUSE Linux Enterprise Server 12 SP5 vim Affected
SUSE Linux Enterprise Server 15 ESPOS vim Released
SUSE Linux Enterprise Server 15 LTSS vim Released
SUSE Linux Enterprise Server 15 SP1 LTSS vim Released
SUSE Linux Enterprise Server 15 SP2 vim Released
SUSE Linux Enterprise Server 15 SP2 LTSS vim Released
SUSE Linux Enterprise Server 15 SP3 vim Released
SUSE Linux Enterprise Server 15 SP4 vim Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 vim Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 vim Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 vim Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 vim Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 vim Affected
SUSE Linux Enterprise Server for SAP Applications 15 vim Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 vim Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 vim Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 vim Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 vim Released
SUSE Linux Enterprise Storage 7 vim Released
SUSE Linux Enterprise Storage 7.1 vim Released
SUSE Manager Proxy 4.1 vim Released
SUSE Manager Proxy 4.2 vim Released
SUSE Manager Proxy 4.3 vim Released
SUSE Manager Retail Branch Server 4.1 vim Released
SUSE Manager Retail Branch Server 4.2 vim Released
SUSE Manager Retail Branch Server 4.3 vim Released
SUSE Manager Server 4.1 vim Released
SUSE Manager Server 4.2 vim Released
SUSE Manager Server 4.3 vim Released
SUSE OpenStack Cloud 8 vim Affected
SUSE OpenStack Cloud 9 vim Affected
SUSE OpenStack Cloud Crowbar 8 vim Affected
SUSE OpenStack Cloud Crowbar 9 vim Affected
ses/7.1/ceph/haproxy
suse/sle-micro/5.2/toolbox
suse/sles/15.4/virt-launcher:0.49.0
vimReleased
bci/dotnet-aspnet:5.0
bci/dotnet-runtime:5.0
bci/dotnet-sdk:5.0
suse/sle-micro/5.0/toolbox
suse/sle-micro/5.1/toolbox
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.3/virt-launcher:0.45.0
vimIn progress