Upstream information

CVE-2021-3798 at MITRE

Description

A flaw was found in openCryptoki. The openCryptoki Soft token does not check if an EC key is valid when an EC key is created via C_CreateObject, nor when C_DeriveKey is used with ECDH public data. This may allow a malicious user to extract the private key by performing an invalid curve attack.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1190527 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 openCryptoki Not affected
SUSE CaaS Platform 4.0 openCryptoki Not affected
SUSE Enterprise Storage 6 openCryptoki Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openCryptoki Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS openCryptoki Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS openCryptoki Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 openCryptoki Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP2 openCryptoki Already fixed
SUSE Linux Enterprise Point of Service 11 SP3 openCryptoki Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS openCryptoki Not affected
SUSE Linux Enterprise Server 12 SP2 BCL openCryptoki Not affected
SUSE Linux Enterprise Server 12 SP3 BCL openCryptoki Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS openCryptoki Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS openCryptoki Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS openCryptoki Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS openCryptoki Not affected
SUSE Linux Enterprise Server 12 SP5 openCryptoki Not affected
SUSE Linux Enterprise Server 15 ESPOS openCryptoki Not affected
SUSE Linux Enterprise Server 15 LTSS openCryptoki Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS openCryptoki Not affected
SUSE Linux Enterprise Server 15 SP2 openCryptoki Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 openCryptoki Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openCryptoki Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openCryptoki Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openCryptoki Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openCryptoki Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openCryptoki Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 openCryptoki Already fixed
SUSE Linux Enterprise Storage 7 openCryptoki Already fixed
SUSE Manager Proxy 4.1 openCryptoki Already fixed
SUSE Manager Retail Branch Server 4.1 openCryptoki Already fixed
SUSE Manager Server 4.1 openCryptoki Already fixed
SUSE OpenStack Cloud 8 openCryptoki Not affected
SUSE OpenStack Cloud 9 openCryptoki Not affected
SUSE OpenStack Cloud Crowbar 8 openCryptoki Not affected
SUSE OpenStack Cloud Crowbar 9 openCryptoki Not affected