Upstream information

CVE-2021-3770 at MITRE

Description

vim is vulnerable to Heap-based Buffer Overflow

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1190379 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 vim Not affected
SUSE CaaS Platform 4.0 vim Not affected
SUSE Enterprise Storage 6 vim Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 vim Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS vim Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS vim Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 vim Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 vim Not affected
SUSE Linux Enterprise Point of Service 11 SP3 vim Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS vim Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS vim Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS vim Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS vim Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS vim Not affected
SUSE Linux Enterprise Server 12 SP5 vim Not affected
SUSE Linux Enterprise Server 15 ESPOS vim Not affected
SUSE Linux Enterprise Server 15 LTSS vim Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS vim Not affected
SUSE Linux Enterprise Server BCL 12 SP2 vim Not affected
SUSE Linux Enterprise Server BCL 12 SP3 vim Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 vim Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 vim Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 vim Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 vim Not affected
SUSE Linux Enterprise Server for SAP Applications 15 vim Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 vim Not affected
SUSE OpenStack Cloud 8 vim Not affected
SUSE OpenStack Cloud 9 vim Not affected
SUSE OpenStack Cloud Crowbar 8 vim Not affected
SUSE OpenStack Cloud Crowbar 9 vim Not affected