Upstream information

CVE-2021-3711 at MITRE

Description

In order to decrypt SM2 encrypted data an application is expected to call the API function EVP_PKEY_decrypt(). Typically an application will call this function twice. The first time, on entry, the "out" parameter can be NULL and, on exit, the "outlen" parameter is populated with the buffer size required to hold the decrypted plaintext. The application can then allocate a sufficiently sized buffer and call EVP_PKEY_decrypt() again, but this time passing a non-NULL value for the "out" parameter. A bug in the implementation of the SM2 decryption code means that the calculation of the buffer size required to hold the plaintext returned by the first call to EVP_PKEY_decrypt() can be smaller than the actual size required by the second call. This can lead to a buffer overflow when EVP_PKEY_decrypt() is called by the application a second time with a buffer that is too small. A malicious attacker who is able present SM2 content for decryption to an application could cause attacker chosen data to overflow the buffer by up to a maximum of 62 bytes altering the contents of other data held after the buffer, possibly changing application behaviour or causing the application to crash. The location of the buffer is application dependent but is typically heap allocated. Fixed in OpenSSL 1.1.1l (Affected 1.1.1-1.1.1k).

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having critical severity.

CVSS v3 Scores
  SUSE
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entries: 1189520 [RESOLVED / FIXED], 1190129 [NEW], 1192100 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/golang:1.16
Container bci/golang:1.17
Container bci/init:15.3.3.1
Container bci/nodejs:12
Container bci/nodejs:14
Container bci/ruby:2.5
Container caasp/v4.5/kube-apiserver:v1.18.20
Container caasp/v4.5/kube-controller-manager:v1.18.20
Container caasp/v4.5/kube-proxy:v1.18.20
Container caasp/v4.5/kube-scheduler:v1.18.20
Container ses/7/ceph/grafana:7.5.7.3.559
Container ses/7/prometheus-webhook-snmp:1.4.1.315
Container ses/7/prometheus/prometheus-alertmanager:sle15.2.octopus
Container ses/7/prometheus/prometheus-node-exporter:sle15.2.octopus
Container ses/7/prometheus/prometheus-server:sle15.2.octopus
  • libopenssl1_1 >= 1.1.1d-11.27.1
  • libopenssl1_1-hmac >= 1.1.1d-11.27.1
Container bci/openjdk-devel:11
Container bci/openjdk:11
Container ses/7/cephcsi/cephcsi:3.3.1.0.3.670
Container suse/sle15:15.2.9.5.13
Container suse/sle15:15.3.17.5.39
  • libopenssl1_1 >= 1.1.1d-11.27.1
  • libopenssl1_1-hmac >= 1.1.1d-11.27.1
  • openssl-1_1 >= 1.1.1d-11.27.1
Image SLES15-SP2-CHOST-BYOS-Aliyun
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-GCE
Image SLES15-SP3-CHOST-BYOS-Aliyun
Image SLES15-SP3-CHOST-BYOS-Azure
Image SLES15-SP3-CHOST-BYOS-EC2
Image SLES15-SP3-CHOST-BYOS-GCE
  • libopenssl1_1 >= 1.1.1d-11.27.1
  • openssl-1_1 >= 1.1.1d-11.27.1
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libopenssl-1_1-devel >= 1.1.1d-11.27.1
  • libopenssl1_1 >= 1.1.1d-11.27.1
  • libopenssl1_1-32bit >= 1.1.1d-11.27.1
  • libopenssl1_1-hmac >= 1.1.1d-11.27.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-11.27.1
  • openssl-1_1 >= 1.1.1d-11.27.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-2830
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libopenssl-1_1-devel >= 1.1.1d-11.27.1
  • libopenssl1_1 >= 1.1.1d-11.27.1
  • libopenssl1_1-32bit >= 1.1.1d-11.27.1
  • libopenssl1_1-hmac >= 1.1.1d-11.27.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-11.27.1
  • openssl-1_1 >= 1.1.1d-11.27.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-2830
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • libopenssl1_1 >= 1.1.1d-2.36.2
  • libopenssl1_1-32bit >= 1.1.1d-2.36.2
  • openssl-1_1 >= 1.1.1d-2.36.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-2833
SUSE Linux Enterprise Server 12 SP4-LTSS
  • libopenssl1_1 >= 1.1.1d-2.36.2
  • libopenssl1_1-32bit >= 1.1.1d-2.36.2
  • openssl-1_1 >= 1.1.1d-2.36.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-2833
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libopenssl1_1 >= 1.1.1d-2.36.2
  • libopenssl1_1-32bit >= 1.1.1d-2.36.2
  • openssl-1_1 >= 1.1.1d-2.36.2
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-2833
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libopenssl1_1 >= 1.1.1d-2.36.2
  • libopenssl1_1-32bit >= 1.1.1d-2.36.2
  • openssl-1_1 >= 1.1.1d-2.36.2
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-2833
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libopenssl-1_1-devel >= 1.1.1d-2.36.2
  • libopenssl-1_1-devel-32bit >= 1.1.1d-2.36.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-2833
SUSE MicroOS 5.0
  • libopenssl1_1 >= 1.1.1d-11.27.1
  • openssl-1_1 >= 1.1.1d-11.27.1
Patchnames:
SUSE-SUSE-MicroOS-5.0-2021-2830
SUSE OpenStack Cloud 9
  • libopenssl1_1 >= 1.1.1d-2.36.2
  • libopenssl1_1-32bit >= 1.1.1d-2.36.2
  • openssl-1_1 >= 1.1.1d-2.36.2
Patchnames:
SUSE-OpenStack-Cloud-9-2021-2833
SUSE OpenStack Cloud Crowbar 9
  • libopenssl1_1 >= 1.1.1d-2.36.2
  • libopenssl1_1-32bit >= 1.1.1d-2.36.2
  • openssl-1_1 >= 1.1.1d-2.36.2
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-2833
openSUSE Leap 15.2
  • libopenssl-1_1-devel >= 1.1.1d-lp152.7.21.1
  • libopenssl-1_1-devel-32bit >= 1.1.1d-lp152.7.21.1
  • libopenssl1_1 >= 1.1.1d-lp152.7.21.1
  • libopenssl1_1-32bit >= 1.1.1d-lp152.7.21.1
  • libopenssl1_1-hmac >= 1.1.1d-lp152.7.21.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-lp152.7.21.1
  • openssl-1_1 >= 1.1.1d-lp152.7.21.1
  • openssl-1_1-doc >= 1.1.1d-lp152.7.21.1
Patchnames:
openSUSE-2021-1188
openSUSE Leap 15.3
  • libopenssl-1_1-devel >= 1.1.1d-11.27.1
  • libopenssl-1_1-devel-32bit >= 1.1.1d-11.27.1
  • libopenssl1_1 >= 1.1.1d-11.27.1
  • libopenssl1_1-32bit >= 1.1.1d-11.27.1
  • libopenssl1_1-hmac >= 1.1.1d-11.27.1
  • libopenssl1_1-hmac-32bit >= 1.1.1d-11.27.1
  • openssl-1_1 >= 1.1.1d-11.27.1
  • openssl-1_1-doc >= 1.1.1d-11.27.1
Patchnames:
openSUSE-SLE-15.3-2021-2830
openSUSE Tumbleweed
  • libopenssl-1_1-devel >= 1.1.1l-1.2
  • libopenssl-1_1-devel-32bit >= 1.1.1l-1.2
  • libopenssl1_1 >= 1.1.1l-1.2
  • libopenssl1_1-32bit >= 1.1.1l-1.2
  • libopenssl1_1-hmac >= 1.1.1l-1.2
  • openssl-1_1 >= 1.1.1l-1.2
  • openssl-1_1-doc >= 1.1.1l-1.2
Patchnames:
openSUSE Tumbleweed GA libopenssl-1_1-devel-1.1.1l-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 openssl Not affected
SLES15-EC2-CHOST-HVM-BYOS openssl Not affected
SLES15-EC2-CHOST-HVM-BYOS openssl-1_1 Not affected
SLES15-SP1-CHOST-BYOS-Azure openssl Not affected
SLES15-SP1-CHOST-BYOS-Azure openssl-1_1 Not affected
SLES15-SP1-CHOST-BYOS-EC2 openssl Not affected
SLES15-SP1-CHOST-BYOS-EC2 openssl-1_1 Not affected
SLES15-SP1-CHOST-BYOS-GCE openssl Not affected
SLES15-SP1-CHOST-BYOS-GCE openssl-1_1 Not affected
SLES15-SP2-CHOST-BYOS-Aliyun openssl Not affected
SLES15-SP2-CHOST-BYOS-Aliyun openssl-1_1 Released
SLES15-SP2-CHOST-BYOS-Azure openssl Not affected
SLES15-SP2-CHOST-BYOS-Azure openssl-1_1 Released
SLES15-SP2-CHOST-BYOS-EC2 openssl Not affected
SLES15-SP2-CHOST-BYOS-EC2 openssl-1_1 Released
SLES15-SP2-CHOST-BYOS-GCE openssl Not affected
SLES15-SP2-CHOST-BYOS-GCE openssl-1_1 Released
SLES15-SP2-CHOST-BYOS-OpenStack openssl Not affected
SLES15-SP2-CHOST-BYOS-OpenStack openssl-1_1 In progress
SLES15-SP3-CHOST-BYOS-Aliyun openssl-1_1 Released
SLES15-SP3-CHOST-BYOS-Azure openssl Not affected
SLES15-SP3-CHOST-BYOS-Azure openssl-1_1 Released
SLES15-SP3-CHOST-BYOS-EC2 openssl-1_1 Released
SLES15-SP3-CHOST-BYOS-GCE openssl-1_1 Released
SUSE CaaS Platform 4.0 openssl Not affected
SUSE CaaS Platform 4.0 openssl-1_0_0 Not affected
SUSE CaaS Platform 4.0 openssl-1_1 Not affected
SUSE CaaS Platform 4.5 openssl Not affected
SUSE CaaS Platform 4.5 openssl-1_0_0 Not affected
SUSE CaaS Platform 4.5 openssl-1_1 Released
SUSE Enterprise Storage 6 openssl Not affected
SUSE Enterprise Storage 6 openssl-1_0_0 Not affected
SUSE Enterprise Storage 6 openssl-1_1 Not affected
SUSE Enterprise Storage 7 openssl Not affected
SUSE Enterprise Storage 7 openssl-1_0_0 Not affected
SUSE Enterprise Storage 7 openssl-1_1 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 openssl Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openssl-1_1 Released
SUSE Linux Enterprise High Performance Computing 15 LTSS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS openssl-1_1 Released
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS openssl-1_1 Released
SUSE Linux Enterprise Micro 5.0 openssl Not affected
SUSE Linux Enterprise Micro 5.0 openssl-1_1 Released
SUSE Linux Enterprise Micro 5.1 openssl Not affected
SUSE Linux Enterprise Micro 5.1 openssl-1_1 Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 openssl-1_1 Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 openssl-1_1 Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 openssl Analysis
SUSE Linux Enterprise Module for Basesystem 15 SP4 openssl-1_1 Already fixed
SUSE Linux Enterprise Module for Legacy 12 compat-openssl098 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP2 openssl-1_0_0 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP3 openssl-1_0_0 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise Point of Service 11 SP3 openssl Not affected
SUSE Linux Enterprise Server 11 SP1 openssl Not affected
SUSE Linux Enterprise Server 11 SP1 openssl1 Not affected
SUSE Linux Enterprise Server 11 SP3 openssl Not affected
SUSE Linux Enterprise Server 11 SP3 openssl1 Not affected
SUSE Linux Enterprise Server 11 SP4 openssl Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP2 BCL openssl Not affected
SUSE Linux Enterprise Server 12 SP3 BCL openssl Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS openssl Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS openssl Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS openssl-1_1 Released
SUSE Linux Enterprise Server 12 SP4 LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS openssl-1_1 Released
SUSE Linux Enterprise Server 12 SP5 openssl Not affected
SUSE Linux Enterprise Server 12 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 12 SP5 openssl-1_1 Released
SUSE Linux Enterprise Server 15 ESPOS openssl Not affected
SUSE Linux Enterprise Server 15 ESPOS openssl-1_1 Not affected
SUSE Linux Enterprise Server 15 LTSS openssl Not affected
SUSE Linux Enterprise Server 15 LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 LTSS openssl-1_1 Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS openssl Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS openssl-1_1 Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS openssl Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS openssl-1_1 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 openssl Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 openssl-1_1 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 openssl Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 openssl-1_1 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssl-1_1 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssl-1_1 In progress
SUSE Linux Enterprise Server for SAP Applications 15 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openssl-1_1 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openssl-1_1 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 openssl-1_1 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 openssl-1_1 Released
SUSE Manager Proxy 4.0 openssl Not affected
SUSE Manager Proxy 4.0 openssl-1_0_0 Not affected
SUSE Manager Proxy 4.0 openssl-1_1 Not affected
SUSE Manager Proxy 4.1 openssl Not affected
SUSE Manager Proxy 4.1 openssl-1_0_0 Not affected
SUSE Manager Proxy 4.1 openssl-1_1 Released
SUSE Manager Retail Branch Server 4.0 openssl Not affected
SUSE Manager Retail Branch Server 4.0 openssl-1_0_0 Not affected
SUSE Manager Retail Branch Server 4.0 openssl-1_1 Not affected
SUSE Manager Retail Branch Server 4.1 openssl Not affected
SUSE Manager Retail Branch Server 4.1 openssl-1_0_0 Not affected
SUSE Manager Retail Branch Server 4.1 openssl-1_1 Released
SUSE Manager Server 4.0 openssl Not affected
SUSE Manager Server 4.0 openssl-1_0_0 Not affected
SUSE Manager Server 4.0 openssl-1_1 Not affected
SUSE Manager Server 4.1 openssl Not affected
SUSE Manager Server 4.1 openssl-1_0_0 Not affected
SUSE Manager Server 4.1 openssl-1_1 Released
SUSE OpenStack Cloud 8 openssl Not affected
SUSE OpenStack Cloud 9 openssl Not affected
SUSE OpenStack Cloud 9 openssl-1_0_0 Not affected
SUSE OpenStack Cloud 9 openssl-1_1 Released
SUSE OpenStack Cloud Crowbar 8 openssl Not affected
SUSE OpenStack Cloud Crowbar 9 openssl Not affected
SUSE OpenStack Cloud Crowbar 9 openssl-1_0_0 Not affected
SUSE OpenStack Cloud Crowbar 9 openssl-1_1 Released
Security Module for SUSE Linux Enterprise 11 openssl1 Not affected
suse/sles12sp4
suse/sles12sp5
openssl-1_0_0Not affected
suse/sle15:15.4 openssl-1_1Already fixed
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
suse/sle15:15.0
suse/sle15:15.1
openssl-1_1Not affected
bci/openjdk-devel:11
bci/openjdk:11
ses/7/cephcsi/cephcsi
suse/sle15:15.2
suse/sle15:15.3
openssl-1_1Released
ses/7/ceph/ceph
ses/7/ceph/grafana
ses/7/cephcsi/csi-attacher:v2.1.0
ses/7/cephcsi/csi-livenessprobe:v1.1.0
ses/7/cephcsi/csi-node-driver-registrar:v1.2.0
ses/7/cephcsi/csi-provisioner:v1.6.0
ses/7/cephcsi/csi-resizer:v0.4.0
ses/7/cephcsi/csi-snapshotter:v2.1.1
ses/7/prometheus-webhook-snmp
ses/7/rook/ceph
trento/trento-runner
openssl-1_1In progress
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
ses/7/ceph/ceph
ses/7/ceph/grafana
ses/7/cephcsi/cephcsi
ses/7/cephcsi/csi-attacher:v2.1.0
ses/7/cephcsi/csi-livenessprobe:v1.1.0
ses/7/cephcsi/csi-node-driver-registrar:v1.2.0
ses/7/cephcsi/csi-provisioner:v1.6.0
ses/7/cephcsi/csi-resizer:v0.4.0
ses/7/cephcsi/csi-snapshotter:v2.1.1
ses/7/prometheus-webhook-snmp
ses/7/rook/ceph
suse/sle15:15.0
suse/sle15:15.1
suse/sle15:15.2
suse/sles12sp3
suse/sles12sp4
suse/sles12sp5
opensslNot affected