Upstream information

CVE-2021-36770 at MITRE

Description

Encode.pm, as distributed in Perl through 5.34.0, allows local users to gain privileges via a Trojan horse Encode::ConfigLocal library (in the current working directory) that preempts dynamic module loading. Exploitation requires an unusual configuration, and certain 2021 versions of Encode.pm (3.05 through 3.11). This issue occurs because the || operator evaluates @INC in a scalar context, and thus @INC has only an integer value.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 8.4
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1188467 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 perl Not affected
SLES15-EC2-CHOST-HVM-BYOS perl Not affected
SLES15-SP1-CHOST-BYOS-Azure perl Not affected
SLES15-SP1-CHOST-BYOS-EC2 perl Not affected
SLES15-SP1-CHOST-BYOS-GCE perl Not affected
SLES15-SP2-CHOST-BYOS-Aliyun perl Not affected
SLES15-SP2-CHOST-BYOS-Azure perl Not affected
SLES15-SP2-CHOST-BYOS-EC2 perl Not affected
SLES15-SP2-CHOST-BYOS-GCE perl Not affected
SLES15-SP3-CHOST-BYOS-Aliyun perl Not affected
SLES15-SP3-CHOST-BYOS-Azure perl Not affected
SLES15-SP3-CHOST-BYOS-EC2 perl Not affected
SLES15-SP3-CHOST-BYOS-GCE perl Not affected
SLES15-SP4-CHOST-BYOS perl Not affected
SLES15-SP4-CHOST-BYOS-Aliyun perl Not affected
SLES15-SP4-CHOST-BYOS-Azure perl Not affected
SLES15-SP4-CHOST-BYOS-EC2 perl Not affected
SLES15-SP4-CHOST-BYOS-GCE perl Not affected
SUSE CaaS Platform 3.0 perl Not affected
SUSE CaaS Platform 4.0 perl Not affected
SUSE Enterprise Storage 6 perl Not affected
SUSE Enterprise Storage 7 perl Not affected
SUSE Enterprise Storage 7.1 perl Not affected
SUSE Linux Enterprise Desktop 11 SP4 perl Not affected
SUSE Linux Enterprise Desktop 12 perl Not affected
SUSE Linux Enterprise Desktop 12 SP1 perl Not affected
SUSE Linux Enterprise Desktop 12 SP2 perl Not affected
SUSE Linux Enterprise Desktop 12 SP3 perl Not affected
SUSE Linux Enterprise Desktop 12 SP4 perl Not affected
SUSE Linux Enterprise Desktop 15 perl Not affected
SUSE Linux Enterprise Desktop 15 SP1 perl Not affected
SUSE Linux Enterprise Desktop 15 SP2 perl Not affected
SUSE Linux Enterprise Desktop 15 SP3 perl Not affected
SUSE Linux Enterprise Desktop 15 SP4 perl Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 perl Not affected
SUSE Linux Enterprise High Performance Computing 15 perl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 perl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS perl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS perl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 perl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS perl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS perl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 perl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 perl Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS perl Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS perl Not affected
SUSE Linux Enterprise Micro 5.0 perl Not affected
SUSE Linux Enterprise Micro 5.1 perl Not affected
SUSE Linux Enterprise Micro 5.2 perl Not affected
SUSE Linux Enterprise Micro 5.3 perl Not affected
SUSE Linux Enterprise Module for Basesystem 15 perl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 perl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 perl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 perl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 perl Not affected
SUSE Linux Enterprise Module for Development Tools 15 perl Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 perl Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 perl Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 perl Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 perl Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP1 perl Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 perl Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 perl Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 perl Not affected
SUSE Linux Enterprise Point of Service 11 SP3 perl Not affected
SUSE Linux Enterprise Real Time 15 SP2 perl Not affected
SUSE Linux Enterprise Real Time 15 SP3 perl Not affected
SUSE Linux Enterprise Server 11 SP1 perl Not affected
SUSE Linux Enterprise Server 11 SP3 perl Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS perl Not affected
SUSE Linux Enterprise Server 11 SP4 perl Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS perl Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS perl Not affected
SUSE Linux Enterprise Server 12 perl Not affected
SUSE Linux Enterprise Server 12 SP1 perl Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS perl Not affected
SUSE Linux Enterprise Server 12 SP2 perl Not affected
SUSE Linux Enterprise Server 12 SP2-BCL perl Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS perl Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS perl Not affected
SUSE Linux Enterprise Server 12 SP3 perl Not affected
SUSE Linux Enterprise Server 12 SP3-BCL perl Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS perl Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS perl Not affected
SUSE Linux Enterprise Server 12 SP4 perl Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS perl Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS perl Not affected
SUSE Linux Enterprise Server 12 SP5 perl Not affected
SUSE Linux Enterprise Server 12-LTSS perl Not affected
SUSE Linux Enterprise Server 15 perl Not affected
SUSE Linux Enterprise Server 15 SP1 perl Not affected
SUSE Linux Enterprise Server 15 SP1-BCL perl Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS perl Not affected
SUSE Linux Enterprise Server 15 SP2 perl Not affected
SUSE Linux Enterprise Server 15 SP2-BCL perl Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS perl Not affected
SUSE Linux Enterprise Server 15 SP3 perl Not affected
SUSE Linux Enterprise Server 15 SP4 perl Not affected
SUSE Linux Enterprise Server 15-ESPOS perl Not affected
SUSE Linux Enterprise Server 15-LTSS perl Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 perl Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 perl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 perl Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 perl Not affected
SUSE Manager Proxy 4.0 perl Not affected
SUSE Manager Proxy 4.1 perl Not affected
SUSE Manager Proxy 4.2 perl Not affected
SUSE Manager Proxy 4.3 perl Not affected
SUSE Manager Retail Branch Server 4.0 perl Not affected
SUSE Manager Retail Branch Server 4.1 perl Not affected
SUSE Manager Retail Branch Server 4.2 perl Not affected
SUSE Manager Retail Branch Server 4.3 perl Not affected
SUSE Manager Server 4.0 perl Not affected
SUSE Manager Server 4.1 perl Not affected
SUSE Manager Server 4.2 perl Not affected
SUSE Manager Server 4.3 perl Not affected
SUSE OpenStack Cloud 7 perl Not affected
SUSE OpenStack Cloud 8 perl Not affected
SUSE OpenStack Cloud 9 perl Not affected
SUSE OpenStack Cloud Crowbar 8 perl Not affected
SUSE OpenStack Cloud Crowbar 9 perl Not affected
bci/dotnet-aspnet:5.0
bci/dotnet-runtime:5.0
bci/dotnet-sdk:5.0
ses/7.1/ceph/haproxy
ses/7.1/ceph/keepalived
suse/pcp
suse/registry
suse/rmt-mariadb
suse/rmt-mariadb:10.6
suse/rmt-nginx
suse/rmt-nginx:1.21
suse/sle-micro/5.0/toolbox
suse/sle-micro/5.1/toolbox
suse/sle-micro/5.2/toolbox
suse/sle-micro/5.3/toolbox
suse/sle-micro/5.4/toolbox
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.3/libguestfs-tools:0.45.0
suse/sles/15.3/virt-launcher:0.45.0
suse/sles/15.4/libguestfs-tools:0.49.0
suse/sles/15.4/virt-launcher:0.49.0
perlNot affected


SUSE Timeline for this CVE

CVE page created: Mon Jul 19 15:34:05 2021
CVE page last modified: Thu Dec 1 00:12:40 2022