Upstream information

CVE-2021-3583 at MITRE

Description

A flaw was found in Ansible, where a user's controller is vulnerable to template injection. This issue can occur through facts used in the template if the user is trying to put templates in multi-line YAML strings and the facts being handled do not routinely include special template characters. This flaw allows attackers to perform command injection, which discloses sensitive information. The highest threat from this vulnerability is to confidentiality and integrity.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 6.6
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1188061 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • ansible >= 2.9.24-1.2
  • ansible-doc >= 2.9.24-1.2
  • ansible-test >= 2.9.24-1.2
Patchnames:
openSUSE Tumbleweed GA ansible-2.9.24-1.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 ansible Affected
HPE Helion OpenStack 8 ansible1 Not affected
SUSE Linux Enterprise Server 11 SP3 ansible Analysis
SUSE Manager Client Tools Beta for SLE 15 ansible Affected
SUSE Manager Client Tools for SLE 15 ansible Affected
SUSE Manager Proxy Module 4.2 ansible Analysis
SUSE OpenStack Cloud 7 ansible Not affected
SUSE OpenStack Cloud 8 ansible Affected
SUSE OpenStack Cloud 8 ansible1 Not affected
SUSE OpenStack Cloud 9 ansible1 Not affected
SUSE OpenStack Cloud Crowbar 8 ansible Affected