Upstream information

CVE-2021-3572 at MITRE

Description

A flaw was found in python-pip in the way it handled Unicode separators in git references. A remote attacker could possibly use this issue to install a different revision on a repository. The highest threat from this vulnerability is to data integrity. This is fixed in python-pip version 21.1.

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 4.5
Vector CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:N
Access Vector Network
Access Complexity Low
Privileges Required High
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1186819 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • python-pip >= 9.0.1-3.6.1
Patchnames:
HPE-Helion-OpenStack-8-2021-2441
SUSE OpenStack Cloud 8
  • python-pip >= 9.0.1-3.6.1
Patchnames:
SUSE-OpenStack-Cloud-8-2021-2441
SUSE OpenStack Cloud 9
  • python-pip >= 9.0.1-4.6.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-2304
SUSE OpenStack Cloud Crowbar 8
  • python-pip >= 9.0.1-3.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-2441
SUSE OpenStack Cloud Crowbar 9
  • python-pip >= 9.0.1-4.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-2304


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 python-pip Released
SUSE CaaS Platform 4.0 python-pip Affected
SUSE Enterprise Storage 6 python-pip Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 python36-pip Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS python-pip Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS python-pip Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS python-pip Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 python-pip Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 python-pip Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 python39-pip Affected
SUSE Linux Enterprise Module for Public Cloud 12 python-pip Affected
SUSE Linux Enterprise Module for Python 2 15 SP2 python-pip Affected
SUSE Linux Enterprise Module for Python 2 15 SP3 python-pip Affected
SUSE Linux Enterprise Server 11 SP1 python27-pip Analysis
SUSE Linux Enterprise Server 11 SP3 python-pip Analysis
SUSE Linux Enterprise Server 11 SP3 python27-pip Analysis
SUSE Linux Enterprise Server 12 SP5 python36-pip Affected
SUSE Linux Enterprise Server 15 ESPOS python-pip Affected
SUSE Linux Enterprise Server 15 LTSS python-pip Affected
SUSE Linux Enterprise Server 15 SP1 LTSS python-pip Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 python-pip Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python36-pip Affected
SUSE Linux Enterprise Server for SAP Applications 15 python-pip Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python-pip Affected
SUSE Manager Proxy 4.0 python-pip Unsupported
SUSE Manager Retail Branch Server 4.0 python-pip Unsupported
SUSE Manager Server 4.0 python-pip Unsupported
SUSE OpenStack Cloud 7 python-pip Unsupported
SUSE OpenStack Cloud 8 python-pip Released
SUSE OpenStack Cloud 9 python-pip Released
SUSE OpenStack Cloud Crowbar 8 python-pip Released
SUSE OpenStack Cloud Crowbar 9 python-pip Released