Upstream information

CVE-2021-3549 at MITRE

Description

An out of bounds flaw was found in GNU binutils objdump utility version 2.36. An attacker could use this flaw and pass a large section to avr_elf32_load_records_from_section() probably resulting in a crash or in some cases memory corruption. The highest threat from this vulnerability is to integrity as well as system availability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:N/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.1 7
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low High
Privileges Required None Low
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1186116 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Carwos 1 binutils Not affected
HPE Helion OpenStack 8 binutils Not affected
SUSE CaaS Platform 4.0 binutils Not affected
SUSE Enterprise Storage 6 binutils Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 binutils Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS binutils Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS binutils Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 binutils Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 binutils Not affected
SUSE Linux Enterprise Point of Service 11 SP3 binutils Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS binutils Not affected
SUSE Linux Enterprise Server 12 SP2 BCL binutils Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON binutils Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS SAP binutils Not affected
SUSE Linux Enterprise Server 12 SP3 BCL binutils Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS binutils Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS binutils Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS binutils Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS binutils Not affected
SUSE Linux Enterprise Server 12 SP5 binutils Not affected
SUSE Linux Enterprise Server 15 LTSS binutils Not affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux binutils Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS binutils Not affected
SUSE Linux Enterprise Server ESPOS 15 binutils Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 binutils Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 binutils Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 binutils Not affected
SUSE Linux Enterprise Server for SAP Applications 15 binutils Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 binutils Not affected
SUSE Manager Proxy 4.0 binutils Not affected
SUSE Manager Retail Branch Server 4.0 binutils Not affected
SUSE Manager Server 4.0 binutils Not affected
SUSE OpenStack Cloud 8 binutils Not affected
SUSE OpenStack Cloud 9 binutils Not affected
SUSE OpenStack Cloud Crowbar 8 binutils Not affected
SUSE OpenStack Cloud Crowbar 9 binutils Not affected