Upstream information

CVE-2021-3504 at MITRE

Description

A flaw was found in the hivex library in versions before 1.3.20. It is caused due to a lack of bounds check within the hivex_open function. An attacker could input a specially crafted Windows Registry (hive) file which would cause hivex to read memory beyond its normal bounds or cause the program to crash. The highest threat from this vulnerability is to system availability.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.4 5.4
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1185013 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • hivex-devel >= 1.3.14-5.3.1
  • libhivex0 >= 1.3.14-5.3.1
  • perl-Win-Hivex >= 1.3.14-5.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-1761
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • hivex-devel >= 1.3.14-5.3.1
  • libhivex0 >= 1.3.14-5.3.1
  • perl-Win-Hivex >= 1.3.14-5.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-1761
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • ocaml-hivex >= 1.3.14-5.3.1
  • ocaml-hivex-devel >= 1.3.14-5.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2021-1761
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • ocaml-hivex >= 1.3.14-5.3.1
  • ocaml-hivex-devel >= 1.3.14-5.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2021-1761
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • hivex >= 1.3.14-5.3.1
  • hivex-lang >= 1.3.14-5.3.1
  • python-hivex >= 1.3.14-5.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1761
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • hivex >= 1.3.14-5.3.1
  • hivex-lang >= 1.3.14-5.3.1
  • python-hivex >= 1.3.14-5.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-1761
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libhivex0 >= 1.3.10-5.3.1
  • perl-Win-Hivex >= 1.3.10-5.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-1760
SUSE Linux Enterprise Software Development Kit 12 SP5
  • hivex-devel >= 1.3.10-5.3.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-1760
SUSE MicroOS 5.0
  • libhivex0 >= 1.3.14-5.3.1
  • perl-Win-Hivex >= 1.3.14-5.3.1
Patchnames:
SUSE-SUSE-MicroOS-5.0-2021-1761
openSUSE Leap 15.2
  • hivex >= 1.3.14-lp152.4.3.1
  • hivex-debuginfo >= 1.3.14-lp152.4.3.1
  • hivex-debugsource >= 1.3.14-lp152.4.3.1
  • hivex-devel >= 1.3.14-lp152.4.3.1
  • hivex-lang >= 1.3.14-lp152.4.3.1
  • libhivex0 >= 1.3.14-lp152.4.3.1
  • libhivex0-debuginfo >= 1.3.14-lp152.4.3.1
  • ocaml-hivex >= 1.3.14-lp152.4.3.1
  • ocaml-hivex-debuginfo >= 1.3.14-lp152.4.3.1
  • ocaml-hivex-devel >= 1.3.14-lp152.4.3.1
  • perl-Win-Hivex >= 1.3.14-lp152.4.3.1
  • perl-Win-Hivex-debuginfo >= 1.3.14-lp152.4.3.1
  • python-hivex >= 1.3.14-lp152.4.3.1
  • python-hivex-debuginfo >= 1.3.14-lp152.4.3.1
Patchnames:
openSUSE-2021-806
openSUSE Leap 15.3
  • hivex >= 1.3.14-5.3.1
  • hivex-devel >= 1.3.14-5.3.1
  • hivex-lang >= 1.3.14-5.3.1
  • libhivex0 >= 1.3.14-5.3.1
  • ocaml-hivex >= 1.3.14-5.3.1
  • ocaml-hivex-devel >= 1.3.14-5.3.1
  • perl-Win-Hivex >= 1.3.14-5.3.1
  • python-hivex >= 1.3.14-5.3.1
Patchnames:
openSUSE-SLE-15.3-2021-1761


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 hivex Affected
SUSE CaaS Platform 4.0 hivex Affected
SUSE Enterprise Storage 6 hivex Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 hivex Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS hivex Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS hivex Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 hivex Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 hivex Affected
SUSE Linux Enterprise Server 12 SP2 BCL hivex Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON hivex Affected
SUSE Linux Enterprise Server 12 SP2 LTSS SAP hivex Affected
SUSE Linux Enterprise Server 12 SP3 BCL hivex Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS hivex Affected
SUSE Linux Enterprise Server 12 SP3 LTSS hivex Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS hivex Affected
SUSE Linux Enterprise Server 12 SP4 LTSS hivex Affected
SUSE Linux Enterprise Server 12 SP5 hivex Affected
SUSE Linux Enterprise Server 15 LTSS hivex Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux hivex Affected
SUSE Linux Enterprise Server 15 SP1 LTSS hivex Affected
SUSE Linux Enterprise Server ESPOS 15 hivex Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 hivex Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 hivex Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 hivex Affected
SUSE Linux Enterprise Server for SAP Applications 15 hivex Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 hivex Affected
SUSE Manager Proxy 4.0 hivex Affected
SUSE Manager Retail Branch Server 4.0 hivex Affected
SUSE Manager Server 4.0 hivex Affected
SUSE OpenStack Cloud 8 hivex Affected
SUSE OpenStack Cloud 9 hivex Affected
SUSE OpenStack Cloud Crowbar 8 hivex Affected
SUSE OpenStack Cloud Crowbar 9 hivex Affected