Upstream information

CVE-2021-3468 at MITRE

Description

A flaw was found in avahi in versions 0.6 up to 0.8. The event used to signal the termination of the client connection on the avahi Unix socket is not correctly handled in the client_work function, allowing a local attacker to trigger an infinite loop. The highest threat from this vulnerability is to the availability of the avahi service, which becomes unresponsive after this flaw is triggered.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 6.2
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1184521 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
HPE-Helion-OpenStack-8-2021-1494
Image SLES15-SP2-CHOST-BYOS-Aliyun
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-GCE
Image SLES15-SP3-CHOST-BYOS-Aliyun
Image SLES15-SP3-CHOST-BYOS-Azure
Image SLES15-SP3-CHOST-BYOS-EC2
Image SLES15-SP3-CHOST-BYOS-GCE
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
SUSE CaaS Platform 4.0
  • avahi >= 0.7-3.9.1
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-1493
SUSE Enterprise Storage 6
  • avahi >= 0.7-3.9.1
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-Storage-6-2021-1493
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • avahi >= 0.7-3.9.1
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-1493
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • avahi >= 0.7-3.9.1
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-1493
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • avahi >= 0.6.32-5.13.1
  • avahi-autoipd >= 0.6.32-5.13.1
  • avahi-compat-howl-devel >= 0.6.32-5.13.1
  • avahi-compat-mDNSResponder-devel >= 0.6.32-5.13.1
  • avahi-lang >= 0.6.32-5.13.1
  • avahi-utils >= 0.6.32-5.13.1
  • avahi-utils-gtk >= 0.6.32-5.13.1
  • libavahi-client3 >= 0.6.32-5.13.1
  • libavahi-client3-32bit >= 0.6.32-5.13.1
  • libavahi-common3 >= 0.6.32-5.13.1
  • libavahi-common3-32bit >= 0.6.32-5.13.1
  • libavahi-core7 >= 0.6.32-5.13.1
  • libavahi-devel >= 0.6.32-5.13.1
  • libavahi-glib-devel >= 0.6.32-5.13.1
  • libavahi-glib1 >= 0.6.32-5.13.1
  • libavahi-gobject-devel >= 0.6.32-5.13.1
  • libavahi-gobject0 >= 0.6.32-5.13.1
  • libavahi-ui-gtk3-0 >= 0.6.32-5.13.1
  • libavahi-ui0 >= 0.6.32-5.13.1
  • libdns_sd >= 0.6.32-5.13.1
  • libhowl0 >= 0.6.32-5.13.1
  • typelib-1_0-Avahi-0_6 >= 0.6.32-5.13.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-1845
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • avahi >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-1493
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • avahi >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-1493
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-1493
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2021-1493
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • libavahi-glib1-32bit >= 0.7-3.9.1
  • libdns_sd-32bit >= 0.7-3.9.1
  • python-avahi >= 0.6.32-5.13.1
  • python-avahi-gtk >= 0.6.32-5.13.1
  • python3-avahi >= 0.7-3.9.1
  • python3-avahi-gtk >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1493
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1845
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • libavahi-glib1-32bit >= 0.7-3.9.1
  • libdns_sd-32bit >= 0.7-3.9.1
  • python-avahi >= 0.6.32-5.13.1
  • python-avahi-gtk >= 0.6.32-5.13.1
  • python3-avahi >= 0.7-3.9.1
  • python3-avahi-gtk >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-1493
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-1845
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
  • python3-avahi >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2021-1493
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • python3-avahi >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2021-1493
SUSE Linux Enterprise Server 12 SP2-BCL
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2021-1494
SUSE Linux Enterprise Server 12 SP3-BCL
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2021-1494
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2021-1494
SUSE Linux Enterprise Server 12 SP3-LTSS
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2021-1494
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-1494
SUSE Linux Enterprise Server 12 SP4-LTSS
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-1494
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-1494
SUSE Linux Enterprise Server 15 SP1-BCL
  • avahi >= 0.7-3.9.1
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-1493
SUSE Linux Enterprise Server 15 SP1-LTSS
  • avahi >= 0.7-3.9.1
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-1493
SUSE Linux Enterprise Server 15-LTSS
  • avahi >= 0.6.32-5.13.1
  • avahi-autoipd >= 0.6.32-5.13.1
  • avahi-compat-howl-devel >= 0.6.32-5.13.1
  • avahi-compat-mDNSResponder-devel >= 0.6.32-5.13.1
  • avahi-lang >= 0.6.32-5.13.1
  • avahi-utils >= 0.6.32-5.13.1
  • avahi-utils-gtk >= 0.6.32-5.13.1
  • libavahi-client3 >= 0.6.32-5.13.1
  • libavahi-client3-32bit >= 0.6.32-5.13.1
  • libavahi-common3 >= 0.6.32-5.13.1
  • libavahi-common3-32bit >= 0.6.32-5.13.1
  • libavahi-core7 >= 0.6.32-5.13.1
  • libavahi-devel >= 0.6.32-5.13.1
  • libavahi-glib-devel >= 0.6.32-5.13.1
  • libavahi-glib1 >= 0.6.32-5.13.1
  • libavahi-gobject-devel >= 0.6.32-5.13.1
  • libavahi-gobject0 >= 0.6.32-5.13.1
  • libavahi-ui-gtk3-0 >= 0.6.32-5.13.1
  • libavahi-ui0 >= 0.6.32-5.13.1
  • libdns_sd >= 0.6.32-5.13.1
  • libhowl0 >= 0.6.32-5.13.1
  • typelib-1_0-Avahi-0_6 >= 0.6.32-5.13.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-1845
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2021-1494
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-1494
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • avahi >= 0.7-3.9.1
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-1493
SUSE Linux Enterprise Server for SAP Applications 15
  • avahi >= 0.6.32-5.13.1
  • avahi-autoipd >= 0.6.32-5.13.1
  • avahi-compat-howl-devel >= 0.6.32-5.13.1
  • avahi-compat-mDNSResponder-devel >= 0.6.32-5.13.1
  • avahi-lang >= 0.6.32-5.13.1
  • avahi-utils >= 0.6.32-5.13.1
  • avahi-utils-gtk >= 0.6.32-5.13.1
  • libavahi-client3 >= 0.6.32-5.13.1
  • libavahi-client3-32bit >= 0.6.32-5.13.1
  • libavahi-common3 >= 0.6.32-5.13.1
  • libavahi-common3-32bit >= 0.6.32-5.13.1
  • libavahi-core7 >= 0.6.32-5.13.1
  • libavahi-devel >= 0.6.32-5.13.1
  • libavahi-glib-devel >= 0.6.32-5.13.1
  • libavahi-glib1 >= 0.6.32-5.13.1
  • libavahi-gobject-devel >= 0.6.32-5.13.1
  • libavahi-gobject0 >= 0.6.32-5.13.1
  • libavahi-ui-gtk3-0 >= 0.6.32-5.13.1
  • libavahi-ui0 >= 0.6.32-5.13.1
  • libdns_sd >= 0.6.32-5.13.1
  • libhowl0 >= 0.6.32-5.13.1
  • typelib-1_0-Avahi-0_6 >= 0.6.32-5.13.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-1845
SUSE Linux Enterprise Software Development Kit 12 SP5
  • avahi-compat-howl-devel >= 0.6.32-32.15.1
  • avahi-compat-mDNSResponder-devel >= 0.6.32-32.15.1
  • libavahi-devel >= 0.6.32-32.15.1
  • libavahi-glib-devel >= 0.6.32-32.15.1
  • libavahi-gobject-devel >= 0.6.32-32.15.1
  • libavahi-gobject0 >= 0.6.32-32.15.1
  • libavahi-ui-gtk3-0 >= 0.6.32-32.15.1
  • libavahi-ui0 >= 0.6.32-32.15.1
  • libhowl0 >= 0.6.32-32.15.1
  • python-avahi >= 0.6.32-32.15.1
  • typelib-1_0-Avahi-0_6 >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-1494
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libavahi-gobject0 >= 0.6.32-32.15.1
  • libavahi-ui-gtk3-0 >= 0.6.32-32.15.1
  • libavahi-ui0 >= 0.6.32-32.15.1
Patchnames:
SUSE-SLE-WE-12-SP5-2021-1494
SUSE Manager Proxy 4.0
  • avahi >= 0.7-3.9.1
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-1493
SUSE Manager Retail Branch Server 4.0
  • avahi >= 0.7-3.9.1
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-1493
SUSE Manager Server 4.0
  • avahi >= 0.7-3.9.1
  • avahi-autoipd >= 0.7-3.9.1
  • avahi-compat-howl-devel >= 0.7-3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-3.9.1
  • avahi-lang >= 0.7-3.9.1
  • avahi-utils >= 0.7-3.9.1
  • avahi-utils-gtk >= 0.7-3.9.1
  • libavahi-client3 >= 0.7-3.9.1
  • libavahi-client3-32bit >= 0.7-3.9.1
  • libavahi-common3 >= 0.7-3.9.1
  • libavahi-common3-32bit >= 0.7-3.9.1
  • libavahi-core7 >= 0.7-3.9.1
  • libavahi-devel >= 0.7-3.9.1
  • libavahi-glib-devel >= 0.7-3.9.1
  • libavahi-glib1 >= 0.7-3.9.1
  • libavahi-gobject-devel >= 0.7-3.9.1
  • libavahi-gobject0 >= 0.7-3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-3.9.1
  • libavahi-ui0 >= 0.7-3.9.1
  • libdns_sd >= 0.7-3.9.1
  • libhowl0 >= 0.7-3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-3.9.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-1493
SUSE OpenStack Cloud 8
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-OpenStack-Cloud-8-2021-1494
SUSE OpenStack Cloud 9
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-1494
SUSE OpenStack Cloud Crowbar 8
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-1494
SUSE OpenStack Cloud Crowbar 9
  • avahi >= 0.6.32-32.15.1
  • avahi-lang >= 0.6.32-32.15.1
  • avahi-utils >= 0.6.32-32.15.1
  • libavahi-client3 >= 0.6.32-32.15.1
  • libavahi-client3-32bit >= 0.6.32-32.15.1
  • libavahi-common3 >= 0.6.32-32.15.1
  • libavahi-common3-32bit >= 0.6.32-32.15.1
  • libavahi-core7 >= 0.6.32-32.15.1
  • libavahi-glib1 >= 0.6.32-32.15.1
  • libavahi-glib1-32bit >= 0.6.32-32.15.1
  • libdns_sd >= 0.6.32-32.15.1
  • libdns_sd-32bit >= 0.6.32-32.15.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-1494
openSUSE Leap 15.2
  • avahi >= 0.7-lp152.3.9.1
  • avahi-32bit-debuginfo >= 0.7-lp152.3.9.1
  • avahi-autoipd >= 0.7-lp152.3.9.1
  • avahi-autoipd-debuginfo >= 0.7-lp152.3.9.1
  • avahi-compat-howl-devel >= 0.7-lp152.3.9.1
  • avahi-compat-mDNSResponder-devel >= 0.7-lp152.3.9.1
  • avahi-debuginfo >= 0.7-lp152.3.9.1
  • avahi-debugsource >= 0.7-lp152.3.9.1
  • avahi-glib2-debugsource >= 0.7-lp152.3.9.1
  • avahi-lang >= 0.7-lp152.3.9.1
  • avahi-mono >= 0.7-lp152.3.9.1
  • avahi-qt4-debugsource >= 0.7-lp152.3.9.1
  • avahi-utils >= 0.7-lp152.3.9.1
  • avahi-utils-debuginfo >= 0.7-lp152.3.9.1
  • avahi-utils-gtk >= 0.7-lp152.3.9.1
  • avahi-utils-gtk-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-client3 >= 0.7-lp152.3.9.1
  • libavahi-client3-32bit >= 0.7-lp152.3.9.1
  • libavahi-client3-32bit-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-client3-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-common3 >= 0.7-lp152.3.9.1
  • libavahi-common3-32bit >= 0.7-lp152.3.9.1
  • libavahi-common3-32bit-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-common3-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-core7 >= 0.7-lp152.3.9.1
  • libavahi-core7-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-devel >= 0.7-lp152.3.9.1
  • libavahi-glib-devel >= 0.7-lp152.3.9.1
  • libavahi-glib1 >= 0.7-lp152.3.9.1
  • libavahi-glib1-32bit >= 0.7-lp152.3.9.1
  • libavahi-glib1-32bit-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-glib1-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-gobject-devel >= 0.7-lp152.3.9.1
  • libavahi-gobject0 >= 0.7-lp152.3.9.1
  • libavahi-gobject0-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-qt4-1 >= 0.7-lp152.3.9.1
  • libavahi-qt4-1-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-qt4-devel >= 0.7-lp152.3.9.1
  • libavahi-ui-gtk3-0 >= 0.7-lp152.3.9.1
  • libavahi-ui-gtk3-0-debuginfo >= 0.7-lp152.3.9.1
  • libavahi-ui0 >= 0.7-lp152.3.9.1
  • libavahi-ui0-debuginfo >= 0.7-lp152.3.9.1
  • libdns_sd >= 0.7-lp152.3.9.1
  • libdns_sd-32bit >= 0.7-lp152.3.9.1
  • libdns_sd-32bit-debuginfo >= 0.7-lp152.3.9.1
  • libdns_sd-debuginfo >= 0.7-lp152.3.9.1
  • libhowl0 >= 0.7-lp152.3.9.1
  • libhowl0-debuginfo >= 0.7-lp152.3.9.1
  • python3-avahi >= 0.7-lp152.3.9.1
  • python3-avahi-gtk >= 0.7-lp152.3.9.1
  • typelib-1_0-Avahi-0_6 >= 0.7-lp152.3.9.1
Patchnames:
openSUSE-2021-694
openSUSE Leap 15.3
  • python-avahi >= 0.6.32-5.13.1
  • python-avahi-gtk >= 0.6.32-5.13.1
Patchnames:
openSUSE-SLE-15.3-2021-1845


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 avahi Released
SUSE CaaS Platform 4.0 avahi Released
SUSE Enterprise Storage 6 avahi Released
SUSE Linux Enterprise High Performance Computing 12 SP5 avahi Released
SUSE Linux Enterprise High Performance Computing 15 LTSS avahi In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS avahi Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS avahi Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 avahi Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 avahi Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 avahi Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 avahi Released
SUSE Linux Enterprise Point of Service 11 SP3 avahi In progress
SUSE Linux Enterprise Point of Service Image Server 12 avahi Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS avahi In progress
SUSE Linux Enterprise Server 12 SP2 BCL avahi Released
SUSE Linux Enterprise Server 12 SP2 ESPOS avahi Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS avahi Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON avahi Released
SUSE Linux Enterprise Server 12 SP2 LTSS SAP avahi Released
SUSE Linux Enterprise Server 12 SP3 BCL avahi Released
SUSE Linux Enterprise Server 12 SP3 ESPOS avahi Released
SUSE Linux Enterprise Server 12 SP3 LTSS avahi Released
SUSE Linux Enterprise Server 12 SP4 ESPOS avahi Released
SUSE Linux Enterprise Server 12 SP4 LTSS avahi Released
SUSE Linux Enterprise Server 12 SP5 avahi Released
SUSE Linux Enterprise Server 15 LTSS avahi In progress
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux avahi Released
SUSE Linux Enterprise Server 15 SP1 LTSS avahi Released
SUSE Linux Enterprise Server ESPOS 15 avahi In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 avahi Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 avahi Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 avahi Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 avahi Released
SUSE Linux Enterprise Server for SAP Applications 15 avahi Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 avahi Released
SUSE Linux Enterprise Software Development Kit 12 SP5 avahi Released
SUSE Manager Proxy 4.0 avahi Released
SUSE Manager Retail Branch Server 4.0 avahi Released
SUSE Manager Server 4.0 avahi Released
SUSE OpenStack Cloud 7 avahi Affected
SUSE OpenStack Cloud 8 avahi Released
SUSE OpenStack Cloud 9 avahi Released
SUSE OpenStack Cloud Crowbar 8 avahi Released
SUSE OpenStack Cloud Crowbar 9 avahi Released
SUSE Package Hub 15 avahi Released