Upstream information

CVE-2021-3421 at MITRE

Description

A flaw was found in the RPM package in the read functionality. This flaw allows an attacker who can convince a victim to install a seemingly verifiable package or compromise an RPM repository, to cause RPM database corruption. The highest threat from this vulnerability is to data integrity. This flaw affects RPM versions before 4.17.0-alpha.

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 5.3
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
Access Vector Local Network
Access Complexity Low High
Privileges Required None Low
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1183543 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/sle15:15.2
Image caasp45/caasp-389-ds-image
Image caasp45/caasp-busybox-image
Image caasp45/caasp-caasp-dex-image
Image caasp45/caasp-cert-manager-cainjector-image
Image caasp45/caasp-cert-manager-controller-image
Image caasp45/caasp-cert-manager-webhook-image
Image caasp45/caasp-cilium-etcd-operator-image
Image caasp45/caasp-cilium-image
Image caasp45/caasp-cilium-operator-image
Image caasp45/caasp-configmap-reload-image
Image caasp45/caasp-coredns-image
Image caasp45/caasp-curl-image
Image caasp45/caasp-default-http-backend-image
Image caasp45/caasp-etcd-image
Image caasp45/caasp-gangway-image
Image caasp45/caasp-grafana-image
Image caasp45/caasp-helm-tiller-image
Image caasp45/caasp-ingress-nginx-controller-image
Image caasp45/caasp-istio-base-image
Image caasp45/caasp-istio-pilot-image
Image caasp45/caasp-istio-proxyv2-image
Image caasp45/caasp-k8s-sidecar-image
Image caasp45/caasp-kube-apiserver-image
Image caasp45/caasp-kube-controller-manager-image
Image caasp45/caasp-kube-proxy-image
Image caasp45/caasp-kube-scheduler-image
Image caasp45/caasp-kube-state-metrics-image
Image caasp45/caasp-kubernetes-client-image
Image caasp45/caasp-kucero-image
Image caasp45/caasp-kured-image
Image caasp45/caasp-metrics-server-image
Image caasp45/caasp-prometheus-alertmanager-image
Image caasp45/caasp-prometheus-node-exporter-image
Image caasp45/caasp-prometheus-pushgateway-image
Image caasp45/caasp-prometheus-server-image
Image caasp45/caasp-reloader-image
Image caasp45/caasp-rsyslog-image
Image caasp45/caasp-skuba-tooling-image
Image caasp45/caasp-velero-image
Image caasp45/caasp-velero-plugin-for-aws-image
Image caasp45/caasp-velero-plugin-for-gcp-image
Image caasp45/caasp-velero-plugin-for-microsoft-azure-image
Image caasp45/caasp-velero-restic-restore-helper-image
  • rpm >= 4.14.1-22.4.2
Container suse/sle15:15.3
Image SLES15-SP3-CHOST-BYOS-Aliyun
Image SLES15-SP3-CHOST-BYOS-Azure
Image SLES15-SP3-CHOST-BYOS-EC2
Image SLES15-SP3-CHOST-BYOS-GCE
  • rpm-ndb >= 4.14.3-37.2
Image SLES15-SP2-CHOST-BYOS-Aliyun
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-GCE
  • rpm-ndb >= 4.14.1-22.4.2
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • python3-rpm >= 4.14.1-22.4.1
  • rpm >= 4.14.1-22.4.2
  • rpm-32bit >= 4.14.1-22.4.2
  • rpm-devel >= 4.14.1-22.4.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-3444
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • python3-rpm >= 4.14.3-37.2
  • rpm >= 4.14.3-37.2
  • rpm-32bit >= 4.14.3-37.2
  • rpm-devel >= 4.14.3-37.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-2682
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • rpm-build >= 4.14.1-22.4.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2021-3444
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • rpm-build >= 4.14.3-37.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2021-2682
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • rpm-ndb-32bit >= 4.14.1-22.4.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-3444
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • hawkey-man >= 0.62.0-5.3.1
  • libdnf-devel >= 0.62.0-5.3.1
  • libdnf-repo-config-zypp >= 0.62.0-5.3.1
  • libdnf2 >= 0.62.0-5.3.1
  • python3-hawkey >= 0.62.0-5.3.1
  • python3-libdnf >= 0.62.0-5.3.1
  • rpm-ndb-32bit >= 4.14.3-37.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-2682
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-2685
SUSE Linux Enterprise Module for Public Cloud 15 SP2
  • rpm-ndb >= 4.14.1-22.4.2
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP2-2021-3444
SUSE Linux Enterprise Module for Public Cloud 15 SP3
  • rpm-ndb >= 4.14.3-37.2
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP3-2021-2682
SUSE Linux Enterprise Module for Python 2 15 SP2
  • python2-rpm >= 4.14.1-22.4.1
Patchnames:
SUSE-SLE-Module-Python2-15-SP2-2021-3444
SUSE Linux Enterprise Module for Python 2 15 SP3
  • python2-rpm >= 4.14.3-37.2
Patchnames:
SUSE-SLE-Module-Python2-15-SP3-2021-2682
SUSE Linux Enterprise Module for SUSE Manager Proxy 4.1
  • rpm-build >= 4.14.1-22.4.2
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Proxy-4.1-2021-3444
SUSE Linux Enterprise Module for SUSE Manager Proxy 4.2
  • rpm-build >= 4.14.3-37.2
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Proxy-4.2-2021-2682
SUSE Linux Enterprise Module for SUSE Manager Server 4.1
  • rpm-build >= 4.14.1-22.4.2
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.1-2021-3444
SUSE Linux Enterprise Module for SUSE Manager Server 4.2
  • rpm-build >= 4.14.3-37.2
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.2-2021-2682
SUSE MicroOS 5.0
  • python3-rpm >= 4.14.1-22.4.1
  • rpm >= 4.14.1-22.4.2
Patchnames:
SUSE-SUSE-MicroOS-5.0-2021-3444
openSUSE Leap 15.2
  • python2-rpm >= 4.14.1-lp152.18.3.1
  • python3-rpm >= 4.14.1-lp152.18.3.1
  • rpm >= 4.14.1-lp152.18.3.1
  • rpm-32bit >= 4.14.1-lp152.18.3.1
  • rpm-build >= 4.14.1-lp152.18.3.1
  • rpm-devel >= 4.14.1-lp152.18.3.1
Patchnames:
openSUSE-2021-1366
openSUSE Leap 15.3
  • hawkey-man >= 0.62.0-5.3.1
  • libdnf-devel >= 0.62.0-5.3.1
  • libdnf-repo-config-zypp >= 0.62.0-5.3.1
  • libdnf2 >= 0.62.0-5.3.1
  • python2-rpm >= 4.14.3-37.2
  • python3-hawkey >= 0.62.0-5.3.1
  • python3-libdnf >= 0.62.0-5.3.1
  • python3-rpm >= 4.14.3-37.2
  • rpm >= 4.14.3-37.2
  • rpm-32bit >= 4.14.3-37.2
  • rpm-build >= 4.14.3-37.2
  • rpm-devel >= 4.14.3-37.2
  • rpm-ndb >= 4.14.3-37.2
  • rpm-ndb-32bit >= 4.14.3-37.2
Patchnames:
openSUSE-SLE-15.3-2021-2682
openSUSE-SLE-15.3-2021-2685
openSUSE Tumbleweed
  • librpmbuild9 >= 4.16.1.3-3.2
  • rpm >= 4.16.1.3-3.2
  • rpm-32bit >= 4.16.1.3-3.2
  • rpm-build >= 4.16.1.3-3.2
  • rpm-build-perl >= 4.16.1.3-3.2
  • rpm-build-python >= 4.16.1.3-3.2
  • rpm-devel >= 4.16.1.3-3.2
Patchnames:
openSUSE Tumbleweed GA librpmbuild9-4.16.1.3-3.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 rpm Affected
SLES-LTSS-SAP rpm Affected
SUSE CaaS Platform 4.0 rpm Affected
SUSE Enterprise Storage 6 rpm Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 rpm Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS rpm Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS rpm Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS rpm Affected
SUSE Linux Enterprise Micro 5.0 rpm Released
SUSE Linux Enterprise Micro 5.1 rpm Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 rpm Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 rpm Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 rpm Released
SUSE Linux Enterprise Module for Development Tools 15 SP3 rpm Released
SUSE Linux Enterprise Point of Service 11 SP3 rpm Affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 rpm Affected
SUSE Linux Enterprise Server 11 SP1 rpm Analysis
SUSE Linux Enterprise Server 11 SP3 rpm Analysis
SUSE Linux Enterprise Server 11 SP4 rpm Analysis
SUSE Linux Enterprise Server 11 SP4 LTSS rpm Affected
SUSE Linux Enterprise Server 12 SP2 ESPOS rpm Affected
SUSE Linux Enterprise Server 12 SP2 LTSS rpm Unsupported
SUSE Linux Enterprise Server 12 SP3 ESPOS rpm Affected
SUSE Linux Enterprise Server 12 SP3 LTSS rpm Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS rpm Affected
SUSE Linux Enterprise Server 12 SP4 LTSS rpm Affected
SUSE Linux Enterprise Server 12 SP5 rpm Affected
SUSE Linux Enterprise Server 15 ESPOS rpm Affected
SUSE Linux Enterprise Server 15 LTSS rpm Affected
SUSE Linux Enterprise Server 15 SP1 LTSS rpm Affected
SUSE Linux Enterprise Server BCL 12 SP2 rpm Affected
SUSE Linux Enterprise Server BCL 12 SP3 rpm Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 rpm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 rpm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 rpm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 rpm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 rpm Affected
SUSE Linux Enterprise Server for SAP Applications 15 rpm Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 rpm Affected
SUSE Manager Proxy 4.0 rpm Unsupported
SUSE Manager Proxy Module 4.0 rpm Unsupported
SUSE Manager Proxy Module 4.1 rpm Released
SUSE Manager Proxy Module 4.2 rpm Released
SUSE Manager Retail Branch Server 4.0 rpm Unsupported
SUSE Manager Server 4.0 rpm Unsupported
SUSE Manager Server Module 4.0 rpm Unsupported
SUSE Manager Server Module 4.1 rpm Released
SUSE Manager Server Module 4.2 rpm Released
SUSE OpenStack Cloud 7 rpm Unsupported
SUSE OpenStack Cloud 8 rpm Affected
SUSE OpenStack Cloud 9 rpm Affected
SUSE OpenStack Cloud Crowbar 8 rpm Affected
SUSE OpenStack Cloud Crowbar 9 rpm Affected