Upstream information

CVE-2021-3409 at MITRE

Description

The patch for CVE-2020-17380/CVE-2020-25085 was found to be ineffective, thus making QEMU vulnerable to the out-of-bounds read/write access issues previously found in the SDHCI controller emulation code. This flaw allows a malicious privileged guest to crash the QEMU process on the host, resulting in a denial of service or potential code execution. QEMU up to (including) 5.2.0 is affected by this.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.7 5.7
Vector CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required High High
User Interaction None None
Scope Changed Changed
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1182282 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • qemu-tools >= 5.2.0-17.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-1942
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • qemu-arm >= 5.2.0-17.1
  • qemu-audio-alsa >= 5.2.0-17.1
  • qemu-audio-pa >= 5.2.0-17.1
  • qemu-audio-spice >= 5.2.0-17.1
  • qemu-block-dmg >= 5.2.0-17.1
  • qemu-block-gluster >= 5.2.0-17.1
  • qemu-block-nfs >= 5.2.0-17.1
  • qemu-chardev-spice >= 5.2.0-17.1
  • qemu-extra >= 5.2.0-17.1
  • qemu-hw-display-qxl >= 5.2.0-17.1
  • qemu-hw-display-virtio-gpu >= 5.2.0-17.1
  • qemu-hw-display-virtio-gpu-pci >= 5.2.0-17.1
  • qemu-hw-display-virtio-vga >= 5.2.0-17.1
  • qemu-hw-s390x-virtio-gpu-ccw >= 5.2.0-17.1
  • qemu-hw-usb-redirect >= 5.2.0-17.1
  • qemu-hw-usb-smartcard >= 5.2.0-17.1
  • qemu-ivshmem-tools >= 5.2.0-17.1
  • qemu-linux-user >= 5.2.0-17.1
  • qemu-microvm >= 5.2.0-17.1
  • qemu-ppc >= 5.2.0-17.1
  • qemu-s390x >= 5.2.0-17.1
  • qemu-seabios >= 1.14.0_0_g155821a-17.1
  • qemu-sgabios >= 8-17.1
  • qemu-skiboot >= 5.2.0-17.1
  • qemu-testsuite >= 5.2.0-17.2
  • qemu-ui-gtk >= 5.2.0-17.1
  • qemu-ui-opengl >= 5.2.0-17.1
  • qemu-ui-spice-app >= 5.2.0-17.1
  • qemu-ui-spice-core >= 5.2.0-17.1
  • qemu-vgabios >= 1.14.0_0_g155821a-17.1
  • qemu-vhost-user-gpu >= 5.2.0-17.1
  • qemu-x86 >= 5.2.0-17.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-1942
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • qemu >= 5.2.0-17.1
  • qemu-arm >= 5.2.0-17.1
  • qemu-audio-alsa >= 5.2.0-17.1
  • qemu-audio-pa >= 5.2.0-17.1
  • qemu-audio-spice >= 5.2.0-17.1
  • qemu-block-curl >= 5.2.0-17.1
  • qemu-block-iscsi >= 5.2.0-17.1
  • qemu-block-rbd >= 5.2.0-17.1
  • qemu-block-ssh >= 5.2.0-17.1
  • qemu-chardev-baum >= 5.2.0-17.1
  • qemu-chardev-spice >= 5.2.0-17.1
  • qemu-guest-agent >= 5.2.0-17.1
  • qemu-hw-display-qxl >= 5.2.0-17.1
  • qemu-hw-display-virtio-gpu >= 5.2.0-17.1
  • qemu-hw-display-virtio-gpu-pci >= 5.2.0-17.1
  • qemu-hw-display-virtio-vga >= 5.2.0-17.1
  • qemu-hw-s390x-virtio-gpu-ccw >= 5.2.0-17.1
  • qemu-hw-usb-redirect >= 5.2.0-17.1
  • qemu-ipxe >= 1.0.0+-17.1
  • qemu-ksm >= 5.2.0-17.1
  • qemu-kvm >= 5.2.0-17.1
  • qemu-lang >= 5.2.0-17.1
  • qemu-ppc >= 5.2.0-17.1
  • qemu-s390x >= 5.2.0-17.1
  • qemu-seabios >= 1.14.0_0_g155821a-17.1
  • qemu-sgabios >= 8-17.1
  • qemu-skiboot >= 5.2.0-17.1
  • qemu-ui-curses >= 5.2.0-17.1
  • qemu-ui-gtk >= 5.2.0-17.1
  • qemu-ui-opengl >= 5.2.0-17.1
  • qemu-ui-spice-app >= 5.2.0-17.1
  • qemu-ui-spice-core >= 5.2.0-17.1
  • qemu-vgabios >= 1.14.0_0_g155821a-17.1
  • qemu-x86 >= 5.2.0-17.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP3-2021-1942
openSUSE Leap 15.3
  • qemu >= 5.2.0-17.1
  • qemu-arm >= 5.2.0-17.1
  • qemu-audio-alsa >= 5.2.0-17.1
  • qemu-audio-pa >= 5.2.0-17.1
  • qemu-audio-spice >= 5.2.0-17.1
  • qemu-block-curl >= 5.2.0-17.1
  • qemu-block-dmg >= 5.2.0-17.1
  • qemu-block-gluster >= 5.2.0-17.1
  • qemu-block-iscsi >= 5.2.0-17.1
  • qemu-block-nfs >= 5.2.0-17.1
  • qemu-block-rbd >= 5.2.0-17.1
  • qemu-block-ssh >= 5.2.0-17.1
  • qemu-chardev-baum >= 5.2.0-17.1
  • qemu-chardev-spice >= 5.2.0-17.1
  • qemu-extra >= 5.2.0-17.1
  • qemu-guest-agent >= 5.2.0-17.1
  • qemu-hw-display-qxl >= 5.2.0-17.1
  • qemu-hw-display-virtio-gpu >= 5.2.0-17.1
  • qemu-hw-display-virtio-gpu-pci >= 5.2.0-17.1
  • qemu-hw-display-virtio-vga >= 5.2.0-17.1
  • qemu-hw-s390x-virtio-gpu-ccw >= 5.2.0-17.1
  • qemu-hw-usb-redirect >= 5.2.0-17.1
  • qemu-hw-usb-smartcard >= 5.2.0-17.1
  • qemu-ipxe >= 1.0.0+-17.1
  • qemu-ivshmem-tools >= 5.2.0-17.1
  • qemu-ksm >= 5.2.0-17.1
  • qemu-kvm >= 5.2.0-17.1
  • qemu-lang >= 5.2.0-17.1
  • qemu-microvm >= 5.2.0-17.1
  • qemu-ppc >= 5.2.0-17.1
  • qemu-s390x >= 5.2.0-17.1
  • qemu-seabios >= 1.14.0_0_g155821a-17.1
  • qemu-sgabios >= 8-17.1
  • qemu-skiboot >= 5.2.0-17.1
  • qemu-tools >= 5.2.0-17.1
  • qemu-ui-curses >= 5.2.0-17.1
  • qemu-ui-gtk >= 5.2.0-17.1
  • qemu-ui-opengl >= 5.2.0-17.1
  • qemu-ui-spice-app >= 5.2.0-17.1
  • qemu-ui-spice-core >= 5.2.0-17.1
  • qemu-vgabios >= 1.14.0_0_g155821a-17.1
  • qemu-vhost-user-gpu >= 5.2.0-17.1
  • qemu-x86 >= 5.2.0-17.1
Patchnames:
openSUSE-SLE-15.3-2021-1942


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 qemu Affected
HPE Helion OpenStack 8 xen Not affected
SUSE CaaS Platform 4.0 qemu Affected
SUSE CaaS Platform 4.0 xen Not affected
SUSE Enterprise Storage 6 qemu Affected
SUSE Enterprise Storage 6 xen Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 qemu Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 xen Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS qemu Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS xen Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS qemu Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS xen Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 qemu Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP1 xen Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 qemu Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 xen Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 qemu Released
SUSE Linux Enterprise Module for Server Applications 15 SP1 qemu Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP1 xen Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP2 qemu Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 xen Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 qemu Released
SUSE Linux Enterprise Point of Service 11 SP3 kvm Not affected
SUSE Linux Enterprise Point of Service 11 SP3 qemu Not affected
SUSE Linux Enterprise Point of Service 11 SP3 xen Not affected
SUSE Linux Enterprise Point of Service Image Server 12 qemu Unsupported
SUSE Linux Enterprise Point of Service Image Server 12 xen Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS kvm Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS xen Not affected
SUSE Linux Enterprise Server 12 SP2 BCL qemu Affected
SUSE Linux Enterprise Server 12 SP2 BCL xen Not affected
SUSE Linux Enterprise Server 12 SP2 ESPOS qemu Unsupported
SUSE Linux Enterprise Server 12 SP2 ESPOS xen Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS qemu Affected
SUSE Linux Enterprise Server 12 SP2 LTSS xen Not affected
SUSE Linux Enterprise Server 12 SP3 BCL qemu Affected
SUSE Linux Enterprise Server 12 SP3 BCL xen Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS qemu Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS xen Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS qemu Affected
SUSE Linux Enterprise Server 12 SP3 LTSS xen Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS qemu Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS xen Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS qemu Affected
SUSE Linux Enterprise Server 12 SP4 LTSS xen Not affected
SUSE Linux Enterprise Server 12 SP5 qemu Affected
SUSE Linux Enterprise Server 12 SP5 xen Not affected
SUSE Linux Enterprise Server 15 LTSS qemu Affected
SUSE Linux Enterprise Server 15 LTSS xen Not affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux qemu Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux xen Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS qemu Affected
SUSE Linux Enterprise Server 15 SP1 LTSS xen Not affected
SUSE Linux Enterprise Server ESPOS 15 qemu Affected
SUSE Linux Enterprise Server ESPOS 15 xen Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 qemu Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 xen Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 qemu Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 xen Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 qemu Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 xen Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 qemu Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 xen Not affected
SUSE Linux Enterprise Server for SAP Applications 15 qemu Affected
SUSE Linux Enterprise Server for SAP Applications 15 xen Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 qemu Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 xen Not affected
SUSE Manager Proxy 4.0 qemu Affected
SUSE Manager Proxy 4.0 xen Not affected
SUSE Manager Retail Branch Server 4.0 qemu Affected
SUSE Manager Retail Branch Server 4.0 xen Not affected
SUSE Manager Server 4.0 qemu Affected
SUSE Manager Server 4.0 xen Not affected
SUSE OpenStack Cloud 7 qemu Affected
SUSE OpenStack Cloud 7 xen Not affected
SUSE OpenStack Cloud 8 qemu Affected
SUSE OpenStack Cloud 8 xen Not affected
SUSE OpenStack Cloud 9 qemu Affected
SUSE OpenStack Cloud 9 xen Not affected
SUSE OpenStack Cloud Crowbar 8 qemu Affected
SUSE OpenStack Cloud Crowbar 8 xen Not affected
SUSE OpenStack Cloud Crowbar 9 qemu Affected
SUSE OpenStack Cloud Crowbar 9 xen Not affected